aboutsummaryrefslogtreecommitdiff
path: root/graphics/ecore-evas
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-06-26 17:36:30 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-06-26 17:36:30 +0000
commitb9eaf394330b28c95aff1aed37c4e9c7269123a4 (patch)
treec7d813040107a076d3b35f3a2eefbed1462e4ed4 /graphics/ecore-evas
parent2cce93719ddda5af2198b65d659b27535350e329 (diff)
Notes
Diffstat (limited to 'graphics/ecore-evas')
-rw-r--r--graphics/ecore-evas/Makefile20
-rw-r--r--graphics/ecore-evas/distinfo4
-rw-r--r--graphics/ecore-evas/pkg-descr2
-rw-r--r--graphics/ecore-evas/pkg-plist2
4 files changed, 10 insertions, 18 deletions
diff --git a/graphics/ecore-evas/Makefile b/graphics/ecore-evas/Makefile
index e22e21c312a5..4107f2948a8b 100644
--- a/graphics/ecore-evas/Makefile
+++ b/graphics/ecore-evas/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= evas
-DISTVERSION= 1.0.1
+DISTVERSION= 1.1.0
CATEGORIES= graphics enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-05-25/base/
+ http://files.roorback.net/e17/2011-12-02/base/
PKGNAMEPREFIX= ecore-
DISTNAME= ecore-${DISTVERSION}
@@ -17,11 +17,12 @@ MAINTAINER= magik@roorback.net
COMMENT= Enlightenment core abstraction library (evas module)
LICENSE= BSD
+
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_EFL= evas ecore libtool_hack
-USE_EFL_ECORE= input input_evas sdl
+USE_EFL_ECORE= input input_evas
USE_GNOME= gnomehack pkgconfig
USE_LDCONFIG= yes
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_evas
@@ -35,7 +36,6 @@ CONFIGURE_ARGS+= --enable-ecore-evas \
OPTIONS= X11 "Enable Evas X11 support" on \
GL "Enable Evas GL support" on \
- XRENDER "Enable Evas Xrender support" on \
BUFFER "Enable Evas Buffer support" on \
SDL "Enable Evas SDL support" off
@@ -49,15 +49,7 @@ WITH_X= yes
CONFIGURE_ARGS+= --disable-ecore-evas-opengl-x11
.endif
-.if !defined(WITHOUT_XRENDER)
-CONFIGURE_ARGS+= --enable-ecore-evas-xrender-x11
-USE_EFL_EVAS_ENGINES+= xrender
-WITH_X= yes
-.else
-CONFIGURE_ARGS+= --disable-ecore-evas-xrender-x11
-.endif
-
-.if !defined(WITHOUT_X11) || defined(WITH_X)
+.if !defined(WITHOUT_X11)
CONFIGURE_ARGS+= --enable-ecore-x
USE_EFL_ECORE+= x11
USE_EFL_EVAS_ENGINES+= x11
@@ -77,7 +69,7 @@ CONFIGURE_ARGS+= --enable-ecore-evas-software-sdl --enable-ecore-sdl
USE_EFL_EVAS_ENGINES+= sdl
USE_EFL_ECORE+= sdl
.else
-CONFIGURE_ARGS+= --disable-ecore-evas-software-sdl --enable-ecore-sdl
+CONFIGURE_ARGS+= --disable-ecore-evas-software-sdl --disable-ecore-sdl
.endif
post-patch:
diff --git a/graphics/ecore-evas/distinfo b/graphics/ecore-evas/distinfo
index 1b6a301ea5d5..30f1faeb45b9 100644
--- a/graphics/ecore-evas/distinfo
+++ b/graphics/ecore-evas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e17/ecore-1.0.1.tar.bz2) = 66d6c08fa2690b7fe0dc11fedfd08c442d8e1b9a5ea16724053c0f7dd625f366
-SIZE (e17/ecore-1.0.1.tar.bz2) = 903399
+SHA256 (e17/ecore-1.1.0.tar.bz2) = c701a31941e178babad577ede886a98cf472352e5a73ee4717c0ffdc980152cc
+SIZE (e17/ecore-1.1.0.tar.bz2) = 3217298
diff --git a/graphics/ecore-evas/pkg-descr b/graphics/ecore-evas/pkg-descr
index 2559668d0e57..de0d636325d6 100644
--- a/graphics/ecore-evas/pkg-descr
+++ b/graphics/ecore-evas/pkg-descr
@@ -2,4 +2,4 @@ A core event abstracter layer and X abstraction layer that makes doing
selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
fast, optimised, and convenient.
-WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
+WWW: http://docs.enlightenment.org/auto/ecore/
diff --git a/graphics/ecore-evas/pkg-plist b/graphics/ecore-evas/pkg-plist
index eddc4ed4a8db..fd77c7cfb3c6 100644
--- a/graphics/ecore-evas/pkg-plist
+++ b/graphics/ecore-evas/pkg-plist
@@ -1,4 +1,4 @@
include/ecore-1/Ecore_Evas.h
lib/libecore_evas.so
-lib/libecore_evas.so.1
+lib/libecore_evas.so.2
libdata/pkgconfig/ecore-evas.pc