aboutsummaryrefslogtreecommitdiff
path: root/graphics/edje
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-06-26 17:36:30 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-06-26 17:36:30 +0000
commitb9eaf394330b28c95aff1aed37c4e9c7269123a4 (patch)
treec7d813040107a076d3b35f3a2eefbed1462e4ed4 /graphics/edje
parent2cce93719ddda5af2198b65d659b27535350e329 (diff)
downloadports-b9eaf394330b28c95aff1aed37c4e9c7269123a4.tar.gz
ports-b9eaf394330b28c95aff1aed37c4e9c7269123a4.zip
Notes
Diffstat (limited to 'graphics/edje')
-rw-r--r--graphics/edje/Makefile19
-rw-r--r--graphics/edje/distinfo4
-rw-r--r--graphics/edje/pkg-plist34
3 files changed, 50 insertions, 7 deletions
diff --git a/graphics/edje/Makefile b/graphics/edje/Makefile
index 16f408c5460a..114adb74909a 100644
--- a/graphics/edje/Makefile
+++ b/graphics/edje/Makefile
@@ -6,20 +6,20 @@
#
PORTNAME= edje
-DISTVERSION= 1.0.1
-PORTREVISION= 1
+DISTVERSION= 1.1.0
PORTEPOCH= 2
CATEGORIES= graphics enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-05-25/base/
+ http://files.roorback.net/e17/2011-12-02/base/
MAINTAINER= magik@roorback.net
COMMENT= Edje is a complex graphical design and layout engine
+LICENSE= BSD
+
LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua
RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
-LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -31,11 +31,22 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS+= --without-vim
+.if !defined(NOPORTEXAMPLES)
+CONFIGURE_ARGS+= --enable-install-examples
+.else
+CONFIGURE_ARGS+= --disable-install-examples
+.endif
+
post-patch:
@${REINPLACE_CMD} -E -e "/^SUBDIRS[[:space:]]+=/s/utils//" \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|= \$$(datadir)/\$$(PACKAGE)/examples|= $$(datadir)/examples/$$(PACKAGE)|' \
+ ${WRKSRC}/src/examples/Makefile.in
post-install:
-update-mime-database ${PREFIX}/share/mime
+.if defined(NOPORTEXAMPLES)
+ @${RMDIR} ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>
diff --git a/graphics/edje/distinfo b/graphics/edje/distinfo
index e214cc2a467f..dda48025142e 100644
--- a/graphics/edje/distinfo
+++ b/graphics/edje/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e17/edje-1.0.1.tar.bz2) = b688a9c0a43acef0f55306e106a53e7cec5b2e773a14c2aac02a8c4b8d1c3377
-SIZE (e17/edje-1.0.1.tar.bz2) = 584395
+SHA256 (e17/edje-1.1.0.tar.bz2) = c662a65897a985b08a3f63a41672e33e20de4c53657859742ab66024977641bd
+SIZE (e17/edje-1.1.0.tar.bz2) = 933474
diff --git a/graphics/edje/pkg-plist b/graphics/edje/pkg-plist
index c73bf2e006d5..65ee429eabdc 100644
--- a/graphics/edje/pkg-plist
+++ b/graphics/edje/pkg-plist
@@ -7,14 +7,46 @@ bin/edje_player
include/edje-1/Edje.h
include/edje-1/Edje_Edit.h
lib/libedje.so
-lib/libedje.so.1
+lib/libedje.so.2
+lib/edje/utils/epp
libdata/pkgconfig/edje.pc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Vera.ttf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animations.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/box.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bubble.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/color-class.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drag.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-animations.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-basic.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-box.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-box2.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-color-class.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-drag.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-perspective.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-signals-messages.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-swallow.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-table.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edje-text.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lua_script.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/perspective.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/red.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/signals-messages.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sigtest.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sigtest.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/swallow.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/table.edc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text.edc
%%DATADIR%%/include/edje.inc
share/mime/packages/edje.xml
@dirrmtry share/mime/packages
@dirrmtry share/mime
+@dirrm lib/edje/utils
+@dirrm lib/edje
@dirrm include/edje-1
@dirrm %%DATADIR%%/include
@dirrm %%DATADIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime