aboutsummaryrefslogtreecommitdiff
path: root/graphics/edje
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /graphics/edje
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'graphics/edje')
-rw-r--r--graphics/edje/Makefile29
-rw-r--r--graphics/edje/distinfo5
-rw-r--r--graphics/edje/files/patch-src_lib_edje_private.h11
-rw-r--r--graphics/edje/pkg-descr2
-rw-r--r--graphics/edje/pkg-plist13
5 files changed, 36 insertions, 24 deletions
diff --git a/graphics/edje/Makefile b/graphics/edje/Makefile
index a048d160c51a..ec5f0ca675cc 100644
--- a/graphics/edje/Makefile
+++ b/graphics/edje/Makefile
@@ -6,30 +6,27 @@
#
PORTNAME= edje
-PORTVERSION= 0.5.0.042
-PORTREVISION= 3
+DISTVERSION= 1.0.0.beta
PORTEPOCH= 2
-CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+CATEGORIES= graphics enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
MAINTAINER= stas@FreeBSD.org
COMMENT= Edje is a complex graphical design and layout engine
-GNU_CONFIGURE= yes
+LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua
+
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= eet evas ecore embryo libtool_hack librt_hack
+USE_EFL_EVAS_LOADERS= eet jpeg png
+USE_EFL_ECORE= evas file imf imf_evas
USE_GNOME= gnomehack pkgconfig gnometarget
-USE_EFL= embryo eet evas ecore imlib2
-USE_EFL_ECORE= evas job
-USE_EVAS_LOADERS= edb eet jpeg png
USE_LDCONFIG= yes
CONFIGURE_ARGS+= --without-vim
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64"
-BROKEN= edje is broken on ia64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/edje/distinfo b/graphics/edje/distinfo
index ae788d7305fa..45b52db1fb2e 100644
--- a/graphics/edje/distinfo
+++ b/graphics/edje/distinfo
@@ -1,3 +1,2 @@
-MD5 (edje-0.5.0.042.tar.bz2) = fc95528409351acea7a48862331eaffd
-SHA256 (edje-0.5.0.042.tar.bz2) = 352f1a9d600e85cddd9e5dbf6becad87f4be49a15b7e87f46e011c9d48e50af2
-SIZE (edje-0.5.0.042.tar.bz2) = 2819823
+SHA256 (e17/edje-1.0.0.beta.tar.bz2) = 7d7949b13209f517b452187b641940f5027e4d2619d8b20378f52a5e66c04952
+SIZE (e17/edje-1.0.0.beta.tar.bz2) = 600360
diff --git a/graphics/edje/files/patch-src_lib_edje_private.h b/graphics/edje/files/patch-src_lib_edje_private.h
new file mode 100644
index 000000000000..a95da457f57c
--- /dev/null
+++ b/graphics/edje/files/patch-src_lib_edje_private.h
@@ -0,0 +1,11 @@
+--- src/lib/edje_private.h.orig 2010-12-11 00:51:59.000000000 -0800
++++ src/lib/edje_private.h 2010-12-11 00:52:57.000000000 -0800
+@@ -11,6 +11,8 @@
+
+ #ifdef HAVE_ALLOCA_H
+ # include <alloca.h>
++#elif defined __FreeBSD__
++# include <stdlib.h>
+ #elif defined __GNUC__
+ # define alloca __builtin_alloca
+ #elif defined _AIX
diff --git a/graphics/edje/pkg-descr b/graphics/edje/pkg-descr
index 7db97f52810d..c6e5a3e9811e 100644
--- a/graphics/edje/pkg-descr
+++ b/graphics/edje/pkg-descr
@@ -13,4 +13,4 @@ elements. Anything more complex is likely the domain of an application
or widget set that may use Edje as a conveneient way of being able to
configure parts of the display.
-WWW: http://enlightenment.sourceforge.net/Libraries/Edje/
+WWW: http://docs.enlightenment.org/auto/edje/
diff --git a/graphics/edje/pkg-plist b/graphics/edje/pkg-plist
index d2264d98c8b9..3a36bdb52547 100644
--- a/graphics/edje/pkg-plist
+++ b/graphics/edje/pkg-plist
@@ -1,12 +1,17 @@
bin/edje_cc
+bin/edje_convert
bin/edje_decc
bin/edje_recc
-include/Edje.h
-lib/libedje.a
-lib/libedje.la
+bin/edje_player
+include/edje-1/Edje.h
+include/edje-1/Edje_Edit.h
lib/libedje.so
-lib/libedje.so.5
+lib/libedje.so.1
libdata/pkgconfig/edje.pc
%%DATADIR%%/include/edje.inc
+share/mime/packages/edje.xml
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@dirrm include/edje-1
@dirrm %%DATADIR%%/include
@dirrm %%DATADIR%%