aboutsummaryrefslogtreecommitdiff
path: root/graphics/electriceyes
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-03-09 01:13:40 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-03-09 01:13:40 +0000
commitf4442a7aa7d134c8de8574845b26edddcac65935 (patch)
tree0f55c576fb88ce09083373c32ab8312529d29dc5 /graphics/electriceyes
parentf642b1eef53afa46d333b0f0cb5bf670d5bd8df1 (diff)
downloadports-f4442a7aa7d134c8de8574845b26edddcac65935.tar.gz
ports-f4442a7aa7d134c8de8574845b26edddcac65935.zip
Notes
Diffstat (limited to 'graphics/electriceyes')
-rw-r--r--graphics/electriceyes/Makefile6
-rw-r--r--graphics/electriceyes/files/patch-aa54
2 files changed, 27 insertions, 33 deletions
diff --git a/graphics/electriceyes/Makefile b/graphics/electriceyes/Makefile
index 02b4c011e6f6..ba5b6688ecb0 100644
--- a/graphics/electriceyes/Makefile
+++ b/graphics/electriceyes/Makefile
@@ -3,14 +3,14 @@
# Date created: 21 August 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.10 1999/01/31 20:52:33 vanilla Exp $
+# $Id: Makefile,v 1.11 1999/02/24 22:04:23 vanilla Exp $
#
DISTNAME= ee-0.3.8
PKGNAME= electriceyes-0.3.8
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= ee
+MASTER_SITE_SUBDIR= gnome-1.0/sources
MAINTAINER= nacai@iname.com
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
--with-gnome=${X11BASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include" \
- GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
+ GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
post-install:
diff --git a/graphics/electriceyes/files/patch-aa b/graphics/electriceyes/files/patch-aa
index 06a4aa19d6d1..8cec444ff988 100644
--- a/graphics/electriceyes/files/patch-aa
+++ b/graphics/electriceyes/files/patch-aa
@@ -1,24 +1,5 @@
---- configure.orig Wed Feb 24 05:54:38 1999
-+++ configure Wed Feb 24 05:55:40 1999
-@@ -1113,13 +1113,13 @@
- fi
-
- if test "$no_gnome_config" = "yes"; then
-- echo $ac_n "checking for gnomeConf.sh file in $gnome_prefix""... $ac_c" 1>&6
--echo "configure:1118: checking for gnomeConf.sh file in $gnome_prefix" >&5
-- if test -f $gnome_prefix/gnomeConf.sh; then
-+ echo $ac_n "checking for gnomeConf.sh file in $prefix/share/gnome""... $ac_c" 1>&6
-+echo "configure:1118: checking for gnomeConf.sh file in $prefix/share/gnome" >&5
-+ if test -f $prefix/share/gnome/gnomeConf.sh; then
- echo "$ac_t""found" 1>&6
- echo "loading gnome configuration from" \
-- "$gnome_prefix/gnomeConf.sh"
-- . $gnome_prefix/gnomeConf.sh
-+ "$prefix/share/gnome/gnomeConf.sh"
-+ . $prefix/share/gnome/gnomeConf.sh
-
- else
- echo "$ac_t""not found" 1>&6
+--- configure.orig Fri Feb 12 23:04:17 1999
++++ configure Sat Mar 6 22:27:13 1999
@@ -4378,7 +4378,7 @@
cat conftest.$ac_ext >&5
rm -rf conftest*
@@ -28,12 +9,25 @@
fi
rm -f conftest*
INSTOBJEXT=.mo
-@@ -4640,7 +4640,7 @@
- USE_INCLUDED_LIBINTL=yes
- CATOBJEXT=.cat
- INSTOBJEXT=.cat
-- DATADIRNAME=lib
-+ DATADIRNAME=share
- INTLDEPS='$(top_builddir)/intl/libintl.a'
- INTLLIBS=$INTLDEPS
- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+@@ -4766,15 +4766,15 @@
+ fi
+
+
+- USE_INCLUDED_LIBINTL=yes
++# USE_INCLUDED_LIBINTL=yes
+ CATOBJEXT=.gmo
+ INSTOBJEXT=.mo
+ DATADIRNAME=share
+- INTLDEPS='$(top_builddir)/intl/libintl.a'
+- INTLLIBS=$INTLDEPS
+- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+- nls_cv_header_intl=intl/libintl.h
+- nls_cv_header_libgt=intl/libgettext.h
++# INTLDEPS='$(top_builddir)/intl/libintl.a'
++# INTLLIBS=$INTLDEPS
++# LIBS=`echo $LIBS | sed -e 's/-lintl//'`
++# nls_cv_header_intl=intl/libintl.h
++# nls_cv_header_libgt=intl/libgettext.h
+ fi
+
+ if test "$XGETTEXT" != ":"; then