aboutsummaryrefslogtreecommitdiff
path: root/graphics/enblend/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-01 23:17:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-01 23:17:41 +0000
commit2df894588bac29dc2b7cc9f6dc08a1178ea72e9a (patch)
tree9a8458d366d3f503dc71b4be844797936d92e067 /graphics/enblend/Makefile
parentaa4ad1ab5430249bd0ebac2c4dab3e6cd295bfff (diff)
downloadports-2df894588bac29dc2b7cc9f6dc08a1178ea72e9a.tar.gz
ports-2df894588bac29dc2b7cc9f6dc08a1178ea72e9a.zip
Notes
Diffstat (limited to 'graphics/enblend/Makefile')
-rw-r--r--graphics/enblend/Makefile30
1 files changed, 21 insertions, 9 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index f73b36d1281d..6b272690b45a 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -6,24 +6,36 @@
#
PORTNAME= enblend
-PORTVERSION= 2.5
+PORTVERSION= 3.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Image Blending with Multiresolution Splines. For panorama images, etc
+COMMENT= A tool for image blending with multiresolution splines
-LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
- jpeg:${PORTSDIR}/graphics/jpeg \
- boost_date_time:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/pool/pool.hpp:${PORTSDIR}/devel/boost
+LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ lcms:${PORTSDIR}/graphics/lcms \
+ glut.4:${PORTSDIR}/graphics/libglut \
+ xmi.1:${PORTSDIR}/graphics/plotutils \
+ tiff.4:${PORTSDIR}/graphics/tiff
+USE_GNOME= gnometarget
+USE_GL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${WRKSRC}/src/vigra_impex -I${WRKSRC}/include -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-USE_GETOPT_LONG=yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-PLIST_FILES= bin/enblend
MAN1= enblend.1
+PLIST_FILES= bin/enblend
+
+CPPFLAGS= -I${WRKSRC}/src/vigra_impex -I${WRKSRC}/include \
+ -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ffast-math||g ; \
+ s|-g -O3||g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>