aboutsummaryrefslogtreecommitdiff
path: root/graphics/enblend
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-01-31 13:38:42 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-01-31 13:38:42 +0000
commitf5f6cd6d9b51abcfaf7d5a03d342e91dc742074d (patch)
tree384a6fe89b7bf8bffcc478f3462d538eea755790 /graphics/enblend
parent49be72eaa4585216ade79b274fca337c2bf4866a (diff)
downloadports-f5f6cd6d9b51abcfaf7d5a03d342e91dc742074d.tar.gz
ports-f5f6cd6d9b51abcfaf7d5a03d342e91dc742074d.zip
Notes
Diffstat (limited to 'graphics/enblend')
-rw-r--r--graphics/enblend/Makefile14
-rw-r--r--graphics/enblend/files/patch-boost-1.52125
2 files changed, 131 insertions, 8 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 1c97c1a2a63b..cd1dd3357fb2 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: enblend
-# Date created: 19 september 2004
-# Whom: cartola@openit.com.br
-#
+# Created by: cartola@openit.com.br
# $FreeBSD$
-#
PORTNAME= enblend
PORTVERSION= 4.0
@@ -16,13 +12,13 @@ DISTNAME= enblend-enfuse-${PORTVERSION}
MAINTAINER= grog@FreeBSD.org
COMMENT= A tool for image blending with multiresolution splines
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/pool/pool.hpp:${PORTSDIR}/devel/boost-libs \
- ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo \
+BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo \
OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
lcms:${PORTSDIR}/graphics/lcms \
xmi:${PORTSDIR}/graphics/plotutils \
- tiff:${PORTSDIR}/graphics/tiff
+ tiff:${PORTSDIR}/graphics/tiff \
+ boost_filesystem:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
WRKSRC= ${WRKDIR}/enblend-enfuse-4.0-753b534c819d
@@ -39,6 +35,8 @@ CONFIGURE_ARGS= MAKEINFO="${LOCALBASE}/bin/makeinfo"
USE_GCC= 4.4+
USE_GL= glew glut
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= "LIBS=-lboost_system"
+CONFIGURE_ARGS+= --with-boost-filesystem
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/enblend/files/patch-boost-1.52 b/graphics/enblend/files/patch-boost-1.52
new file mode 100644
index 000000000000..c9827eb53d29
--- /dev/null
+++ b/graphics/enblend/files/patch-boost-1.52
@@ -0,0 +1,125 @@
+--- src/filenameparse.cc Tue Mar 15 18:52:46 2011 +0100
++++ src/filenameparse.cc Sat Apr 09 20:17:05 2011 -0700
+@@ -50,7 +50,7 @@
+ #ifdef HAVE_BOOST_FILESYSTEM
+ #include <boost/filesystem.hpp>
+
+-typedef boost::filesystem::basic_path<std::string, boost::filesystem::path_traits> basic_path;
++//typedef boost::filesystem::basic_path<std::string, boost::filesystem::path_traits> basic_path;
+ #endif
+
+
+@@ -60,7 +60,7 @@
+ isRelativePath(const std::string& aFilename)
+ {
+ #ifdef HAVE_BOOST_FILESYSTEM
+- const basic_path path(aFilename);
++ const boost::filesystem::path path(aFilename);
+ return !path.has_root_directory();
+ #else
+ const std::string::size_type separator = aFilename.find(PATH_SEPARATOR);
+@@ -80,7 +80,7 @@
+ extractDirname(const std::string& aFilename)
+ {
+ #ifdef HAVE_BOOST_FILESYSTEM
+- const basic_path path(aFilename);
++ const boost::filesystem::path path(aFilename);
+ const std::string directory(path.branch_path().string());
+ return directory.empty() ? DOT : directory;
+ #else
+@@ -94,8 +94,8 @@
+ extractBasename(const std::string& aFilename)
+ {
+ #ifdef HAVE_BOOST_FILESYSTEM
+- const basic_path path(aFilename);
+- return path.leaf();
++ const boost::filesystem::path path(aFilename);
++ return path.leaf().string();
+ #else
+ const std::string::size_type separator = aFilename.rfind(PATH_SEPARATOR);
+ return
+@@ -110,7 +110,7 @@
+ extractFilename(const std::string& aFilename)
+ {
+ #ifdef HAVE_BOOST_FILESYSTEM
+- const basic_path path(aFilename);
++ const boost::filesystem::path path(aFilename);
+ return basename(path);
+ #else
+ const std::string::size_type separator = aFilename.rfind(PATH_SEPARATOR);
+@@ -134,7 +134,7 @@
+ extractExtension(const std::string& aFilename)
+ {
+ #ifdef HAVE_BOOST_FILESYSTEM
+- const basic_path path(aFilename);
++ const boost::filesystem::path path(aFilename);
+ return extension(path);
+ #else
+ const std::string::size_type dot = aFilename.rfind(DOT);
+@@ -151,11 +151,11 @@
+
+ #ifdef HAVE_BOOST_FILESYSTEM
+
+-inline basic_path
+-removeDotsBoost(const basic_path& aPath)
++inline boost::filesystem::path
++removeDotsBoost(const boost::filesystem::path& aPath)
+ {
+- basic_path result;
+- for (basic_path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
++ boost::filesystem::path result;
++ for (boost::filesystem::path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
+ {
+ if (*p != DOT)
+ {
+@@ -166,11 +166,12 @@
+ }
+
+
+-inline basic_path
+-removeDotDotsBoost(const basic_path& aPath)
++inline boost::filesystem::path
++removeDotDotsBoost(const boost::filesystem::path& aPath)
+ {
+ list_t directories;
+- for (basic_path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
++ for (boost::filesystem::path::const_iterator p = aPath.begin(); p != aPath.end(); ++p)
++
+ {
+ if (*p == DOTDOT &&
+ !directories.empty() && directories.back() != DOTDOT)
+@@ -179,10 +180,10 @@
+ }
+ else
+ {
+- directories.push_back(*p);
++ directories.push_back((*p).string());
+ }
+ }
+- basic_path result;
++ boost::filesystem::path result;
+ for (list_t::const_iterator p = directories.begin(); p != directories.end(); ++p)
+ {
+ result /= *p;
+@@ -295,8 +296,8 @@
+ canonicalizePath(const std::string& aPathname, bool keepDot)
+ {
+ #ifdef HAVE_BOOST_FILESYSTEM
+- const basic_path result =
+- removeDotDotsBoost(removeDotsBoost(basic_path(aPathname)));
++ const boost::filesystem::path result =
++ removeDotDotsBoost(removeDotsBoost(boost::filesystem::path(aPathname)));
+ if (keepDot && result.empty())
+ {
+ return std::string(DOT);
+@@ -331,8 +332,8 @@
+ concatPath(const std::string& aPathname, const std::string& anotherPathname)
+ {
+ #ifdef HAVE_BOOST_FILESYSTEM
+- basic_path path(aPathname);
+- basic_path leaf(anotherPathname);
++ boost::filesystem::path path(aPathname);
++ boost::filesystem::path leaf(anotherPathname);
+ path /= leaf;
+ return path.string();
+ #else