aboutsummaryrefslogtreecommitdiff
path: root/graphics/enblend
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
commitd4f0d0048a8755106a4b0445221a19761e746984 (patch)
treec87184c5bfeaf942c827c5f706186ce9786a2588 /graphics/enblend
parente82affd309fc2d8e5ea19b2e003f1296920bd825 (diff)
downloadports-d4f0d0048a8755106a4b0445221a19761e746984.tar.gz
ports-d4f0d0048a8755106a4b0445221a19761e746984.zip
Notes
Diffstat (limited to 'graphics/enblend')
-rw-r--r--graphics/enblend/Makefile1
-rw-r--r--graphics/enblend/files/patch-src__anneal.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 6b272690b45a..4306a0fc2b19 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -7,6 +7,7 @@
PORTNAME= enblend
PORTVERSION= 3.0
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/enblend/files/patch-src__anneal.h b/graphics/enblend/files/patch-src__anneal.h
new file mode 100644
index 000000000000..e116408bb88b
--- /dev/null
+++ b/graphics/enblend/files/patch-src__anneal.h
@@ -0,0 +1,11 @@
+--- src/anneal.h.orig Sun Nov 21 18:23:08 2004
++++ src/anneal.h Mon May 7 21:21:12 2007
+@@ -678,7 +678,7 @@
+
+ localK = stateSpace->size();
+ if (localK < 2) convergedPoints[index] = true;
+- kMax = std::max(kMax, stateProbabilities->size());
++ kMax = std::max((size_t)kMax, stateProbabilities->size());
+
+ }
+