aboutsummaryrefslogtreecommitdiff
path: root/graphics/enfle
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/enfle
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'graphics/enfle')
-rw-r--r--graphics/enfle/Makefile6
-rw-r--r--graphics/enfle/files/patch-plugins-loader-png-png.c18
2 files changed, 16 insertions, 8 deletions
diff --git a/graphics/enfle/Makefile b/graphics/enfle/Makefile
index 34bfca699dcc..8292760c0c53 100644
--- a/graphics/enfle/Makefile
+++ b/graphics/enfle/Makefile
@@ -7,7 +7,7 @@
PORTNAME= enfle
PORTVERSION= 20101006
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://enfle.fennel.org/files/stable/
@@ -20,7 +20,7 @@ LIB_DEPENDS= arc.1:${PORTSDIR}/archivers/libarc \
jpeg.11:${PORTSDIR}/graphics/jpeg \
mng.1:${PORTSDIR}/graphics/libmng \
gif.5:${PORTSDIR}/graphics/giflib \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
theora.0:${PORTSDIR}/multimedia/libtheora
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -42,7 +42,7 @@ CONFIGURE_ARGS= --with-ungif
PKGDEINSTALL= ${PKGINSTALL}
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/graphics/enfle/files/patch-plugins-loader-png-png.c b/graphics/enfle/files/patch-plugins-loader-png-png.c
index eab0c8c1ed78..956b39a4fdcb 100644
--- a/graphics/enfle/files/patch-plugins-loader-png-png.c
+++ b/graphics/enfle/files/patch-plugins-loader-png-png.c
@@ -1,6 +1,14 @@
---- plugins/loader/png/png.c.orig 2006-03-12 09:24:16.000000000 +0100
-+++ plugins/loader/png/png.c 2010-03-29 16:51:07.000000000 +0200
-@@ -156,7 +156,7 @@
+--- plugins/loader/png/png.c.orig 2010-10-06 14:47:32.000000000 +0200
++++ plugins/loader/png/png.c 2012-05-04 07:30:47.000000000 +0200
+@@ -34,6 +34,7 @@
+ #error Install libpng
+ #endif
+ #endif
++# include <pngpriv.h>
+
+ #include "enfle/loader-plugin.h"
+ #include "utils/libstring.h"
+@@ -156,7 +157,7 @@
int try_when_error;
unsigned int i, num_text;
int num_trans;
@@ -9,7 +17,7 @@
png_bytep trans;
//debug_message("png loader: load() called\n");
-@@ -260,7 +260,7 @@
+@@ -260,7 +261,7 @@
color_type = png_get_color_type(png_ptr, info_ptr);
/* Set the transparent color */
@@ -18,7 +26,7 @@
//p->transparent_disposal = info->transparent_disposal;
switch (color_type) {
case PNG_COLOR_TYPE_PALETTE:
-@@ -273,13 +273,13 @@
+@@ -273,13 +274,13 @@
break;
case PNG_COLOR_TYPE_RGB:
case PNG_COLOR_TYPE_RGB_ALPHA: