aboutsummaryrefslogtreecommitdiff
path: root/graphics/entangle
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-26 23:30:51 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-26 23:30:51 +0000
commit0bbd3aba07dce4ece55cc44bd35e8d589036e1e2 (patch)
tree876fb654f24f88c5f1a8b80b2e50e3b25114f08b /graphics/entangle
parent3189a9e1d34d3795affc6d391e0da84d4e056ae1 (diff)
downloadports-0bbd3aba07dce4ece55cc44bd35e8d589036e1e2.tar.gz
ports-0bbd3aba07dce4ece55cc44bd35e8d589036e1e2.zip
Notes
Diffstat (limited to 'graphics/entangle')
-rw-r--r--graphics/entangle/Makefile14
-rw-r--r--graphics/entangle/distinfo4
-rw-r--r--graphics/entangle/pkg-plist91
3 files changed, 61 insertions, 48 deletions
diff --git a/graphics/entangle/Makefile b/graphics/entangle/Makefile
index 94b3d9a8a92c..74afa13c363c 100644
--- a/graphics/entangle/Makefile
+++ b/graphics/entangle/Makefile
@@ -2,16 +2,17 @@
# $FreeBSD$
PORTNAME= entangle
-DISTVERSION= 0.6.1
+DISTVERSION= 0.7.0
CATEGORIES= graphics
MASTER_SITES= http://entangle-photo.org/download/sources/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= woodsb02@gmail.com
COMMENT= Digital camera tethered control and capture program
LICENSE= GPLv3
-BUILD_DEPENDS= ${LOCALBASE}/share/icons/mate/scalable/devices/camera-photo-symbolic.svg:${PORTSDIR}/x11-themes/mate-icon-theme
+BUILD_DEPENDS= ${LOCALBASE}/share/icons/mate/scalable/devices/camera-photo-symbolic.svg:${PORTSDIR}/x11-themes/mate-icon-theme \
+ itstool:${PORTSDIR}/textproc/itstool
LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2 \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
@@ -20,10 +21,13 @@ LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2 \
libpeas-1.0.so:${PORTSDIR}/devel/libpeas
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gmake pkgconfig
+USES= gettext-tools gmake libtool pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk30 introspection:build
GLIB_SCHEMAS= org.entangle-photo.manager.gschema.xml
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
# XXX: it would be nice if one day this option would be passed automatically
# to configure scripts that support it :)
@@ -37,8 +41,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
+NLS_USES= gettext-runtime
post-patch:
@${REINPLACE_CMD} -e '/checking for GUDEV/,+93d ; \
diff --git a/graphics/entangle/distinfo b/graphics/entangle/distinfo
index 8ed3431c28ac..355177d9bf0f 100644
--- a/graphics/entangle/distinfo
+++ b/graphics/entangle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (entangle-0.6.1.tar.gz) = b5ab32e933f46d14c579d641eaf84223c9f24f7b35dd9da1aa4af8db91c9e0ef
-SIZE (entangle-0.6.1.tar.gz) = 903981
+SHA256 (entangle-0.7.0.tar.gz) = ebbfc92f7f4c379d7b85a52da3965593356b491fadbc635b1d90a7e6c3cc0fe2
+SIZE (entangle-0.7.0.tar.gz) = 965666
diff --git a/graphics/entangle/pkg-plist b/graphics/entangle/pkg-plist
index cb6d03c19a70..491a31e5d40c 100644
--- a/graphics/entangle/pkg-plist
+++ b/graphics/entangle/pkg-plist
@@ -1,27 +1,18 @@
bin/entangle
lib/entangle/plugins/photobox/photobox.plugin
lib/entangle/plugins/photobox/photobox.py
+lib/entangle/plugins/shooter/shooter.plugin
+lib/entangle/plugins/shooter/shooter.py
lib/girepository-1.0/Entangle-0.1.typelib
+lib/libentangle_backend.so
+lib/libentangle_backend.so.0
+lib/libentangle_backend.so.0.0.0
+lib/libentangle_frontend.so
+lib/libentangle_frontend.so.0
+lib/libentangle_frontend.so.0.0.0
man/man1/entangle.1.gz
share/appdata/entangle.appdata.xml
share/applications/entangle.desktop
-share/icons/hicolor/128x128/apps/entangle.png
-share/icons/hicolor/16x16/apps/entangle.png
-share/icons/hicolor/22x22/apps/entangle-capture.png
-share/icons/hicolor/22x22/apps/entangle-color-management.png
-share/icons/hicolor/22x22/apps/entangle-imageviewer.png
-share/icons/hicolor/22x22/apps/entangle-interface.png
-share/icons/hicolor/22x22/apps/entangle-plugins.png
-share/icons/hicolor/256x256/apps/entangle.png
-share/icons/hicolor/32x32/apps/entangle.png
-share/icons/hicolor/48x48/apps/entangle.png
-share/icons/hicolor/48x48/apps/entangle-capture.png
-share/icons/hicolor/48x48/apps/entangle-color-management.png
-share/icons/hicolor/48x48/apps/entangle-imageviewer.png
-share/icons/hicolor/48x48/apps/entangle-interface.png
-share/icons/hicolor/48x48/apps/entangle-plugins.png
-share/icons/hicolor/64x64/apps/entangle.png
-share/icons/hicolor/scalable/apps/entangle.svg
%%DATADIR%%/entangle-camera-manager.ui
%%DATADIR%%/entangle-camera-picker.ui
%%DATADIR%%/entangle-camera-support.ui
@@ -30,6 +21,8 @@ share/icons/hicolor/scalable/apps/entangle.svg
%%DATADIR%%/entangle-preferences-display.ui
%%DATADIR%%/plugins/photobox/schemas/gschemas.compiled
%%DATADIR%%/plugins/photobox/schemas/org.entangle-photo.plugins.photobox.gschema.xml
+%%DATADIR%%/plugins/shooter/schemas/gschemas.compiled
+%%DATADIR%%/plugins/shooter/schemas/org.entangle-photo.plugins.shooter.gschema.xml
%%DATADIR%%/sRGB.icc
share/gir-1.0/Entangle-0.1.gir
share/gtk-doc/html/Entangle/Entangle-entangle-debug.html
@@ -75,22 +68,49 @@ share/gtk-doc/html/Entangle/ch02.html
share/gtk-doc/html/Entangle/home.png
share/gtk-doc/html/Entangle/index.html
share/gtk-doc/html/Entangle/index.sgml
-share/gtk-doc/html/Entangle/left.png
share/gtk-doc/html/Entangle/left-insensitive.png
+share/gtk-doc/html/Entangle/left.png
share/gtk-doc/html/Entangle/object-tree.html
-share/gtk-doc/html/Entangle/right.png
share/gtk-doc/html/Entangle/right-insensitive.png
+share/gtk-doc/html/Entangle/right.png
share/gtk-doc/html/Entangle/style.css
-share/gtk-doc/html/Entangle/up.png
share/gtk-doc/html/Entangle/up-insensitive.png
-%%NLS%%share/locale/ach/LC_MESSAGES/entangle.mo
+share/gtk-doc/html/Entangle/up.png
+share/help/C/entangle/camera-focusing.page
+share/help/C/entangle/figures/entangle.png
+share/help/C/entangle/image-capture.page
+share/help/C/entangle/image-preview.page
+share/help/C/entangle/image-storage.page
+share/help/C/entangle/index.page
+share/help/C/entangle/introduction.page
+share/help/C/entangle/legal.xml
+share/help/C/entangle/plugin-management.page
+share/help/C/entangle/plugin-photobox.page
+share/icons/hicolor/128x128/apps/entangle.png
+share/icons/hicolor/16x16/apps/entangle.png
+share/icons/hicolor/192x192/apps/entangle.png
+share/icons/hicolor/22x22/apps/entangle-capture.png
+share/icons/hicolor/22x22/apps/entangle-color-management.png
+share/icons/hicolor/22x22/apps/entangle-imageviewer.png
+share/icons/hicolor/22x22/apps/entangle-interface.png
+share/icons/hicolor/22x22/apps/entangle-plugins.png
+share/icons/hicolor/256x256/apps/entangle.png
+share/icons/hicolor/32x32/apps/entangle.png
+share/icons/hicolor/48x48/apps/entangle-capture.png
+share/icons/hicolor/48x48/apps/entangle-color-management.png
+share/icons/hicolor/48x48/apps/entangle-imageviewer.png
+share/icons/hicolor/48x48/apps/entangle-interface.png
+share/icons/hicolor/48x48/apps/entangle-plugins.png
+share/icons/hicolor/48x48/apps/entangle.png
+share/icons/hicolor/64x64/apps/entangle.png
+share/icons/hicolor/96x96/apps/entangle.png
+share/icons/hicolor/scalable/apps/entangle.svg
%%NLS%%share/locale/af/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/aln/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/am/LC_MESSAGES/entangle.mo
+%%NLS%%share/locale/anp/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ar/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/as/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ast/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/az/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/bal/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/be/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/bg/LC_MESSAGES/entangle.mo
@@ -106,10 +126,8 @@ share/gtk-doc/html/Entangle/up-insensitive.png
%%NLS%%share/locale/da/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/de/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/de_CH/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/dz/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/el/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/en_US/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/eo/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/es/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/et/LC_MESSAGES/entangle.mo
@@ -117,14 +135,12 @@ share/gtk-doc/html/Entangle/up-insensitive.png
%%NLS%%share/locale/fa/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/fi/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/fr/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/ga/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/gl/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/gu/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/he/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/hi/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/hr/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/hu/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/hy/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ia/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/id/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ilo/LC_MESSAGES/entangle.mo
@@ -136,27 +152,24 @@ share/gtk-doc/html/Entangle/up-insensitive.png
%%NLS%%share/locale/km/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/kn/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ko/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/ks/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/ku/LC_MESSAGES/entangle.mo
+%%NLS%%share/locale/kw/LC_MESSAGES/entangle.mo
+%%NLS%%share/locale/kw@kkcor/LC_MESSAGES/entangle.mo
+%%NLS%%share/locale/kw@uccor/LC_MESSAGES/entangle.mo
+%%NLS%%share/locale/kw_GB/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ky/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/la/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/lo/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/lt/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/lv/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/mai/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/mg/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/mk/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ml/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/mn/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/mr/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ms/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/my/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/nb/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/nds/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ne/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/nl/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/nn/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/no/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/nso/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/or/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/pa/LC_MESSAGES/entangle.mo
@@ -165,7 +178,6 @@ share/gtk-doc/html/Entangle/up-insensitive.png
%%NLS%%share/locale/pt_BR/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ro/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ru/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/ru_RU/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/si/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/sk/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/sl/LC_MESSAGES/entangle.mo
@@ -177,17 +189,14 @@ share/gtk-doc/html/Entangle/up-insensitive.png
%%NLS%%share/locale/te/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/tg/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/th/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/tl/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/tr/LC_MESSAGES/entangle.mo
+%%NLS%%share/locale/tw/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/uk/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/ur/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/uz/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/vi/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/wo/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/xh/LC_MESSAGES/entangle.mo
+%%NLS%%share/locale/wba/LC_MESSAGES/entangle.mo
+%%NLS%%share/locale/yo/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/zh_CN.GB2312/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/zh_HK/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/entangle.mo
-%%NLS%%share/locale/zh_TW.Big5/LC_MESSAGES/entangle.mo
%%NLS%%share/locale/zu/LC_MESSAGES/entangle.mo