aboutsummaryrefslogtreecommitdiff
path: root/graphics/eog-plugins/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /graphics/eog-plugins/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'graphics/eog-plugins/Makefile')
-rw-r--r--graphics/eog-plugins/Makefile58
1 files changed, 32 insertions, 26 deletions
diff --git a/graphics/eog-plugins/Makefile b/graphics/eog-plugins/Makefile
index 21510e0d3929..893ea41fc525 100644
--- a/graphics/eog-plugins/Makefile
+++ b/graphics/eog-plugins/Makefile
@@ -1,59 +1,65 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/graphics/eog-plugins/Makefile,v 1.14 2010/09/04 18:09:30 kwm Exp $
+# $MCom: ports/trunk/graphics/eog-plugins/Makefile 19804 2014-08-13 14:55:11Z kwm $
PORTNAME= eog-plugins
-PORTVERSION= 2.30.1
-PORTREVISION= 7
+PORTVERSION= 3.12.1
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Plug-ins for the Eye of GNOME image viewer application
BUILD_DEPENDS= eog:${PORTSDIR}/graphics/eog
-LIB_DEPENDS= libgdata.so:${PORTSDIR}/devel/libgdata
+LIB_DEPENDS= libgdata.so:${PORTSDIR}/devel/libgdata \
+ libexif.so:${PORTSDIR}/graphics/libexif \
+ libpeas-1.0.so:${PORTSDIR}/devel/libpeas
RUN_DEPENDS= eog:${PORTSDIR}/graphics/eog
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
-USE_GL= gl
-USE_GNOME= gnomeprefix intlhack gtk20
+USE_GNOME= gnomeprefix intlhack gtk30
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-.include <bsd.port.pre.mk>
+GLIB_SCHEMAS= org.gnome.eog.plugins.exif-display.gschema.xml
-.if !defined(WITHOUT_CHAMPLAIN) || \
- (exists(${LOCALBASE}/lib/libchamplain-0.8.so)) || defined(WITH_CHAMPLIAN)
-LIB_DEPENDS+= libchamplain-0.8.so:${PORTSDIR}/graphics/libchamplain
-PLIST_SUB+= CHAMPLAIN=""
-.else
-PLUST_SUB+= CHAMPLAIN="@comment "
-.endif
+OPTIONS_DEFINE= CHAMPLAIN PYTHON
+OPTIONS_DEFAULT=CHAMPLAIN PYTHON
+CHAMPLAIN_DESC= Champlain map plugin
+
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_EXIF) || (exists(${LOCALBASE}/lib/libexif.so.12) || \
- defined(WITH_EXIF))
-LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif
-PLIST_SUB+= EXIF=""
+.if ${PORT_OPTIONS:MCHAMPLAIN}
+USE_GL= gl
+LIB_DEPENDS+= libchamplain-0.12.so:${PORTSDIR}/graphics/libchamplain
+PLIST_SUB+= CHAMPLAIN=""
.else
-PLIST_SUB+= EXIF="@comment "
+PLIST_SUB+= CHAMPLAIN="@comment "
.endif
-.if ${HAVE_GNOME:Mpygnome2}!=""
-USE_GNOME+= pygnome2
+PLIST_SUB+= PYVER=${PYTHON_VER:S|.||}
+.if ${PORT_OPTIONS:MPYTHON}
CONFIGURE_ARGS+=--enable-python
+USES+= python:3
PLIST_SUB+= PYTHON=""
+GLIB_SCHEMAS+= org.gnome.eog.plugins.export-to-folder.gschema.xml \
+ org.gnome.eog.plugins.fullscreenbg.gschema.xml \
+ org.gnome.eog.plugins.pythonconsole.gschema.xml
.else
CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+.if ! ${PORT_OPTIONS:MCHAMPLAIN}
post-patch:
- @${REINPLACE_CMD} -e 's|champlain-0.4|champlain-0.8|g' \
- -e 's|champlain-gtk-0.4|champlain-gtk-0.8|g' \
+ @${REINPLACE_CMD} -e 's|champlain-gtk|disabled-champlain-gtk|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^DEFAULT_PLUGINS=/,/^$$/ s/map//' \
+ ${WRKSRC}/configure
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>