aboutsummaryrefslogtreecommitdiff
path: root/graphics/eog-plugins
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /graphics/eog-plugins
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'graphics/eog-plugins')
-rw-r--r--graphics/eog-plugins/Makefile58
-rw-r--r--graphics/eog-plugins/distinfo4
-rw-r--r--graphics/eog-plugins/files/patch-configure11
-rw-r--r--graphics/eog-plugins/pkg-plist68
4 files changed, 88 insertions, 53 deletions
diff --git a/graphics/eog-plugins/Makefile b/graphics/eog-plugins/Makefile
index 21510e0d3929..893ea41fc525 100644
--- a/graphics/eog-plugins/Makefile
+++ b/graphics/eog-plugins/Makefile
@@ -1,59 +1,65 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/graphics/eog-plugins/Makefile,v 1.14 2010/09/04 18:09:30 kwm Exp $
+# $MCom: ports/trunk/graphics/eog-plugins/Makefile 19804 2014-08-13 14:55:11Z kwm $
PORTNAME= eog-plugins
-PORTVERSION= 2.30.1
-PORTREVISION= 7
+PORTVERSION= 3.12.1
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Plug-ins for the Eye of GNOME image viewer application
BUILD_DEPENDS= eog:${PORTSDIR}/graphics/eog
-LIB_DEPENDS= libgdata.so:${PORTSDIR}/devel/libgdata
+LIB_DEPENDS= libgdata.so:${PORTSDIR}/devel/libgdata \
+ libexif.so:${PORTSDIR}/graphics/libexif \
+ libpeas-1.0.so:${PORTSDIR}/devel/libpeas
RUN_DEPENDS= eog:${PORTSDIR}/graphics/eog
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
-USE_GL= gl
-USE_GNOME= gnomeprefix intlhack gtk20
+USE_GNOME= gnomeprefix intlhack gtk30
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-.include <bsd.port.pre.mk>
+GLIB_SCHEMAS= org.gnome.eog.plugins.exif-display.gschema.xml
-.if !defined(WITHOUT_CHAMPLAIN) || \
- (exists(${LOCALBASE}/lib/libchamplain-0.8.so)) || defined(WITH_CHAMPLIAN)
-LIB_DEPENDS+= libchamplain-0.8.so:${PORTSDIR}/graphics/libchamplain
-PLIST_SUB+= CHAMPLAIN=""
-.else
-PLUST_SUB+= CHAMPLAIN="@comment "
-.endif
+OPTIONS_DEFINE= CHAMPLAIN PYTHON
+OPTIONS_DEFAULT=CHAMPLAIN PYTHON
+CHAMPLAIN_DESC= Champlain map plugin
+
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_EXIF) || (exists(${LOCALBASE}/lib/libexif.so.12) || \
- defined(WITH_EXIF))
-LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif
-PLIST_SUB+= EXIF=""
+.if ${PORT_OPTIONS:MCHAMPLAIN}
+USE_GL= gl
+LIB_DEPENDS+= libchamplain-0.12.so:${PORTSDIR}/graphics/libchamplain
+PLIST_SUB+= CHAMPLAIN=""
.else
-PLIST_SUB+= EXIF="@comment "
+PLIST_SUB+= CHAMPLAIN="@comment "
.endif
-.if ${HAVE_GNOME:Mpygnome2}!=""
-USE_GNOME+= pygnome2
+PLIST_SUB+= PYVER=${PYTHON_VER:S|.||}
+.if ${PORT_OPTIONS:MPYTHON}
CONFIGURE_ARGS+=--enable-python
+USES+= python:3
PLIST_SUB+= PYTHON=""
+GLIB_SCHEMAS+= org.gnome.eog.plugins.export-to-folder.gschema.xml \
+ org.gnome.eog.plugins.fullscreenbg.gschema.xml \
+ org.gnome.eog.plugins.pythonconsole.gschema.xml
.else
CONFIGURE_ARGS+=--disable-python
PLIST_SUB+= PYTHON="@comment "
.endif
+.if ! ${PORT_OPTIONS:MCHAMPLAIN}
post-patch:
- @${REINPLACE_CMD} -e 's|champlain-0.4|champlain-0.8|g' \
- -e 's|champlain-gtk-0.4|champlain-gtk-0.8|g' \
+ @${REINPLACE_CMD} -e 's|champlain-gtk|disabled-champlain-gtk|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} '/^DEFAULT_PLUGINS=/,/^$$/ s/map//' \
+ ${WRKSRC}/configure
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/eog-plugins/distinfo b/graphics/eog-plugins/distinfo
index 26fd1b259afb..e5fe70172596 100644
--- a/graphics/eog-plugins/distinfo
+++ b/graphics/eog-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/eog-plugins-2.30.1.tar.bz2) = 0e651053367e1d6aecfb8058a93dcac2223ec822a691ee134e9a879662580caf
-SIZE (gnome2/eog-plugins-2.30.1.tar.bz2) = 344700
+SHA256 (gnome3/eog-plugins-3.12.1.tar.xz) = 5b9a6854d5411e75aadb9d44694bbe02a35f5a79a23da5c1bb4feb6bacf56f1c
+SIZE (gnome3/eog-plugins-3.12.1.tar.xz) = 351844
diff --git a/graphics/eog-plugins/files/patch-configure b/graphics/eog-plugins/files/patch-configure
new file mode 100644
index 000000000000..c53047416044
--- /dev/null
+++ b/graphics/eog-plugins/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2013-05-12 12:16:28.000000000 +0000
++++ configure 2013-05-12 12:16:52.000000000 +0000
+@@ -14495,7 +14495,7 @@
+ disabled_plugins="$disabled_plugins, $1 ($2)"
+ fi
+
+- PLUGINS=$(echo "$PLUGINS" | sed -e "s/[^a-zA-Z0-9_]$1[ \t\r\n\f]\{1,\}/ /" -e "s/[^a-zA-Z0-9_]$1$//" -e "s/^$1[ \t\r\n\f]\{1,\}//")
++ PLUGINS=$(echo "$PLUGINS" | sed -e "s/[^a-zA-Z0-9_]$1[ \t\r\n]\{1,\}/ /" -e "s/[^a-zA-Z0-9_]$1$//" -e "s/^$1[ \t\r\n]\{1,\}//")
+ }
+
+ # Disable python plugins if there is no python support
diff --git a/graphics/eog-plugins/pkg-plist b/graphics/eog-plugins/pkg-plist
index 9c4bc96e9db8..f156c242b1a0 100644
--- a/graphics/eog-plugins/pkg-plist
+++ b/graphics/eog-plugins/pkg-plist
@@ -1,39 +1,49 @@
-%%PYTHON%%lib/eog/plugins/console.py
-%%PYTHON%%lib/eog/plugins/console.pyc
-%%PYTHON%%lib/eog/plugins/console.pyo
-%%EXIF%%lib/eog/plugins/exif-display.eog-plugin
-%%EXIF%%lib/eog/plugins/exif-display/exif-display-config.ui
-%%EXIF%%lib/eog/plugins/exif-display/exif-display.ui
-lib/eog/plugins/fit-to-width.eog-plugin
-%%EXIF%%lib/eog/plugins/libexif-display.la
-%%EXIF%%lib/eog/plugins/libexif-display.so
-lib/eog/plugins/libfit-to-width.la
+lib/eog/plugins/exif-display.plugin
+%%PYTHON%%lib/eog/plugins/export-to-folder.plugin
+%%PYTHON%%lib/eog/plugins/export-to-folder.py
+%%PYTHON%%lib/eog/plugins/__pycache__/export-to-folder.cpython-%%PYVER%%.pyc
+%%PYTHON%%lib/eog/plugins/__pycache__/export-to-folder.cpython-%%PYVER%%.pyo
+lib/eog/plugins/fit-to-width.plugin
+%%PYTHON%%lib/eog/plugins/fullscreenbg.plugin
+%%PYTHON%%lib/eog/plugins/fullscreenbg.py
+%%PYTHON%%lib/eog/plugins/__pycache__/fullscreenbg.cpython-%%PYVER%%.pyc
+%%PYTHON%%lib/eog/plugins/__pycache__/fullscreenbg.cpython-%%PYVER%%.pyo
+lib/eog/plugins/hide-titlebar.plugin
+lib/eog/plugins/libexif-display.so
lib/eog/plugins/libfit-to-width.so
-%%CHAMPLAIN%%lib/eog/plugins/libmap.la
+lib/eog/plugins/libhide-titlebar.so
+lib/eog/plugins/liblight-theme.so
%%CHAMPLAIN%%lib/eog/plugins/libmap.so
-lib/eog/plugins/libpostasa.la
lib/eog/plugins/libpostasa.so
-lib/eog/plugins/libsend-by-mail.la
lib/eog/plugins/libsend-by-mail.so
-%%CHAMPLAIN%%lib/eog/plugins/map.eog-plugin
-lib/eog/plugins/postasa.eog-plugin
-lib/eog/plugins/postasa/postasa-config.xml
-lib/eog/plugins/postasa/postasa-uploads.xml
-%%PYTHON%%lib/eog/plugins/pythonconsole.eog-plugin
-%%PYTHON%%lib/eog/plugins/pythonconsole.py
-%%PYTHON%%lib/eog/plugins/pythonconsole.pyc
-%%PYTHON%%lib/eog/plugins/pythonconsole.pyo
-lib/eog/plugins/send-by-mail.eog-plugin
-%%PYTHON%%lib/eog/plugins/slideshowshuffle.eog-plugin
+lib/eog/plugins/light-theme.plugin
+%%CHAMPLAIN%%lib/eog/plugins/map.plugin
+lib/eog/plugins/postasa.plugin
+%%PYTHON%%lib/eog/plugins/pythonconsole.plugin
+%%PYTHON%%lib/eog/plugins/pythonconsole/__init__.py
+%%PYTHON%%lib/eog/plugins/pythonconsole/__pycache__/__init__.cpython-%%PYVER%%.pyc
+%%PYTHON%%lib/eog/plugins/pythonconsole/__pycache__/__init__.cpython-%%PYVER%%.pyo
+%%PYTHON%%lib/eog/plugins/pythonconsole/__pycache__/config.cpython-%%PYVER%%.pyc
+%%PYTHON%%lib/eog/plugins/pythonconsole/__pycache__/config.cpython-%%PYVER%%.pyo
+%%PYTHON%%lib/eog/plugins/pythonconsole/__pycache__/console.cpython-%%PYVER%%.pyc
+%%PYTHON%%lib/eog/plugins/pythonconsole/__pycache__/console.cpython-%%PYVER%%.pyo
+%%PYTHON%%lib/eog/plugins/pythonconsole/config.py
+%%PYTHON%%lib/eog/plugins/pythonconsole/console.py
+lib/eog/plugins/send-by-mail.plugin
+%%PYTHON%%lib/eog/plugins/slideshowshuffle.plugin
%%PYTHON%%lib/eog/plugins/slideshowshuffle.py
-%%PYTHON%%lib/eog/plugins/slideshowshuffle.pyc
-%%PYTHON%%lib/eog/plugins/slideshowshuffle.pyo
+%%PYTHON%%lib/eog/plugins/__pycache__/slideshowshuffle.cpython-%%PYVER%%.pyc
+%%PYTHON%%lib/eog/plugins/__pycache__/slideshowshuffle.cpython-%%PYVER%%.pyo
+%%PYTHON%%share/eog/plugins/export-to-folder/preferences_dialog.ui
+%%PYTHON%%share/eog/plugins/fullscreenbg/preferences_dialog.ui
+%%PYTHON%%share/eog/plugins/pythonconsole/config.ui
share/locale/ar/LC_MESSAGES/eog-plugins.mo
share/locale/as/LC_MESSAGES/eog-plugins.mo
share/locale/be@latin/LC_MESSAGES/eog-plugins.mo
share/locale/bg/LC_MESSAGES/eog-plugins.mo
share/locale/bn_IN/LC_MESSAGES/eog-plugins.mo
share/locale/ca/LC_MESSAGES/eog-plugins.mo
+share/locale/ca@valencia/LC_MESSAGES/eog-plugins.mo
share/locale/cs/LC_MESSAGES/eog-plugins.mo
share/locale/da/LC_MESSAGES/eog-plugins.mo
share/locale/de/LC_MESSAGES/eog-plugins.mo
@@ -45,12 +55,15 @@ share/locale/fi/LC_MESSAGES/eog-plugins.mo
share/locale/fr/LC_MESSAGES/eog-plugins.mo
share/locale/gl/LC_MESSAGES/eog-plugins.mo
share/locale/gu/LC_MESSAGES/eog-plugins.mo
+share/locale/he/LC_MESSAGES/eog-plugins.mo
share/locale/hu/LC_MESSAGES/eog-plugins.mo
share/locale/id/LC_MESSAGES/eog-plugins.mo
share/locale/it/LC_MESSAGES/eog-plugins.mo
share/locale/ja/LC_MESSAGES/eog-plugins.mo
share/locale/kn/LC_MESSAGES/eog-plugins.mo
+share/locale/ko/LC_MESSAGES/eog-plugins.mo
share/locale/lt/LC_MESSAGES/eog-plugins.mo
+share/locale/lv/LC_MESSAGES/eog-plugins.mo
share/locale/mk/LC_MESSAGES/eog-plugins.mo
share/locale/ml/LC_MESSAGES/eog-plugins.mo
share/locale/mr/LC_MESSAGES/eog-plugins.mo
@@ -60,8 +73,13 @@ share/locale/pa/LC_MESSAGES/eog-plugins.mo
share/locale/pl/LC_MESSAGES/eog-plugins.mo
share/locale/pt/LC_MESSAGES/eog-plugins.mo
share/locale/pt_BR/LC_MESSAGES/eog-plugins.mo
+share/locale/ro/LC_MESSAGES/eog-plugins.mo
+share/locale/ru/LC_MESSAGES/eog-plugins.mo
+share/locale/sk/LC_MESSAGES/eog-plugins.mo
share/locale/sl/LC_MESSAGES/eog-plugins.mo
share/locale/sq/LC_MESSAGES/eog-plugins.mo
+share/locale/sr/LC_MESSAGES/eog-plugins.mo
+share/locale/sr@latin/LC_MESSAGES/eog-plugins.mo
share/locale/sv/LC_MESSAGES/eog-plugins.mo
share/locale/ta/LC_MESSAGES/eog-plugins.mo
share/locale/te/LC_MESSAGES/eog-plugins.mo