aboutsummaryrefslogtreecommitdiff
path: root/graphics/eog
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /graphics/eog
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
Notes
Diffstat (limited to 'graphics/eog')
-rw-r--r--graphics/eog/Makefile11
-rw-r--r--graphics/eog/distinfo4
-rw-r--r--graphics/eog/files/patch-libeog_eog-image-list.c17
-rw-r--r--graphics/eog/pkg-plist13
4 files changed, 40 insertions, 5 deletions
diff --git a/graphics/eog/Makefile b/graphics/eog/Makefile
index f1ff2b2702f5..75a3ba5ecf3e 100644
--- a/graphics/eog/Makefile
+++ b/graphics/eog/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/graphics/eog/Makefile,v 1.9 2005/10/04 03:00:35 ahze Exp $
#
PORTNAME= eog
-PORTVERSION= 2.10.2
+PORTVERSION= 2.12.1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.12
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -22,7 +23,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui \
librsvg2 desktopfileutils libgnomeui
USE_X_PREFIX= yes
INSTALLS_OMF= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
@@ -30,6 +31,10 @@ GCONF_SCHEMAS= eog.schemas
.include <bsd.port.pre.mk>
+.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
+WITH_EXIF= yes
+.endif
+
.if defined(WITH_EXIF) || exists(${LOCALBASE}/lib/libexif.so.12)
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
.endif
diff --git a/graphics/eog/distinfo b/graphics/eog/distinfo
index b370fc72f13f..53ebdf94e042 100644
--- a/graphics/eog/distinfo
+++ b/graphics/eog/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/eog-2.10.2.tar.bz2) = 09884ebaf4d520195093b2a516252579
-SIZE (gnome2/eog-2.10.2.tar.bz2) = 870480
+MD5 (gnome2/eog-2.12.1.tar.bz2) = d5dc20850777bb85ec90ff92817106dd
+SIZE (gnome2/eog-2.12.1.tar.bz2) = 799227
diff --git a/graphics/eog/files/patch-libeog_eog-image-list.c b/graphics/eog/files/patch-libeog_eog-image-list.c
new file mode 100644
index 000000000000..609cd0469a4e
--- /dev/null
+++ b/graphics/eog/files/patch-libeog_eog-image-list.c
@@ -0,0 +1,17 @@
+--- libeog/eog-image-list.c.orig Thu Aug 25 14:57:02 2005
++++ libeog/eog-image-list.c Thu Aug 25 14:57:46 2005
+@@ -450,12 +450,13 @@
+ case GNOME_VFS_MONITOR_EVENT_CREATED:
+
+ if (list && list->priv) {
++ gchar *str;
+ node = list->priv->store;
+
+ while (node != NULL && !found) {
+
+ uri = eog_image_get_uri(node->data);
+- gchar *str = gnome_vfs_uri_to_string
++ str = gnome_vfs_uri_to_string
+ (uri, GNOME_VFS_URI_HIDE_NONE);
+ found = (strcmp (str, info_uri)==0)?TRUE:FALSE;
+ g_free (str);
diff --git a/graphics/eog/pkg-plist b/graphics/eog/pkg-plist
index b1d8e407371a..9ab737a65952 100644
--- a/graphics/eog/pkg-plist
+++ b/graphics/eog/pkg-plist
@@ -30,6 +30,10 @@ share/gnome/help/eog/ko/legal.xml
share/gnome/help/eog/sv/eog.xml
share/gnome/help/eog/sv/figures/eog_start_window.png
share/gnome/help/eog/sv/legal.xml
+share/gnome/help/eog/uk/eog.xml
+share/gnome/help/eog/uk/figures/eog_save_as_window.png
+share/gnome/help/eog/uk/figures/eog_start_window.png
+share/gnome/help/eog/uk/legal.xml
share/gnome/help/eog/zh_CN/eog.xml
share/gnome/help/eog/zh_CN/figures/eog_start_window.png
share/gnome/help/eog/zh_CN/legal.xml
@@ -45,6 +49,7 @@ share/gnome/omf/eog/eog-it.omf
share/gnome/omf/eog/eog-ja.omf
share/gnome/omf/eog/eog-ko.omf
share/gnome/omf/eog/eog-sv.omf
+share/gnome/omf/eog/eog-uk.omf
share/gnome/omf/eog/eog-zh_CN.omf
share/gnome/omf/eog/eog-zh_TW.omf
share/gnome/pixmaps/eog/down-right.png
@@ -93,6 +98,7 @@ share/locale/it/LC_MESSAGES/eog.mo
share/locale/ja/LC_MESSAGES/eog.mo
share/locale/kn/LC_MESSAGES/eog.mo
share/locale/ko/LC_MESSAGES/eog.mo
+share/locale/ku/LC_MESSAGES/eog.mo
share/locale/lt/LC_MESSAGES/eog.mo
share/locale/lv/LC_MESSAGES/eog.mo
share/locale/mk/LC_MESSAGES/eog.mo
@@ -123,6 +129,7 @@ share/locale/ta/LC_MESSAGES/eog.mo
share/locale/th/LC_MESSAGES/eog.mo
share/locale/tk/LC_MESSAGES/eog.mo
share/locale/tr/LC_MESSAGES/eog.mo
+share/locale/ug/LC_MESSAGES/eog.mo
share/locale/uk/LC_MESSAGES/eog.mo
share/locale/vi/LC_MESSAGES/eog.mo
share/locale/wa/LC_MESSAGES/eog.mo
@@ -134,16 +141,22 @@ share/locale/zu/LC_MESSAGES/eog.mo
@unexec rmdir %D/share/locale/zu 2> /dev/null || true
@unexec rmdir %D/share/locale/xh/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/xh 2> /dev/null || true
+@unexec rmdir %D/share/locale/ug/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/ug 2> /dev/null || true
@unexec rmdir %D/share/locale/rw/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/rw 2> /dev/null || true
@unexec rmdir %D/share/locale/nso/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/nso 2> /dev/null || true
+@unexec rmdir %D/share/locale/ku/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/ku 2> /dev/null || true
@dirrm share/gnome/pixmaps/eog
@dirrm share/gnome/omf/eog
@dirrm share/gnome/help/eog/zh_TW/figures
@dirrm share/gnome/help/eog/zh_TW
@dirrm share/gnome/help/eog/zh_CN/figures
@dirrm share/gnome/help/eog/zh_CN
+@dirrm share/gnome/help/eog/uk/figures
+@dirrm share/gnome/help/eog/uk
@dirrm share/gnome/help/eog/sv/figures
@dirrm share/gnome/help/eog/sv
@dirrm share/gnome/help/eog/ko/figures