aboutsummaryrefslogtreecommitdiff
path: root/graphics/eom
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-07-04 11:44:30 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-07-04 11:44:30 +0000
commit0a7668c1332918aa06ca27664ae8c447a553c5fd (patch)
tree37169f4d6a1ec15a3f96493c65cb713e58dc7aee /graphics/eom
parent1702ea4d9050cc64965b5766671c067e06c781e2 (diff)
Notes
Diffstat (limited to 'graphics/eom')
-rw-r--r--graphics/eom/Makefile56
-rw-r--r--graphics/eom/distinfo5
-rw-r--r--graphics/eom/pkg-plist25
3 files changed, 37 insertions, 49 deletions
diff --git a/graphics/eom/Makefile b/graphics/eom/Makefile
index 6ef4f0725d5f..0880a0ec0700 100644
--- a/graphics/eom/Makefile
+++ b/graphics/eom/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= eom
-PORTVERSION= 1.12.2
+PORTVERSION= 1.18.2
CATEGORIES= graphics mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -10,25 +10,26 @@ DIST_SUBDIR= mate
MAINTAINER= gnome@FreeBSD.org
COMMENT= Eye of MATE image viewer
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= itstool:textproc/itstool
+LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification \
+ libdbus-1.so:devel/dbus \
+ libdbus-glib-1.so:devel/dbus-glib \
+ libpeas-gtk-1.0.so:devel/libpeas
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake jpeg libtool pathfix pkgconfig \
- tar:xz
+USES= desktop-file-utils gettext gmake jpeg libtool localbase \
+ pathfix pkgconfig tar:xz
USE_MATE= desktop icontheme
USE_XORG= x11
-USE_GNOME= gdkpixbuf2 glib20 gtk20 intltool librsvg2 libxml2
+USE_GNOME= cairo gnomeprefix gtk30 intltool introspection \
+ librsvg2 libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --disable-gtk-doc \
- --with-html-dir=${PREFIX}/share/doc \
- --disable-introspection \
- --with-gtk=2.0 \
- --disable-python \
- --without-cms
+CONFIGURE_ARGS= --without-cms
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.eom.gschema.xml \
@@ -36,33 +37,18 @@ GLIB_SCHEMAS= org.mate.eom.gschema.xml \
OPTIONS_DEFINE= EXIF EXEMPI
OPTIONS_DEFAULT=EXIF EXEMPI
-EXIF_DESC= Digital camera file meta-data support
-EXEMPI_DESC= XMP support
-
-.include <bsd.port.options.mk>
-_WITH_EXIF= no
-_WITH_EXEMPI= no
+EXEMPI_DESC= XMP support
+EXEMPI_CONFIGURE_WITH= xmp
+EXEMPI_LIB_DEPENDS= libexempi.so:textproc/exempi
-.if ${PORT_OPTIONS:MEXIF}
-CONFIGURE_ARGS+=--with-libexif
-LIB_DEPENDS+= libexif.so:graphics/libexif
-PLIST_SUB+= EXIF=""
-_WITH_EXIF= yes
-.else
-CONFIGURE_ARGS+=--without-libexif
-PLIST_SUB+= EXIF="@comment "
-.endif
+EXIF_DESC= Digital camera file meta-data support
+EXIF_CONFIGURE_WITH= libexif
+EXIF_LIB_DEPENDS= libexif.so:graphics/libexif
-.if ${PORT_OPTIONS:MEXEMPI}
-CONFIGURE_ARGS+=--with-xmp
-LIB_DEPENDS+= libexempi.so:textproc/exempi
-_WITH_EXEMPI= yes
-.else
-CONFIGURE_ARGS+=--without-xmp
-.endif
+.include <bsd.port.options.mk>
-.if ${_WITH_EXIF}=="yes" || ${_WITH_EXEMPI}=="yes"
+.if ${PORT_OPTIONS:MEXIF} || ${PORT_OPTIONS:MEXEMPI}
PLIST_SUB+= EXIFEXEMPI=""
.else
PLIST_SUB+= EXIFEXEMPI="@comment "
diff --git a/graphics/eom/distinfo b/graphics/eom/distinfo
index 17d4708daf17..c407084f3ec9 100644
--- a/graphics/eom/distinfo
+++ b/graphics/eom/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mate/eom-1.12.2.tar.xz) = 38ad10a6794e02e9e319a293393a36532e86572010442ba2f1d3773313c0a1da
-SIZE (mate/eom-1.12.2.tar.xz) = 2213260
+TIMESTAMP = 1494460910
+SHA256 (mate/eom-1.18.2.tar.xz) = 0755a43f48fe1a09b826cdd6ed239631f5e4f9163ccb481362534d8fcf3bda02
+SIZE (mate/eom-1.18.2.tar.xz) = 2196228
diff --git a/graphics/eom/pkg-plist b/graphics/eom/pkg-plist
index da5bd6f6f999..adcf042a5cff 100644
--- a/graphics/eom/pkg-plist
+++ b/graphics/eom/pkg-plist
@@ -13,7 +13,6 @@ include/eom-2.20/eom/eom-image.h
include/eom-2.20/eom/eom-job-queue.h
include/eom-2.20/eom/eom-jobs.h
include/eom-2.20/eom/eom-list-store.h
-include/eom-2.20/eom/eom-plugin.h
include/eom-2.20/eom/eom-properties-dialog.h
include/eom-2.20/eom/eom-scroll-view.h
include/eom-2.20/eom/eom-sidebar.h
@@ -23,15 +22,15 @@ include/eom-2.20/eom/eom-thumb-view.h
include/eom-2.20/eom/eom-thumbnail.h
include/eom-2.20/eom/eom-transform.h
include/eom-2.20/eom/eom-window.h
-lib/eom/plugins/fullscreen.eom-plugin
+lib/eom/plugins/fullscreen.plugin
lib/eom/plugins/libfullscreen.so
lib/eom/plugins/libreload.so
lib/eom/plugins/libstatusbar-date.so
-lib/eom/plugins/reload.eom-plugin
-lib/eom/plugins/statusbar-date.eom-plugin
+lib/eom/plugins/reload.plugin
+lib/eom/plugins/statusbar-date.plugin
+lib/girepository-1.0/Eom-1.0.typelib
libdata/pkgconfig/eom.pc
man/man1/eom.1.gz
-share/MateConf/gsettings/eom.convert
share/appdata/eom.appdata.xml
share/applications/eom.desktop
%%PORTDOCS%%%%DOCSDIR%%/EomDialog.html
@@ -40,7 +39,6 @@ share/applications/eom.desktop
%%PORTDOCS%%%%DOCSDIR%%/EomImageSaveInfo.html
%%PORTDOCS%%%%DOCSDIR%%/EomMetadataReaderJpg.html
%%PORTDOCS%%%%DOCSDIR%%/EomMetadataReaderPng.html
-%%PORTDOCS%%%%DOCSDIR%%/EomPluginManager.html
%%PORTDOCS%%%%DOCSDIR%%/EomPreferencesDialog.html
%%PORTDOCS%%%%DOCSDIR%%/EomPrintImageSetup.html
%%PORTDOCS%%%%DOCSDIR%%/EomPrintPreview.html
@@ -68,7 +66,6 @@ share/applications/eom.desktop
%%PORTDOCS%%%%DOCSDIR%%/eom-eom-metadata-reader.html
%%PORTDOCS%%%%DOCSDIR%%/eom-eom-pixbuf-util.html
%%PORTDOCS%%%%DOCSDIR%%/eom-eom-plugin-engine.html
-%%PORTDOCS%%%%DOCSDIR%%/eom-eom-plugin.html
%%PORTDOCS%%%%DOCSDIR%%/eom-eom-print.html
%%PORTDOCS%%%%DOCSDIR%%/eom-eom-properties-dialog.html
%%PORTDOCS%%%%DOCSDIR%%/eom-eom-save-as-dialog-helper.html
@@ -85,7 +82,6 @@ share/applications/eom.desktop
%%PORTDOCS%%%%DOCSDIR%%/eom.devhelp2
%%PORTDOCS%%%%DOCSDIR%%/home.png
%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/index.sgml
%%PORTDOCS%%%%DOCSDIR%%/left-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%/left.png
%%PORTDOCS%%%%DOCSDIR%%/pt01.html
@@ -95,6 +91,7 @@ share/applications/eom.desktop
%%PORTDOCS%%%%DOCSDIR%%/style.css
%%PORTDOCS%%%%DOCSDIR%%/up-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%/up.png
+%%DATADIR%%/eom-3.18.css
%%DATADIR%%/eom-image-properties-dialog.ui
%%DATADIR%%/eom-multiple-save-as-dialog.ui
%%DATADIR%%/eom-preferences-dialog.ui
@@ -118,6 +115,7 @@ share/applications/eom.desktop
%%DATADIR%%/icons/hicolor/scalable/actions/eom-plugin.svg
%%DATADIR%%/icons/hicolor/scalable/actions/slideshow-play.svg
%%DATADIR%%/pixmaps/thumbnail-frame.png
+share/gir-1.0/Eom-1.0.gir
share/help/C/eom/figures/eom_save_as_window.png
share/help/C/eom/figures/eom_start_window.png
share/help/C/eom/figures/eom_toolbar_editor_window.png
@@ -255,7 +253,6 @@ share/locale/as/LC_MESSAGES/eom.mo
share/locale/ast/LC_MESSAGES/eom.mo
share/locale/az/LC_MESSAGES/eom.mo
share/locale/be/LC_MESSAGES/eom.mo
-share/locale/be@latin/LC_MESSAGES/eom.mo
share/locale/bg/LC_MESSAGES/eom.mo
share/locale/bn/LC_MESSAGES/eom.mo
share/locale/bn_IN/LC_MESSAGES/eom.mo
@@ -270,18 +267,20 @@ share/locale/da/LC_MESSAGES/eom.mo
share/locale/de/LC_MESSAGES/eom.mo
share/locale/dz/LC_MESSAGES/eom.mo
share/locale/el/LC_MESSAGES/eom.mo
-share/locale/en@shaw/LC_MESSAGES/eom.mo
share/locale/en_AU/LC_MESSAGES/eom.mo
share/locale/en_CA/LC_MESSAGES/eom.mo
share/locale/en_GB/LC_MESSAGES/eom.mo
-share/locale/en_US/LC_MESSAGES/eom.mo
share/locale/eo/LC_MESSAGES/eom.mo
share/locale/es/LC_MESSAGES/eom.mo
+share/locale/es_CO/LC_MESSAGES/eom.mo
+share/locale/es_MX/LC_MESSAGES/eom.mo
share/locale/et/LC_MESSAGES/eom.mo
share/locale/eu/LC_MESSAGES/eom.mo
share/locale/fa/LC_MESSAGES/eom.mo
share/locale/fi/LC_MESSAGES/eom.mo
share/locale/fr/LC_MESSAGES/eom.mo
+share/locale/fr_CA/LC_MESSAGES/eom.mo
+share/locale/frp/LC_MESSAGES/eom.mo
share/locale/fur/LC_MESSAGES/eom.mo
share/locale/ga/LC_MESSAGES/eom.mo
share/locale/gl/LC_MESSAGES/eom.mo
@@ -295,12 +294,14 @@ share/locale/id/LC_MESSAGES/eom.mo
share/locale/is/LC_MESSAGES/eom.mo
share/locale/it/LC_MESSAGES/eom.mo
share/locale/ja/LC_MESSAGES/eom.mo
+share/locale/jv/LC_MESSAGES/eom.mo
share/locale/ka/LC_MESSAGES/eom.mo
share/locale/kk/LC_MESSAGES/eom.mo
share/locale/kn/LC_MESSAGES/eom.mo
share/locale/ko/LC_MESSAGES/eom.mo
share/locale/ks/LC_MESSAGES/eom.mo
share/locale/ku/LC_MESSAGES/eom.mo
+share/locale/ku_IQ/LC_MESSAGES/eom.mo
share/locale/ky/LC_MESSAGES/eom.mo
share/locale/lt/LC_MESSAGES/eom.mo
share/locale/lv/LC_MESSAGES/eom.mo
@@ -321,6 +322,7 @@ share/locale/oc/LC_MESSAGES/eom.mo
share/locale/or/LC_MESSAGES/eom.mo
share/locale/pa/LC_MESSAGES/eom.mo
share/locale/pl/LC_MESSAGES/eom.mo
+share/locale/pms/LC_MESSAGES/eom.mo
share/locale/ps/LC_MESSAGES/eom.mo
share/locale/pt/LC_MESSAGES/eom.mo
share/locale/pt_BR/LC_MESSAGES/eom.mo
@@ -342,7 +344,6 @@ share/locale/tr/LC_MESSAGES/eom.mo
share/locale/ug/LC_MESSAGES/eom.mo
share/locale/uk/LC_MESSAGES/eom.mo
share/locale/uz/LC_MESSAGES/eom.mo
-share/locale/uz@cyrillic/LC_MESSAGES/eom.mo
share/locale/vi/LC_MESSAGES/eom.mo
share/locale/wa/LC_MESSAGES/eom.mo
share/locale/xh/LC_MESSAGES/eom.mo