aboutsummaryrefslogtreecommitdiff
path: root/graphics/epdfview
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 16:39:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 16:39:14 +0000
commitbc62127a69294fd3340ea793685953d98ff835dc (patch)
treed124c4d6f965d5152806ebfbf40e1b5a25860ddb /graphics/epdfview
parente8dd5f52410bdf2a989023706699373d47296008 (diff)
downloadports-bc62127a69294fd3340ea793685953d98ff835dc.tar.gz
ports-bc62127a69294fd3340ea793685953d98ff835dc.zip
Notes
Diffstat (limited to 'graphics/epdfview')
-rw-r--r--graphics/epdfview/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
index 4efbce1e1ab5..d99eceff02b0 100644
--- a/graphics/epdfview/Makefile
+++ b/graphics/epdfview/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: epdfview
-# Date created: 2006/06/01
-# Whom: chinsan <chinsan.tw@gmail.com>
-#
+# Created by: chinsan <chinsan.tw@gmail.com>
# $FreeBSD$
-#
PORTNAME= epdfview
PORTVERSION= 0.1.8
@@ -29,22 +25,21 @@ USE_GNOME= gtk20 intlhack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= CUPS "Use cups printing system" off \
- NLS "Native language support" on
+OPTIONS_DEFINE= CUPS NLS
MAN1= epdfview.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_CUPS)
+.if ${PORT_OPTIONS:MCUPS}
CONFIGURE_ARGS+=--with-cups
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
.else
CONFIGURE_ARGS+=--without-cups
.endif
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -63,4 +58,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/data/${PORTNAME}.desktop ${PREFIX}/share/applications/
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>