aboutsummaryrefslogtreecommitdiff
path: root/graphics/epeg/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-08-08 16:50:01 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-08-08 16:50:01 +0000
commit66217dffe486e69ed40bdb018e7ba114ab70eaf8 (patch)
treec906c29416423728a4443e4620a7054d997e4b2f /graphics/epeg/Makefile
parentc994533986d4aad8f831e45943eb1e939098829b (diff)
downloadports-66217dffe486e69ed40bdb018e7ba114ab70eaf8.tar.gz
ports-66217dffe486e69ed40bdb018e7ba114ab70eaf8.zip
Notes
Diffstat (limited to 'graphics/epeg/Makefile')
-rw-r--r--graphics/epeg/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/epeg/Makefile b/graphics/epeg/Makefile
new file mode 100644
index 000000000000..8802d617106d
--- /dev/null
+++ b/graphics/epeg/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: epeg
+# Date created: 08/08/2004
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= epeg
+PORTVERSION= 0.9.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= enlightenment
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= An immensely fast jpeg thumbnailer library API
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_LIBTOOL_VER= 15
+USE_GNOME= gnomehack
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
+
+CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}