aboutsummaryrefslogtreecommitdiff
path: root/graphics/epix
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-05 19:55:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-05 19:55:49 +0000
commitffee13f318a7b2c169b31dfa0ff305ce0c4eb5ea (patch)
treec25e64c9c728c36a6d95d9d41ba8fbce1da303ef /graphics/epix
parente4cd19415fd53d4ab734c3bf5658aeac08ce5bd5 (diff)
downloadports-ffee13f318a7b2c169b31dfa0ff305ce0c4eb5ea.tar.gz
ports-ffee13f318a7b2c169b31dfa0ff305ce0c4eb5ea.zip
Notes
Diffstat (limited to 'graphics/epix')
-rw-r--r--graphics/epix/Makefile15
-rw-r--r--graphics/epix/distinfo4
-rw-r--r--graphics/epix/files/patch-newbash.sh10
-rw-r--r--graphics/epix/pkg-plist8
4 files changed, 19 insertions, 18 deletions
diff --git a/graphics/epix/Makefile b/graphics/epix/Makefile
index 237a797c0343..703766c5ecae 100644
--- a/graphics/epix/Makefile
+++ b/graphics/epix/Makefile
@@ -7,28 +7,27 @@
#
PORTNAME= epix
-PORTVERSION= 0.8.10a
+PORTVERSION= 1.0.0
CATEGORIES= graphics
-MASTER_SITES= http://mathcs.holycross.edu/~ahwang/software/
+MASTER_SITES= http://mathcs.holycross.edu/~ahwang/epix/
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
MAINTAINER= ports@FreeBSD.org
COMMENT= Creates math plots and line figures using easy-to-learn syntax
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
latex:${PORTSDIR}/print/teTeX
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
-
USE_BZIP2= yes
+USE_GCC= 3.4
USE_REINPLACE= yes
MAKE_ARGS= CXX="${CXX}" CFLAGS="${CXXFLAGS} -c" \
INSTALL_PROGRAM="${INSTALL_DATA}" \
INSTALL_BIN="${INSTALL_SCRIPT}"
-PLIST_SUB= VERSION="${PORTVERSION:S/a//}"
+PLIST_SUB= VERSION="${PORTVERSION}"
-MAN1= epix.1
+MAN1= epix.1
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/graphics/epix/distinfo b/graphics/epix/distinfo
index 776206f23c39..6dddd18bc00b 100644
--- a/graphics/epix/distinfo
+++ b/graphics/epix/distinfo
@@ -1,2 +1,2 @@
-MD5 (epix-0.8.10a_src.tar.bz2) = 9d470d60782758fa12f7050ee0c3707e
-SIZE (epix-0.8.10a_src.tar.bz2) = 122164
+MD5 (epix-1.0.0_src.tar.bz2) = 6da4c68ce0bea32fc2d069502893b85c
+SIZE (epix-1.0.0_src.tar.bz2) = 117612
diff --git a/graphics/epix/files/patch-newbash.sh b/graphics/epix/files/patch-newbash.sh
index 0b7fadd4dd18..4d59627268a8 100644
--- a/graphics/epix/files/patch-newbash.sh
+++ b/graphics/epix/files/patch-newbash.sh
@@ -1,11 +1,11 @@
---- newbash.sh.orig Sat Apr 26 09:34:50 2003
-+++ newbash.sh Thu Jun 19 13:08:48 2003
+--- newbash.sh.orig Thu Aug 26 21:41:44 2004
++++ newbash.sh Wed Nov 3 00:52:21 2004
@@ -1,10 +1,10 @@
#!/bin/sh
#
- for FILE in elaps laps make_header post-uninst.sh pre-install.sh prepix \
-- samples/sample.sh samples/makefigs Makefile
-+ helpfiles.sh samples/sample.sh samples/makefigs Makefile
+ for FILE in elaps laps make_header post-uninst.sh pre-install.sh preflix \
+- prepix samples/sample.sh samples/makefigs Makefile
++ prepix helpfiles.sh samples/sample.sh samples/makefigs Makefile
do
mv $FILE $FILE.orig
- sed 's+/bin/bash+/usr/local/bin/bash+g' $FILE.orig > $FILE
diff --git a/graphics/epix/pkg-plist b/graphics/epix/pkg-plist
index 1116b25e7200..6b91cb6410bf 100644
--- a/graphics/epix/pkg-plist
+++ b/graphics/epix/pkg-plist
@@ -1,5 +1,6 @@
bin/elaps
bin/epix
+bin/flix
bin/keywords
bin/laps
include/epix.h
@@ -7,21 +8,22 @@ lib/libepix.a
%%DATADIR%%/config/bash_completions
%%DATADIR%%/config/epix.el
%%DATADIR%%/config/epix.spec
-%%DATADIR%%/config/epix.texi
%%DATADIR%%/config/update_figs.sh
%%DATADIR%%/notes/BUGS
%%DATADIR%%/notes/CHANGELOG
%%DATADIR%%/notes/INSTALL
%%DATADIR%%/notes/POST-INSTALL
%%DATADIR%%/notes/README
-%%DATADIR%%/notes/README-authors
%%DATADIR%%/notes/README-changes
%%DATADIR%%/notes/THANKS
%%DATADIR%%/notes/TODO
%%DATADIR%%/samples/epix-%%VERSION%%_samples.tar
+%%DATADIR%%/tutorial/contrib/CartesianCoord.cc
+%%DATADIR%%/tutorial/contrib/CoordAxis.cc
+%%DATADIR%%/tutorial/contrib/CoordSystem.cc
+@dirrm %%DATADIR%%/tutorial/contrib
@dirrm %%DATADIR%%/samples
@dirrm %%DATADIR%%/notes
@dirrm %%DATADIR%%/config
-@exec mkdir -p %D/%%DATADIR%%/tutorial
@unexec rmdir %D/%%DATADIR%%/tutorial 2>/dev/null || true
@unexec rmdir %D/%%DATADIR%% 2>/dev/null || true