aboutsummaryrefslogtreecommitdiff
path: root/graphics/epsilon
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-06-16 10:05:09 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-06-16 10:05:09 +0000
commit8af83e2209d35dfae2e1f5f4a6282099146233b6 (patch)
treec6756e0e9bc0e5ea48d5ab6fe3f05fbb4dc5c468 /graphics/epsilon
parent06a021f8881a42edaf434a76d891561bf1afe9a4 (diff)
downloadports-8af83e2209d35dfae2e1f5f4a6282099146233b6.tar.gz
ports-8af83e2209d35dfae2e1f5f4a6282099146233b6.zip
Notes
Diffstat (limited to 'graphics/epsilon')
-rw-r--r--graphics/epsilon/Makefile24
-rw-r--r--graphics/epsilon/distinfo2
-rw-r--r--graphics/epsilon/pkg-descr11
-rw-r--r--graphics/epsilon/pkg-plist6
4 files changed, 43 insertions, 0 deletions
diff --git a/graphics/epsilon/Makefile b/graphics/epsilon/Makefile
new file mode 100644
index 000000000000..37289531bd69
--- /dev/null
+++ b/graphics/epsilon/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: epsilon
+# Date created: 05/09/2005
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= epsilon
+PORTVERSION= 0.3.0.003
+CATEGORIES= graphics
+MASTER_SITES= http://enlightenment.freedesktop.org/files/
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= A small, display independent, and quick thumbnailing library
+
+LIB_DEPENDS= epeg.9:${PORTSDIR}/graphics/epeg
+
+USE_LIBTOOL_VER= 15
+USE_GNOME= gnomehack gnometarget
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/epsilon/distinfo b/graphics/epsilon/distinfo
new file mode 100644
index 000000000000..17ed13ab3b60
--- /dev/null
+++ b/graphics/epsilon/distinfo
@@ -0,0 +1,2 @@
+MD5 (epsilon-0.3.0.003.tar.gz) = 60763c79162d1cd060ce4e20a1ec5df2
+SIZE (epsilon-0.3.0.003.tar.gz) = 338364
diff --git a/graphics/epsilon/pkg-descr b/graphics/epsilon/pkg-descr
new file mode 100644
index 000000000000..3d2180f7674c
--- /dev/null
+++ b/graphics/epsilon/pkg-descr
@@ -0,0 +1,11 @@
+This is a small, display independent, and quick thumbnailing library.
+The lib itself conforms to the standard put forth by freedesktop.org.
+It seemed better to
+break it out into a component that only depended on what was absolutely
+necessary. Upon showing raster the wonders of freedesktop.org
+thumbnailing, he proclaimed that it was far to slow, this prompted him
+to write epeg. Epeg offers very noticeable speed increases to this
+standard, but is only available if the input image is a jpeg file. If
+the file is anything other than jpg, the traditional freedesktop.org png
+thumbnailing will occur. To show the speed increase epeg offers,
+Epsilon builds with and without epeg.
diff --git a/graphics/epsilon/pkg-plist b/graphics/epsilon/pkg-plist
new file mode 100644
index 000000000000..712464b0ff04
--- /dev/null
+++ b/graphics/epsilon/pkg-plist
@@ -0,0 +1,6 @@
+bin/epsilon
+bin/epsilon-config
+include/Epsilon.h
+lib/libepsilon.a
+lib/libepsilon.so
+lib/libepsilon.so.0