aboutsummaryrefslogtreecommitdiff
path: root/graphics/esmart
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-06-16 10:06:13 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-06-16 10:06:13 +0000
commit556d75738819d8729a69d10715ca9160fad38452 (patch)
treecd5dd85407c7d82cf04b9a5f2dcdf0dbfdc5f608 /graphics/esmart
parent8af83e2209d35dfae2e1f5f4a6282099146233b6 (diff)
downloadports-556d75738819d8729a69d10715ca9160fad38452.tar.gz
ports-556d75738819d8729a69d10715ca9160fad38452.zip
Notes
Diffstat (limited to 'graphics/esmart')
-rw-r--r--graphics/esmart/Makefile29
-rw-r--r--graphics/esmart/distinfo2
-rw-r--r--graphics/esmart/pkg-descr21
-rw-r--r--graphics/esmart/pkg-plist40
4 files changed, 92 insertions, 0 deletions
diff --git a/graphics/esmart/Makefile b/graphics/esmart/Makefile
new file mode 100644
index 000000000000..409bc75c9aaf
--- /dev/null
+++ b/graphics/esmart/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: esmart
+# Date created: 05/09/2005
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= esmart
+PORTVERSION= 0.9.0.003
+CATEGORIES= graphics
+MASTER_SITES= http://enlightenment.freedesktop.org/files/
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= Evas smart objects development libraries
+
+LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2 \
+ epsilon.0:${PORTSDIR}/graphics/epsilon \
+ evas.1:${PORTSDIR}/graphics/evas \
+ ecore.1:${PORTSDIR}/x11/ecore
+
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER= 15
+USE_LIBLTDL= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/esmart/distinfo b/graphics/esmart/distinfo
new file mode 100644
index 000000000000..7706bef7d5a5
--- /dev/null
+++ b/graphics/esmart/distinfo
@@ -0,0 +1,2 @@
+MD5 (esmart-0.9.0.003.tar.gz) = b59ae74e5e273ede20450d724514d9e2
+SIZE (esmart-0.9.0.003.tar.gz) = 379440
diff --git a/graphics/esmart/pkg-descr b/graphics/esmart/pkg-descr
new file mode 100644
index 000000000000..d9a350349c5e
--- /dev/null
+++ b/graphics/esmart/pkg-descr
@@ -0,0 +1,21 @@
+Enlightenment Database Library
+
+Edb is intended to provide a stable API and file format for archiving
+configuration, theme, and other data available all the time for access at
+random really fast. Edb can store any kind of data in key-value pair format.
+Random access reading and writing is FAST as the core of Edb uses a berkley.
+Edb provides a convenience API designed to make access fast AND improve access
+speed by caching open db's until a flush and providing conveience macros too.
+It also will be used to store image data and geometry data for theme files so
+the information can be accessed without needing to unarchive files and can be
+edited without having to unarchive and re-archive, and still be accesses at
+random really quickly. Documentation is provided as comments in the Edb.h
+header file.
+
+Edb will be used for all config theme and meta data stroage for E17/EFM
+etc. sine it provides FAST random-access read/write of any data wanted
+(binary, string, integert, floating point) withotu the need to
+unpack/repack files - data can be etxracted and put back at whim with a
+simple API from which simple or complex tools can be built.
+
+WWW: http://www.enlightenment.org/pages/edb.html
diff --git a/graphics/esmart/pkg-plist b/graphics/esmart/pkg-plist
new file mode 100644
index 000000000000..2dc41af42952
--- /dev/null
+++ b/graphics/esmart/pkg-plist
@@ -0,0 +1,40 @@
+bin/esmart-config
+bin/esmart_file_dialog_test
+bin/esmart_test
+include/Esmart/Esmart_Container.h
+include/Esmart/Esmart_Draggies.h
+include/Esmart/Esmart_File_Dialog.h
+include/Esmart/Esmart_Text_Entry.h
+include/Esmart/Esmart_Textarea.h
+include/Esmart/Esmart_Thumb.h
+include/Esmart/Esmart_Trans_X11.h
+lib/libesmart_container.a
+lib/libesmart_container.so
+lib/libesmart_container.so.0
+lib/libesmart_draggies.a
+lib/libesmart_draggies.so
+lib/libesmart_draggies.so.0
+lib/libesmart_file_dialog.a
+lib/libesmart_file_dialog.so
+lib/libesmart_file_dialog.so.0
+lib/libesmart_text_entry.a
+lib/libesmart_text_entry.so
+lib/libesmart_text_entry.so.0
+lib/libesmart_textarea.a
+lib/libesmart_textarea.so
+lib/libesmart_textarea.so.0
+lib/libesmart_thumb.a
+lib/libesmart_thumb.so
+lib/libesmart_thumb.so.0
+lib/libesmart_trans_x11.a
+lib/libesmart_trans_x11.so
+lib/libesmart_trans_x11.so.0
+lib/esmart/layout/default.so
+lib/esmart/layout/engage.so
+lib/esmart/layout/entice.so
+libdata/pkgconfig/esmart.pc
+%%DATADIR%%/esmart.png
+@dirrm %%DATADIR%%
+@dirrm lib/esmart/layout
+@dirrm lib/esmart
+@dirrm include/Esmart