aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-core
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2012-12-22 20:54:59 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2012-12-22 20:54:59 +0000
commit2d250bb95eac4419c2b2a81d30d1629c50a4ba4f (patch)
tree9c4bc08591050b7b536082be6db8392c913f8089 /graphics/evas-core
parent3f57bf2285e342135340477d9404790fda157f15 (diff)
Notes
Diffstat (limited to 'graphics/evas-core')
-rw-r--r--graphics/evas-core/Makefile52
-rw-r--r--graphics/evas-core/Makefile.inc3
-rw-r--r--graphics/evas-core/distinfo4
-rw-r--r--graphics/evas-core/pkg-plist9
4 files changed, 39 insertions, 29 deletions
diff --git a/graphics/evas-core/Makefile b/graphics/evas-core/Makefile
index 9f642e707350..8fbe2c126dfe 100644
--- a/graphics/evas-core/Makefile
+++ b/graphics/evas-core/Makefile
@@ -2,61 +2,63 @@
# $FreeBSD$
PORTNAME= core
-DISTVERSION= 1.1.0
+PORTVERSION= 1.7.4
CATEGORIES= graphics enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
- http://files.roorback.net/e17/2011-12-02/base/
+ LOCAL/gblach/e17/
PKGNAMEPREFIX= evas-
-DISTNAME= evas-${DISTVERSION}
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
MAINTAINER= gblach@FreeBSD.org
COMMENT= A hardware accelerated canvas API (core library)
LICENSE= BSD
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig
USE_EFL= librt_hack libtool_hack
+USE_GNOME= gnomehack pkgconfig
+USE_LDCONFIG= yes
DATADIR= ${PREFIX}/share/evas
+EXAMPLESDIR= ${PREFIX}/share/examples/evas
.include "Makefile.inc"
-OPTIONS= FONTCONFIG "Enable fontconfig support" on \
- FRIBIDI "Enable bidirectional text support" on \
- EET "Enable EET font loader" on
+OPTIONS_DEFINE= EET FONTCONFIG FRIBIDI
+OPTIONS_DEFAULT=EET FONTCONFIG FRIBIDI
+EET_DESC= EET font loader
+FRIBIDI_DESC= Bidirectional text support
-EXAMPLESDIR= ${PREFIX}/share/examples/evas
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_FONTCONFIG)
-CONFIGURE_ARGS+= --enable-fontconfig
-LIB_DEPENDS+= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+.if ${PORT_OPTIONS:MFONTCONFIG}
+LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+CONFIGURE_ARGS+=--enable-fontconfig
.else
-CONFIGURE_ARGS+= --disable-fontconfig
+CONFIGURE_ARGS+=--disable-fontconfig
.endif
-.if !defined(WITHOUT_FRIBIDI)
-CONFIGURE_ARGS+= --enable-fribidi
-LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
+.if ${PORT_OPTIONS:MFRIBIDI}
+LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+CONFIGURE_ARGS+=--enable-fribidi
.else
-CONFIGURE_ARGS+= --disable-fribidi
+CONFIGURE_ARGS+=--disable-fribidi
.endif
-.if !defined(WITHOUT_EET)
-CONFIGURE_ARGS+= --enable-font-loader-eet
+.if ${PORT_OPTIONS:MEET}
USE_EFL+= eet
+CONFIGURE_ARGS+=--enable-font-loader-eet
.else
-CONFIGURE_ARGS+= --disable-font-loader-eet
+CONFIGURE_ARGS+=--disable-font-loader-eet
.endif
-.if !defined(NOPORTEXAMPLES)
-CONFIGURE_ARGS+= --enable-install-examples
+.if ${PORT_OPTIONS:MEXAMPLES}
+CONFIGURE_ARGS+=--enable-install-examples
.else
-CONFIGURE_ARGS+= --disable-install-examples
+CONFIGURE_ARGS+=--disable-install-examples
.endif
post-patch:
@@ -64,7 +66,7 @@ post-patch:
${WRKSRC}/src/examples/Makefile.in
post-install:
-.if defined(NOPORTEXAMPLES)
+.if empty(PORT_OPTIONS:MEXAMPLES)
@${RMDIR} ${EXAMPLESDIR}
.endif
diff --git a/graphics/evas-core/Makefile.inc b/graphics/evas-core/Makefile.inc
index 2fdc63494b8f..62300f34cba1 100644
--- a/graphics/evas-core/Makefile.inc
+++ b/graphics/evas-core/Makefile.inc
@@ -3,7 +3,6 @@ CONFIGURE_ARGS= --disable-software-xcb \
--disable-software-8-x11 \
--disable-software-16-x11 \
--disable-directfb \
- --disable-software-sdl \
--disable-software-16-sdl \
--disable-gl-sdl \
--disable-buffer \
@@ -24,6 +23,8 @@ CONFIGURE_ARGS= --disable-software-xcb \
--disable-image-loader-tiff \
--disable-image-loader-wbmp \
--disable-image-loader-xpm \
+ --disable-wayland-shm \
+ --disable-wayland-egl \
--disable-cpu-sse3
PATCHDIR= "../../graphics/evas-core/files"
diff --git a/graphics/evas-core/distinfo b/graphics/evas-core/distinfo
index 0159d761d2d9..82db61be2731 100644
--- a/graphics/evas-core/distinfo
+++ b/graphics/evas-core/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e17/evas-1.1.0.tar.bz2) = 7702a315dc22f4abc269f6a3ef2695b365a3eab4fd2fcdd07275e41221b03930
-SIZE (e17/evas-1.1.0.tar.bz2) = 9235732
+SHA256 (e17/evas-1.7.4.tar.bz2) = 53f3e58c876c38a6de9aa65ae660e526bc4671d05397c2c347f11e5e61f50a8f
+SIZE (e17/evas-1.7.4.tar.bz2) = 9365979
diff --git a/graphics/evas-core/pkg-plist b/graphics/evas-core/pkg-plist
index bfbc3a73006b..b241c50ea4d8 100644
--- a/graphics/evas-core/pkg-plist
+++ b/graphics/evas-core/pkg-plist
@@ -1,8 +1,12 @@
+bin/evas_cserve
+bin/evas_cserve_tool
include/evas-1/Evas.h
+include/evas-1/Evas_GL.h
lib/libevas.so
-lib/libevas.so.2
+lib/libevas.so.8
lib/evas/modules/engines/software_generic/%%E17_ARCH%%/module.so
libdata/pkgconfig/evas.pc
+%%DATADIR%%/checkme
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/aspect.edc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cube1.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/enlightenment.png
@@ -13,9 +17,11 @@ libdata/pkgconfig/evas.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-hints.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-images.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-images2.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-images3.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-init-shutdown.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-map-utils.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-object-manipulation.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-smart-interface.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-smart-object.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-stacking.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evas-text.c
@@ -27,4 +33,5 @@ libdata/pkgconfig/evas.pc
@dirrmtry lib/evas/modules/engines
@dirrmtry lib/evas/modules
@dirrmtry lib/evas
+@dirrm %%DATADIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%