aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-loader-ico/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-06-26 17:36:30 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-06-26 17:36:30 +0000
commitb9eaf394330b28c95aff1aed37c4e9c7269123a4 (patch)
treec7d813040107a076d3b35f3a2eefbed1462e4ed4 /graphics/evas-loader-ico/Makefile
parent2cce93719ddda5af2198b65d659b27535350e329 (diff)
downloadports-b9eaf394330b28c95aff1aed37c4e9c7269123a4.tar.gz
ports-b9eaf394330b28c95aff1aed37c4e9c7269123a4.zip
Notes
Diffstat (limited to 'graphics/evas-loader-ico/Makefile')
-rw-r--r--graphics/evas-loader-ico/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/graphics/evas-loader-ico/Makefile b/graphics/evas-loader-ico/Makefile
new file mode 100644
index 000000000000..f11431ecb16f
--- /dev/null
+++ b/graphics/evas-loader-ico/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: evas-loader-ico
+# Date created: 2012-04-28
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= loader-ico
+DISTVERSION= 1.1.0
+CATEGORIES= graphics enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2011-12-02/base/
+PKGNAMEPREFIX= evas-
+DISTNAME= evas-${DISTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= A hardware accelerated canvas API (ICO loader)
+
+LICENSE= BSD
+
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= evas librt_hack libtool_hack
+USE_GNOME= gnomehack pkgconfig
+USE_LDCONFIG= yes
+
+MAKEDIRS= ${WRKSRC}/src/modules/loaders/ico
+
+.include "../evas-core/Makefile.inc"
+CONFIGURE_ARGS+= --enable-image-loader-ico
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/\.libs,${LOCALBASE}/lib,' \
+ -e 's,\$$\(top_builddir\)/src/lib/libevas\.la,-levas,' \
+ ${MAKEDIRS:S,$,/Makefile.in,}
+
+do-build:
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
+
+do-install:
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
+
+.include <bsd.port.mk>