aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-loader-psd
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-03 12:24:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-03 12:24:26 +0000
commit17a043ebcdd6316843b85d6bccef676314db0b05 (patch)
tree8750231324508086cb75cdcadc02339d878c0c5d /graphics/evas-loader-psd
parent41f553bf27d80a550bc4bd11a9b9d9b3c51520d1 (diff)
downloadports-17a043ebcdd6316843b85d6bccef676314db0b05.tar.gz
ports-17a043ebcdd6316843b85d6bccef676314db0b05.zip
Notes
Diffstat (limited to 'graphics/evas-loader-psd')
-rw-r--r--graphics/evas-loader-psd/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/evas-loader-psd/Makefile b/graphics/evas-loader-psd/Makefile
index 37bbc2fade3f..349c071528a7 100644
--- a/graphics/evas-loader-psd/Makefile
+++ b/graphics/evas-loader-psd/Makefile
@@ -18,6 +18,11 @@ DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_LDCONFIG= yes
@@ -33,11 +38,11 @@ post-patch:
${MAKEDIRS:S,$,/Makefile.in,}
do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MYMAKE} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
.include <bsd.port.mk>