aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2006-07-06 15:48:49 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2006-07-06 15:48:49 +0000
commit749238deccb4427e47256e68c2e2a1b49d6ab87b (patch)
treec9f29ed6693176b3a2c9a0f98f178bec0f641cb7 /graphics/evas
parentb1fb8d953774c6b558dca209c8524bfdb1833e21 (diff)
downloadports-749238deccb4427e47256e68c2e2a1b49d6ab87b.tar.gz
ports-749238deccb4427e47256e68c2e2a1b49d6ab87b.zip
Notes
Diffstat (limited to 'graphics/evas')
-rw-r--r--graphics/evas/Makefile16
-rw-r--r--graphics/evas/pkg-plist6
2 files changed, 20 insertions, 2 deletions
diff --git a/graphics/evas/Makefile b/graphics/evas/Makefile
index ecca50e070ca..6cf7237ee2a3 100644
--- a/graphics/evas/Makefile
+++ b/graphics/evas/Makefile
@@ -7,7 +7,7 @@
PORTNAME= evas
PORTVERSION= 0.9.9.029
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://enlightenment.freedesktop.org/files/
@@ -26,4 +26,16 @@ USE_GNOME= gnomehack pkgconfig gnometarget
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-.include <bsd.port.mk>
+OPTIONS= GL "Enable GL support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GL)
+CONFIGURE_ARGS+= --enable-gl-x11
+PLIST_SUB+= WITH_GL=""
+USE_GL= yes
+.else
+PLIST_SUB+= WITH_GL="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/evas/pkg-plist b/graphics/evas/pkg-plist
index 672c10225777..fec4164d8ac0 100644
--- a/graphics/evas/pkg-plist
+++ b/graphics/evas/pkg-plist
@@ -1,11 +1,13 @@
bin/evas-config
bin/evas_buffer_test
+%%WITH_GL%%bin/evas_gl_x11_test
bin/evas_software_x11_perf_load
bin/evas_software_x11_perf_test
bin/evas_software_x11_test
bin/evas_xrender_x11_test
include/Evas.h
include/Evas_Engine_Buffer.h
+%%WITH_GL%%include/Evas_Engine_GL_X11.h
include/Evas_Engine_Software_X11.h
include/Evas_Engine_XRender_X11.h
lib/libevas.a
@@ -15,6 +17,9 @@ lib/libevas.so.1
lib/evas/modules/engines/buffer/module.a
lib/evas/modules/engines/buffer/module.la
lib/evas/modules/engines/buffer/module.so
+%%WITH_GL%%lib/evas/modules/engines/gl_x11/module.a
+%%WITH_GL%%lib/evas/modules/engines/gl_x11/module.la
+%%WITH_GL%%lib/evas/modules/engines/gl_x11/module.so
lib/evas/modules/engines/software_generic/module.a
lib/evas/modules/engines/software_generic/module.la
lib/evas/modules/engines/software_generic/module.so
@@ -96,6 +101,7 @@ libdata/pkgconfig/evas.pc
@dirrm lib/evas/modules/engines/xrender_x11
@dirrm lib/evas/modules/engines/software_x11
@dirrm lib/evas/modules/engines/software_generic
+%%WITH_GL%%@dirrm lib/evas/modules/engines/gl_x11
@dirrm lib/evas/modules/engines/buffer
@dirrm lib/evas/modules/engines
@dirrm lib/evas/modules