aboutsummaryrefslogtreecommitdiff
path: root/graphics/evince
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-07-14 23:28:42 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-07-14 23:28:42 +0000
commit8e36928beb1fd8a10b44a116f5b6626c3c700a9e (patch)
tree5753fc3672c0598c494b16a908987b066d2547f8 /graphics/evince
parent0721553f8f8e172e14c61030ef9c435c20bbdcaa (diff)
downloadports-8e36928beb1fd8a10b44a116f5b6626c3c700a9e.tar.gz
ports-8e36928beb1fd8a10b44a116f5b6626c3c700a9e.zip
Notes
Diffstat (limited to 'graphics/evince')
-rw-r--r--graphics/evince/Makefile58
-rw-r--r--graphics/evince/pkg-plist254
2 files changed, 161 insertions, 151 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 8d4d10a46701..a92a4c3691ce 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -1,32 +1,31 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/graphics/evince/Makefile 20078 2014-11-13 09:06:29Z gusi $
PORTNAME= evince
PORTVERSION= 3.14.2
+PORTREVISION?= 1
CATEGORIES= graphics print gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT= GNOME 3 multi-format document viewer
+COMMENT?= GNOME 3 multi-format document viewer
BUILD_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
itstool:${PORTSDIR}/textproc/itstool \
adwaita-icon-theme>=0:${PORTSDIR}/x11-themes/adwaita-icon-theme \
gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
- libspectre.so:${PORTSDIR}/print/libspectre \
- libsecret-1.so:${PORTSDIR}/security/libsecret
+ libspectre.so:${PORTSDIR}/print/libspectre
RUN_DEPENDS= gnome-icon-theme>=0:${PORTSDIR}/misc/gnome-icon-theme \
adwaita-icon-theme>=0:${PORTSDIR}/x11-themes/adwaita-icon-theme \
gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
-CONFLICT_INSTALL= evince-lite-*
+SLAVEPORT?= no
USES= compiler:c++11-lib desktop-file-utils gettext gmake libtool \
pathfix pkgconfig tar:xz
-USE_GNOME= gnomeprefix gtk30 intlhack introspection:build
+USE_GNOME= gtk30 intlhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_XORG= ice
@@ -34,25 +33,43 @@ INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include -Wno-format-nonliteral
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS= --enable-introspection
+
+.if ${SLAVEPORT} == lite
+CONFIGURE_ARGS+=--disable-introspection \
+ --disable-libgnome-desktop \
+ --disable-thumbnailer \
+ --disable-previewer
+.else
+USE_GNOME+= introspection:build
+CONFIGURE_ARGS+= --enable-introspection
+.endif
GLIB_SCHEMAS= org.gnome.Evince.gschema.xml
PLIST_SUB= VERSION=3.0
-OPTIONS_DEFINE= DVI XPS T1LIB NAUTILUS KEYRING COMICS IMPRESS DJVU
-OPTIONS_DEFAULT=NAUTILUS KEYRING COMICS XPS
+OPTIONS_DEFINE= COMICS DJVU DVI KEYRING NAUTILUS T1LIB XPS
+OPTIONS_DEFAULT=COMICS KEYRING NAUTILUS XPS
DVI_DESC= DVI viewer support
T1LIB_DESC= T1LIB for TYPE1 fonts to DVI (Enables DVI)
NAUTILUS_DESC= Nautilus plugin
-KEYRING_DESC= Gnome-Keyring without Nautilus
+KEYRING_DESC= Keyring support
COMICS_DESC= Comic book archives support
-IMPRESS_DESC= Impress presentations support
DJVU_DESC= DJVU support
XPS_DESC= XPS support
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:NDBUS} && ${SLAVEPORT} == lite
+CONFIGURE_ARGS+=--disable-dbus
+.else
+CONFIGURE_ARGS+=--enable-dbus
+.endif
+
+.if ${OSVERSION} < 900000
+BROKEN= Fails to build
+.endif
+
.if ${PORT_OPTIONS:MDVI} || ${PORT_OPTIONS:MT1LIB}
USE_TEX= latex
@@ -69,6 +86,12 @@ CONFIGURE_ARGS+= --disable-dvi
PLIST_SUB+= DVI="@comment "
.endif
+.if ${PORT_OPTIONS:MKEYRING}
+LIB_DEPENDS+= libsecret-1.so:${PORTSDIR}/security/libsecret
+.else
+CONFIGURE_ARGS+=--without-keyring
+.endif
+
.if ${PORT_OPTIONS:MNAUTILUS}
USE_GNOME+= nautilus3
CONFIGURE_ARGS+= --enable-nautilus
@@ -76,23 +99,10 @@ PLIST_SUB+= NAUTILUS=""
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
RUN_DEPENDS+= ${LOCALBASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
-.if ${PORT_OPTIONS:MKEYRING}
-LIB_DEPENDS+= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
-.else
-CONFIGURE_ARGS+= --without-keyring
-.endif
CONFIGURE_ARGS+= --disable-nautilus
PLIST_SUB+= NAUTILUS="@comment "
.endif
-.if ${PORT_OPTIONS:MIMPRESS}
-CONFIGURE_ARGS+= --enable-impress
-PLIST_SUB+= IMPRESS=""
-.else
-CONFIGURE_ARGS+= --disable-impress
-PLIST_SUB+= IMPRESS="@comment "
-.endif
-
.if ${PORT_OPTIONS:MXPS}
LIB_DEPENDS+= libgxps.so:${PORTSDIR}/graphics/libgxps
CONFIGURE_ARGS+= --enable-xps
diff --git a/graphics/evince/pkg-plist b/graphics/evince/pkg-plist
index 6d995c303bba..8ba5cf7d7078 100644
--- a/graphics/evince/pkg-plist
+++ b/graphics/evince/pkg-plist
@@ -99,133 +99,6 @@ share/appdata/evince.appdata.xml
share/applications/evince-previewer.desktop
share/applications/evince.desktop
share/dbus-1/services/org.gnome.evince.Daemon.service
-%%DOCSDIR%%/EggFindBar.html
-%%DOCSDIR%%/EvFileMonitor.html
-%%DOCSDIR%%/EvHistory.html
-%%DOCSDIR%%/EvMessageArea.html
-%%DOCSDIR%%/EvPageAction.html
-%%DOCSDIR%%/EvPageActionWidget.html
-%%DOCSDIR%%/EvPasswordView.html
-%%DOCSDIR%%/EvProgressMessageArea.html
-%%DOCSDIR%%/EvSidebar.html
-%%DOCSDIR%%/EvSidebarAttachments.html
-%%DOCSDIR%%/EvSidebarLayers.html
-%%DOCSDIR%%/EvSidebarLinks.html
-%%DOCSDIR%%/EvSidebarPage.html
-%%DOCSDIR%%/EvSidebarThumbnails.html
-%%DOCSDIR%%/EvWindow.html
-%%DOCSDIR%%/api-index-full.html
-%%DOCSDIR%%/evince-ev-application.html
-%%DOCSDIR%%/evince-ev-keyring.html
-%%DOCSDIR%%/evince-ev-media-player-keys.html
-%%DOCSDIR%%/evince-ev-metadata.html
-%%DOCSDIR%%/evince-ev-properties-dialog.html
-%%DOCSDIR%%/evince-ev-properties-fonts.html
-%%DOCSDIR%%/evince-ev-properties-license.html
-%%DOCSDIR%%/evince-ev-utils.html
-%%DOCSDIR%%/evince-ev-window-title.html
-%%DOCSDIR%%/evince-frontend.html
-%%DOCSDIR%%/evince.devhelp2
-%%DOCSDIR%%/home.png
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/index.sgml
-%%DOCSDIR%%/left-insensitive.png
-%%DOCSDIR%%/left.png
-%%DOCSDIR%%/licence.html
-%%DOCSDIR%%/object-tree.html
-%%DOCSDIR%%/right-insensitive.png
-%%DOCSDIR%%/right.png
-%%DOCSDIR%%/style.css
-%%DOCSDIR%%/up-insensitive.png
-%%DOCSDIR%%/up.png
-share/doc/libevdocument/EvAnnotation.html
-share/doc/libevdocument/EvAsyncRenderer.html
-share/doc/libevdocument/EvAttachment.html
-share/doc/libevdocument/EvDocument.html
-share/doc/libevdocument/EvDocumentAnnotations.html
-share/doc/libevdocument/EvDocumentAttachments.html
-share/doc/libevdocument/EvDocumentFind.html
-share/doc/libevdocument/EvDocumentFonts.html
-share/doc/libevdocument/EvDocumentForms.html
-share/doc/libevdocument/EvDocumentImages.html
-share/doc/libevdocument/EvDocumentInfo.html
-share/doc/libevdocument/EvDocumentLayers.html
-share/doc/libevdocument/EvDocumentLinks.html
-share/doc/libevdocument/EvDocumentPrint.html
-share/doc/libevdocument/EvDocumentSecurity.html
-share/doc/libevdocument/EvDocumentText.html
-share/doc/libevdocument/EvDocumentTransition.html
-share/doc/libevdocument/EvFileExporter.html
-share/doc/libevdocument/EvFormField.html
-share/doc/libevdocument/EvImage.html
-share/doc/libevdocument/EvLayer.html
-share/doc/libevdocument/EvPage.html
-share/doc/libevdocument/EvRenderContext.html
-share/doc/libevdocument/EvSelection.html
-share/doc/libevdocument/annotation-glossary.html
-share/doc/libevdocument/api-index-3-6.html
-share/doc/libevdocument/api-index-3-10.html
-share/doc/libevdocument/api-index-3-12.html
-share/doc/libevdocument/api-index-3-4.html
-share/doc/libevdocument/api-index-3-8.html
-share/doc/libevdocument/api-index-deprecated.html
-share/doc/libevdocument/api-index-full.html
-share/doc/libevdocument/document-data.html
-share/doc/libevdocument/document-helpers.html
-share/doc/libevdocument/document-interfaces.html
-share/doc/libevdocument/home.png
-share/doc/libevdocument/index.html
-share/doc/libevdocument/index.sgml
-share/doc/libevdocument/left-insensitive.png
-share/doc/libevdocument/left.png
-share/doc/libevdocument/libevdocument-EvDocumentMisc.html
-share/doc/libevdocument/libevdocument-Version-checks.html
-share/doc/libevdocument/libevdocument-ev-backends-manager.html
-share/doc/libevdocument/libevdocument-ev-document-factory.html
-share/doc/libevdocument/libevdocument-ev-file-helpers.html
-share/doc/libevdocument/libevdocument-ev-init.html
-share/doc/libevdocument/libevdocument-ev-link-action.html
-share/doc/libevdocument/libevdocument-ev-link-dest.html
-share/doc/libevdocument/libevdocument-ev-link.html
-share/doc/libevdocument/libevdocument-ev-mapping.html
-share/doc/libevdocument/libevdocument-ev-transition-effect.html
-share/doc/libevdocument/libevdocument.devhelp2
-share/doc/libevdocument/licence.html
-share/doc/libevdocument/object-tree.html
-share/doc/libevdocument/right-insensitive.png
-share/doc/libevdocument/right.png
-share/doc/libevdocument/style.css
-share/doc/libevdocument/up-insensitive.png
-share/doc/libevdocument/up.png
-share/doc/libevview/EvJob.html
-share/doc/libevview/api-index-3-6.html
-share/doc/libevview/api-index-3-8.html
-share/doc/libevview/api-index-3-10.html
-share/doc/libevview/api-index-deprecated.html
-share/doc/libevview/api-index-full.html
-share/doc/libevview/home.png
-share/doc/libevview/index.html
-share/doc/libevview/index.sgml
-share/doc/libevview/left-insensitive.png
-share/doc/libevview/left.png
-share/doc/libevview/libevview-ev-annotation-window.html
-share/doc/libevview/libevview-ev-document-model.html
-share/doc/libevview/libevview-ev-job-scheduler.html
-share/doc/libevview/libevview-ev-page-cache.html
-share/doc/libevview/libevview-ev-print-operation.html
-share/doc/libevview/libevview-ev-stock-icons.html
-share/doc/libevview/libevview-ev-view-cursor.html
-share/doc/libevview/libevview-ev-view-presentation.html
-share/doc/libevview/libevview-ev-view.html
-share/doc/libevview/libevview.devhelp2
-share/doc/libevview/licence.html
-share/doc/libevview/object-tree.html
-share/doc/libevview/right-insensitive.png
-share/doc/libevview/right.png
-share/doc/libevview/style.css
-share/doc/libevview/up-insensitive.png
-share/doc/libevview/up.png
-share/doc/libevview/view-view.html
%%DATADIR%%/hand-open.png
%%DATADIR%%/icons/hicolor/16x16/actions/object-rotate-left.png
%%DATADIR%%/icons/hicolor/16x16/actions/object-rotate-right.png
@@ -268,6 +141,133 @@ share/doc/libevview/view-view.html
%%DATADIR%%/icons/hicolor/scalable/mimetypes/x-office-presentation.svg
share/gir-1.0/EvinceDocument-%%VERSION%%.gir
share/gir-1.0/EvinceView-%%VERSION%%.gir
+share/gtk-doc/html/evince/EggFindBar.html
+share/gtk-doc/html/evince/EvFileMonitor.html
+share/gtk-doc/html/evince/EvHistory.html
+share/gtk-doc/html/evince/EvMessageArea.html
+share/gtk-doc/html/evince/EvPageAction.html
+share/gtk-doc/html/evince/EvPageActionWidget.html
+share/gtk-doc/html/evince/EvPasswordView.html
+share/gtk-doc/html/evince/EvProgressMessageArea.html
+share/gtk-doc/html/evince/EvSidebar.html
+share/gtk-doc/html/evince/EvSidebarAttachments.html
+share/gtk-doc/html/evince/EvSidebarLayers.html
+share/gtk-doc/html/evince/EvSidebarLinks.html
+share/gtk-doc/html/evince/EvSidebarPage.html
+share/gtk-doc/html/evince/EvSidebarThumbnails.html
+share/gtk-doc/html/evince/EvWindow.html
+share/gtk-doc/html/evince/api-index-full.html
+share/gtk-doc/html/evince/evince-ev-application.html
+share/gtk-doc/html/evince/evince-ev-keyring.html
+share/gtk-doc/html/evince/evince-ev-media-player-keys.html
+share/gtk-doc/html/evince/evince-ev-metadata.html
+share/gtk-doc/html/evince/evince-ev-properties-dialog.html
+share/gtk-doc/html/evince/evince-ev-properties-fonts.html
+share/gtk-doc/html/evince/evince-ev-properties-license.html
+share/gtk-doc/html/evince/evince-ev-utils.html
+share/gtk-doc/html/evince/evince-ev-window-title.html
+share/gtk-doc/html/evince/evince-frontend.html
+share/gtk-doc/html/evince/evince.devhelp2
+share/gtk-doc/html/evince/home.png
+share/gtk-doc/html/evince/index.html
+share/gtk-doc/html/evince/index.sgml
+share/gtk-doc/html/evince/left-insensitive.png
+share/gtk-doc/html/evince/left.png
+share/gtk-doc/html/evince/licence.html
+share/gtk-doc/html/evince/object-tree.html
+share/gtk-doc/html/evince/right-insensitive.png
+share/gtk-doc/html/evince/right.png
+share/gtk-doc/html/evince/style.css
+share/gtk-doc/html/evince/up-insensitive.png
+share/gtk-doc/html/evince/up.png
+share/gtk-doc/html/libevdocument/EvAnnotation.html
+share/gtk-doc/html/libevdocument/EvAsyncRenderer.html
+share/gtk-doc/html/libevdocument/EvAttachment.html
+share/gtk-doc/html/libevdocument/EvDocument.html
+share/gtk-doc/html/libevdocument/EvDocumentAnnotations.html
+share/gtk-doc/html/libevdocument/EvDocumentAttachments.html
+share/gtk-doc/html/libevdocument/EvDocumentFind.html
+share/gtk-doc/html/libevdocument/EvDocumentFonts.html
+share/gtk-doc/html/libevdocument/EvDocumentForms.html
+share/gtk-doc/html/libevdocument/EvDocumentImages.html
+share/gtk-doc/html/libevdocument/EvDocumentInfo.html
+share/gtk-doc/html/libevdocument/EvDocumentLayers.html
+share/gtk-doc/html/libevdocument/EvDocumentLinks.html
+share/gtk-doc/html/libevdocument/EvDocumentPrint.html
+share/gtk-doc/html/libevdocument/EvDocumentSecurity.html
+share/gtk-doc/html/libevdocument/EvDocumentText.html
+share/gtk-doc/html/libevdocument/EvDocumentTransition.html
+share/gtk-doc/html/libevdocument/EvFileExporter.html
+share/gtk-doc/html/libevdocument/EvFormField.html
+share/gtk-doc/html/libevdocument/EvImage.html
+share/gtk-doc/html/libevdocument/EvLayer.html
+share/gtk-doc/html/libevdocument/EvPage.html
+share/gtk-doc/html/libevdocument/EvRenderContext.html
+share/gtk-doc/html/libevdocument/EvSelection.html
+share/gtk-doc/html/libevdocument/annotation-glossary.html
+share/gtk-doc/html/libevdocument/api-index-3-10.html
+share/gtk-doc/html/libevdocument/api-index-3-12.html
+share/gtk-doc/html/libevdocument/api-index-3-4.html
+share/gtk-doc/html/libevdocument/api-index-3-6.html
+share/gtk-doc/html/libevdocument/api-index-3-8.html
+share/gtk-doc/html/libevdocument/api-index-deprecated.html
+share/gtk-doc/html/libevdocument/api-index-full.html
+share/gtk-doc/html/libevdocument/document-data.html
+share/gtk-doc/html/libevdocument/document-helpers.html
+share/gtk-doc/html/libevdocument/document-interfaces.html
+share/gtk-doc/html/libevdocument/home.png
+share/gtk-doc/html/libevdocument/index.html
+share/gtk-doc/html/libevdocument/index.sgml
+share/gtk-doc/html/libevdocument/left-insensitive.png
+share/gtk-doc/html/libevdocument/left.png
+share/gtk-doc/html/libevdocument/libevdocument-EvDocumentMisc.html
+share/gtk-doc/html/libevdocument/libevdocument-Version-checks.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-backends-manager.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-document-factory.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-file-helpers.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-init.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-link-action.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-link-dest.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-link.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-mapping.html
+share/gtk-doc/html/libevdocument/libevdocument-ev-transition-effect.html
+share/gtk-doc/html/libevdocument/libevdocument.devhelp2
+share/gtk-doc/html/libevdocument/licence.html
+share/gtk-doc/html/libevdocument/object-tree.html
+share/gtk-doc/html/libevdocument/right-insensitive.png
+share/gtk-doc/html/libevdocument/right.png
+share/gtk-doc/html/libevdocument/style.css
+share/gtk-doc/html/libevdocument/up-insensitive.png
+share/gtk-doc/html/libevdocument/up.png
+share/gtk-doc/html/libevview/EvJob.html
+share/gtk-doc/html/libevview/api-index-3-10.html
+share/gtk-doc/html/libevview/api-index-3-6.html
+share/gtk-doc/html/libevview/api-index-3-8.html
+share/gtk-doc/html/libevview/api-index-deprecated.html
+share/gtk-doc/html/libevview/api-index-full.html
+share/gtk-doc/html/libevview/home.png
+share/gtk-doc/html/libevview/index.html
+share/gtk-doc/html/libevview/index.sgml
+share/gtk-doc/html/libevview/left-insensitive.png
+share/gtk-doc/html/libevview/left.png
+share/gtk-doc/html/libevview/libevview-ev-annotation-window.html
+share/gtk-doc/html/libevview/libevview-ev-document-model.html
+share/gtk-doc/html/libevview/libevview-ev-job-scheduler.html
+share/gtk-doc/html/libevview/libevview-ev-page-cache.html
+share/gtk-doc/html/libevview/libevview-ev-print-operation.html
+share/gtk-doc/html/libevview/libevview-ev-stock-icons.html
+share/gtk-doc/html/libevview/libevview-ev-view-cursor.html
+share/gtk-doc/html/libevview/libevview-ev-view-presentation.html
+share/gtk-doc/html/libevview/libevview-ev-view.html
+share/gtk-doc/html/libevview/libevview.devhelp2
+share/gtk-doc/html/libevview/licence.html
+share/gtk-doc/html/libevview/object-tree.html
+share/gtk-doc/html/libevview/right-insensitive.png
+share/gtk-doc/html/libevview/right.png
+share/gtk-doc/html/libevview/style.css
+share/gtk-doc/html/libevview/up-insensitive.png
+share/gtk-doc/html/libevview/up.png
+share/gtk-doc/html/libevview/view-view.html
share/help/C/evince/annotation-properties.page
share/help/C/evince/annotations-delete.page
share/help/C/evince/annotations-disabled.page