aboutsummaryrefslogtreecommitdiff
path: root/graphics/evince
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /graphics/evince
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'graphics/evince')
-rw-r--r--graphics/evince/Makefile16
-rw-r--r--graphics/evince/distinfo6
-rw-r--r--graphics/evince/files/patch-backend_pdf_ev-poppler.cc38
-rw-r--r--graphics/evince/files/patch-backend_ps_ps-interpreter.c10
-rw-r--r--graphics/evince/files/patch-configure24
-rw-r--r--graphics/evince/pkg-plist150
6 files changed, 122 insertions, 122 deletions
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 104f95515e60..8394cc0c93f5 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -3,12 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/evince/Makefile,v 1.64 2007/03/13 12:00:09 ahze Exp $
+# $MCom: ports/graphics/evince/Makefile,v 1.81 2007/10/16 03:16:14 mezz Exp $
#
PORTNAME= evince
-PORTVERSION= 0.8.3
-PORTREVISION= 2
+PORTVERSION= 2.20.1
CATEGORIES= graphics print gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -29,8 +28,8 @@ USE_GHOSTSCRIPT=yes
INSTALLS_OMF= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui libgnomeprintui \
desktopfileutils gnomedocutils
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= evince.schemas evince-thumbnailer.schemas \
evince-thumbnailer-ps.schemas
@@ -79,7 +78,7 @@ CONFIGURE_ARGS+= --enable-impress
CONFIGURE_ARGS+= --disable-impress
.endif
-.if exists(${X11BASE}/bin/djview)
+.if exists(${LOCALBASE}/bin/djview)
DJVU_DIR?= # empty
.else
DJVU_DIR?= -nox11
@@ -106,9 +105,8 @@ RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar \
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|execinfo.h|#|g ; s|[$$]POPPLER_VERSION|9|g ; \
- s| poppler-glib <= [$$]POPPLER_MAX_REQUIRED||g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|execinfo.h|#|g' \
+ ${WRKSRC}/configure
post-install:
@-update-desktop-database
diff --git a/graphics/evince/distinfo b/graphics/evince/distinfo
index 5401d88284e7..a08810fb8ba7 100644
--- a/graphics/evince/distinfo
+++ b/graphics/evince/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/evince-0.8.3.tar.bz2) = 0603d3f3f5648c88f10f75c89807c3d1
-SHA256 (gnome2/evince-0.8.3.tar.bz2) = 2b02cacecbcde7d2849e2b40239d7cdae3e0f8e117c529249ac5d327e605baac
-SIZE (gnome2/evince-0.8.3.tar.bz2) = 1515083
+MD5 (gnome2/evince-2.20.1.tar.bz2) = c0f3e4d5279ef3d08cc46b752e230c01
+SHA256 (gnome2/evince-2.20.1.tar.bz2) = 9435c67974b59979b8d84224ed63128cd428fc9bb746f6b333c400619c7f182e
+SIZE (gnome2/evince-2.20.1.tar.bz2) = 1613601
diff --git a/graphics/evince/files/patch-backend_pdf_ev-poppler.cc b/graphics/evince/files/patch-backend_pdf_ev-poppler.cc
deleted file mode 100644
index b0b698b531fd..000000000000
--- a/graphics/evince/files/patch-backend_pdf_ev-poppler.cc
+++ /dev/null
@@ -1,38 +0,0 @@
---- backend/pdf/ev-poppler.cc.orig 2007-09-11 02:17:19.000000000 -0400
-+++ backend/pdf/ev-poppler.cc 2007-09-11 02:22:10.000000000 -0400
-@@ -654,7 +654,7 @@ pdf_document_get_text (EvDocument *docum
- r.x2 = rect->x2;
- r.y2 = height - rect->y1;
-
-- text = poppler_page_get_text (poppler_page, &r);
-+ text = poppler_page_get_text (poppler_page, POPPLER_SELECTION_GLYPH, &r);
-
- g_object_unref (poppler_page);
-
-@@ -1636,7 +1636,7 @@ pdf_selection_render_selection (EvSelect
- rc->scale, rc->rotation, *pixbuf,
- (PopplerRectangle *)points,
- (PopplerRectangle *)old_points,
-- POPPLER_SELECTION_NORMAL,
-+ POPPLER_SELECTION_GLYPH,
- text,
- base);
- #endif
-@@ -1655,7 +1655,7 @@ pdf_selection_get_selection_region (EvSe
-
- set_rc_data (pdf_document, rc);
-
-- retval = poppler_page_get_selection_region ((PopplerPage *)rc->data, rc->scale, (PopplerRectangle *) points);
-+ retval = poppler_page_get_selection_region ((PopplerPage *)rc->data, rc->scale, POPPLER_SELECTION_GLYPH, (PopplerRectangle *) points);
-
- return retval;
- }
-@@ -1676,7 +1676,7 @@ pdf_selection_get_selection_map (EvSelec
- points.x1 = 0.0;
- points.y1 = 0.0;
- poppler_page_get_size (poppler_page, &(points.x2), &(points.y2));
-- retval = poppler_page_get_selection_region (poppler_page, 1.0, &points);
-+ retval = poppler_page_get_selection_region (poppler_page, 1.0, POPPLER_SELECTION_GLYPH, &points);
- g_object_unref (poppler_page);
-
- return retval;
diff --git a/graphics/evince/files/patch-backend_ps_ps-interpreter.c b/graphics/evince/files/patch-backend_ps_ps-interpreter.c
deleted file mode 100644
index 9cd98bbefae7..000000000000
--- a/graphics/evince/files/patch-backend_ps_ps-interpreter.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- backend/ps/ps-interpreter.c.orig Tue Mar 13 07:00:12 2007
-+++ backend/ps/ps-interpreter.c Tue Mar 13 07:00:21 2007
-@@ -29,6 +29,7 @@
- #include <string.h>
- #include <stdlib.h>
- #include <sys/wait.h>
-+#include <signal.h>
- #include <errno.h>
-
- #include "ps-interpreter.h"
diff --git a/graphics/evince/files/patch-configure b/graphics/evince/files/patch-configure
index dc2323992061..9ca1314d6329 100644
--- a/graphics/evince/files/patch-configure
+++ b/graphics/evince/files/patch-configure
@@ -1,6 +1,15 @@
---- configure.orig Mon Dec 18 18:05:50 2006
-+++ configure Mon Dec 18 18:06:30 2006
-@@ -25315,7 +25315,7 @@ else
+--- configure.orig 2007-08-27 23:27:26.000000000 -0400
++++ configure 2007-08-27 23:29:35.000000000 -0400
+@@ -25411,7 +25411,7 @@ fi
+
+
+
+-for ac_header in execinfo.h
++for ac_header in #
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
+@@ -26204,7 +26204,7 @@ else
echo "${ECHO_T}yes" >&6
enable_cairo_pdf=yes
fi
@@ -9,3 +18,12 @@
cat >>confdefs.h <<\_ACEOF
#define HAVE_CAIRO_PDF 1
+@@ -26283,7 +26283,7 @@ else
+ echo "${ECHO_T}yes" >&6
+ enable_cairo_ps=yes
+ fi
+- if test x$enable_cairo_ps == xyes; then
++ if test x$enable_cairo_ps = xyes; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_CAIRO_PS 1
diff --git a/graphics/evince/pkg-plist b/graphics/evince/pkg-plist
index 281910505951..2014c40f8274 100644
--- a/graphics/evince/pkg-plist
+++ b/graphics/evince/pkg-plist
@@ -3,6 +3,7 @@ bin/evince-thumbnailer
%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.a
%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.la
%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.so
+share/applications/evince.desktop
%%DOCSDIR%%/EvAttachment.html
%%DOCSDIR%%/EvJobPrint.html
%%DOCSDIR%%/EvNavigationAction.html
@@ -65,25 +66,30 @@ bin/evince-thumbnailer
%%DOCSDIR%%/right.png
%%DOCSDIR%%/style.css
%%DOCSDIR%%/up.png
-share/gnome/applications/evince.desktop
-share/gnome/evince/evince-password.glade
-share/gnome/evince/evince-preview-toolbar.xml
-share/gnome/evince/evince-properties.glade
-share/gnome/evince/evince-toolbar.xml
-share/gnome/evince/evince-ui.xml
-share/gnome/evince/hand-open.png
-share/gnome/evince/icons/hicolor/16x16/actions/view-page-continuous.png
-share/gnome/evince/icons/hicolor/16x16/actions/view-page-facing.png
-share/gnome/evince/icons/hicolor/16x16/actions/zoom-fit-page.png
-share/gnome/evince/icons/hicolor/16x16/actions/zoom-fit-width.png
-share/gnome/evince/icons/hicolor/22x22/actions/view-page-continuous.png
-share/gnome/evince/icons/hicolor/22x22/actions/view-page-facing.png
-share/gnome/evince/icons/hicolor/22x22/actions/zoom-fit-page.png
-share/gnome/evince/icons/hicolor/22x22/actions/zoom-fit-width.png
-share/gnome/evince/icons/hicolor/24x24/actions/view-page-continuous.png
-share/gnome/evince/icons/hicolor/24x24/actions/view-page-facing.png
-share/gnome/evince/icons/hicolor/24x24/actions/zoom-fit-page.png
-share/gnome/evince/icons/hicolor/24x24/actions/zoom-fit-width.png
+%%DATADIR%%/evince-password.glade
+%%DATADIR%%/evince-properties.glade
+%%DATADIR%%/evince-toolbar.xml
+%%DATADIR%%/evince-ui.xml
+%%DATADIR%%/hand-open.png
+%%DATADIR%%/icons/hicolor/16x16/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/16x16/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/16x16/actions/zoom-fit-page.png
+%%DATADIR%%/icons/hicolor/16x16/actions/zoom-fit-width.png
+%%DATADIR%%/icons/hicolor/16x16/actions/zoom.png
+%%DATADIR%%/icons/hicolor/22x22/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/22x22/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/22x22/actions/zoom-fit-page.png
+%%DATADIR%%/icons/hicolor/22x22/actions/zoom-fit-width.png
+%%DATADIR%%/icons/hicolor/22x22/actions/zoom.png
+%%DATADIR%%/icons/hicolor/24x24/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/24x24/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/24x24/actions/zoom-fit-page.png
+%%DATADIR%%/icons/hicolor/24x24/actions/zoom-fit-width.png
+%%DATADIR%%/icons/hicolor/24x24/actions/zoom.png
+%%DATADIR%%/icons/hicolor/32x32/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/32x32/actions/view-page-facing.png
+%%DATADIR%%/icons/hicolor/48x48/actions/view-page-continuous.png
+%%DATADIR%%/icons/hicolor/48x48/actions/view-page-facing.png
share/gnome/help/evince/C/evince.xml
share/gnome/help/evince/C/figures/evince_start_window.png
share/gnome/help/evince/C/legal.xml
@@ -103,8 +109,14 @@ share/gnome/help/evince/fr/evince.xml
share/gnome/help/evince/fr/figures/evince_start_window.png
share/gnome/help/evince/it/evince.xml
share/gnome/help/evince/it/figures/evince_start_window.png
+share/gnome/help/evince/ja/evince.xml
+share/gnome/help/evince/ja/figures/evince_start_window.png
share/gnome/help/evince/nl/evince.xml
share/gnome/help/evince/nl/figures/evince_start_window.png
+share/gnome/help/evince/oc/evince.xml
+share/gnome/help/evince/oc/figures/evince_start_window.png
+share/gnome/help/evince/pt_BR/evince.xml
+share/gnome/help/evince/pt_BR/figures/evince_start_window.png
share/gnome/help/evince/ru/evince.xml
share/gnome/help/evince/ru/figures/evince_start_window.png
share/gnome/help/evince/sr/evince.xml
@@ -113,20 +125,6 @@ share/gnome/help/evince/sv/evince.xml
share/gnome/help/evince/sv/figures/evince_start_window.png
share/gnome/help/evince/uk/evince.xml
share/gnome/help/evince/uk/figures/evince_start_window.png
-share/gnome/omf/evince/evince-C.omf
-share/gnome/omf/evince/evince-bg.omf
-share/gnome/omf/evince/evince-ca.omf
-share/gnome/omf/evince/evince-el.omf
-share/gnome/omf/evince/evince-en_GB.omf
-share/gnome/omf/evince/evince-es.omf
-share/gnome/omf/evince/evince-fi.omf
-share/gnome/omf/evince/evince-fr.omf
-share/gnome/omf/evince/evince-it.omf
-share/gnome/omf/evince/evince-nl.omf
-share/gnome/omf/evince/evince-ru.omf
-share/gnome/omf/evince/evince-sr.omf
-share/gnome/omf/evince/evince-sv.omf
-share/gnome/omf/evince/evince-uk.omf
share/icons/hicolor/16x16/apps/evince.png
share/icons/hicolor/22x22/apps/evince.png
share/icons/hicolor/24x24/apps/evince.png
@@ -134,6 +132,7 @@ share/icons/hicolor/48x48/apps/evince.png
share/icons/hicolor/scalable/apps/evince.svg
share/locale/ar/LC_MESSAGES/evince.mo
share/locale/be/LC_MESSAGES/evince.mo
+share/locale/be@latin/LC_MESSAGES/evince.mo
share/locale/bg/LC_MESSAGES/evince.mo
share/locale/bn/LC_MESSAGES/evince.mo
share/locale/bn_IN/LC_MESSAGES/evince.mo
@@ -190,6 +189,7 @@ share/locale/sr/LC_MESSAGES/evince.mo
share/locale/sr@Latn/LC_MESSAGES/evince.mo
share/locale/sv/LC_MESSAGES/evince.mo
share/locale/ta/LC_MESSAGES/evince.mo
+share/locale/te/LC_MESSAGES/evince.mo
share/locale/th/LC_MESSAGES/evince.mo
share/locale/tr/LC_MESSAGES/evince.mo
share/locale/uk/LC_MESSAGES/evince.mo
@@ -198,23 +198,24 @@ share/locale/wa/LC_MESSAGES/evince.mo
share/locale/zh_CN/LC_MESSAGES/evince.mo
share/locale/zh_HK/LC_MESSAGES/evince.mo
share/locale/zh_TW/LC_MESSAGES/evince.mo
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/mg/LC_MESSAGES
-@dirrmtry share/locale/mg
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrm share/gnome/omf/evince
+share/omf/evince/evince-C.omf
+share/omf/evince/evince-bg.omf
+share/omf/evince/evince-ca.omf
+share/omf/evince/evince-el.omf
+share/omf/evince/evince-en_GB.omf
+share/omf/evince/evince-es.omf
+share/omf/evince/evince-fi.omf
+share/omf/evince/evince-fr.omf
+share/omf/evince/evince-it.omf
+share/omf/evince/evince-ja.omf
+share/omf/evince/evince-nl.omf
+share/omf/evince/evince-oc.omf
+share/omf/evince/evince-pt_BR.omf
+share/omf/evince/evince-ru.omf
+share/omf/evince/evince-sr.omf
+share/omf/evince/evince-sv.omf
+share/omf/evince/evince-uk.omf
+@dirrm share/omf/evince
@dirrm share/gnome/help/evince/uk/figures
@dirrm share/gnome/help/evince/uk
@dirrm share/gnome/help/evince/sv/figures
@@ -223,8 +224,14 @@ share/locale/zh_TW/LC_MESSAGES/evince.mo
@dirrm share/gnome/help/evince/sr
@dirrm share/gnome/help/evince/ru/figures
@dirrm share/gnome/help/evince/ru
+@dirrm share/gnome/help/evince/pt_BR/figures
+@dirrm share/gnome/help/evince/pt_BR
+@dirrm share/gnome/help/evince/oc/figures
+@dirrm share/gnome/help/evince/oc
@dirrm share/gnome/help/evince/nl/figures
@dirrm share/gnome/help/evince/nl
+@dirrm share/gnome/help/evince/ja/figures
+@dirrm share/gnome/help/evince/ja
@dirrm share/gnome/help/evince/it/figures
@dirrm share/gnome/help/evince/it
@dirrm share/gnome/help/evince/fr/figures
@@ -244,15 +251,40 @@ share/locale/zh_TW/LC_MESSAGES/evince.mo
@dirrm share/gnome/help/evince/C/figures
@dirrm share/gnome/help/evince/C
@dirrm share/gnome/help/evince
-@dirrm share/gnome/evince/icons/hicolor/24x24/actions
-@dirrm share/gnome/evince/icons/hicolor/24x24
-@dirrm share/gnome/evince/icons/hicolor/22x22/actions
-@dirrm share/gnome/evince/icons/hicolor/22x22
-@dirrm share/gnome/evince/icons/hicolor/16x16/actions
-@dirrm share/gnome/evince/icons/hicolor/16x16
-@dirrm share/gnome/evince/icons/hicolor
-@dirrm share/gnome/evince/icons
-@dirrm share/gnome/evince
+@dirrm %%DATADIR%%/icons/hicolor/48x48/actions
+@dirrm %%DATADIR%%/icons/hicolor/48x48
+@dirrm %%DATADIR%%/icons/hicolor/32x32/actions
+@dirrm %%DATADIR%%/icons/hicolor/32x32
+@dirrm %%DATADIR%%/icons/hicolor/24x24/actions
+@dirrm %%DATADIR%%/icons/hicolor/24x24
+@dirrm %%DATADIR%%/icons/hicolor/22x22/actions
+@dirrm %%DATADIR%%/icons/hicolor/22x22
+@dirrm %%DATADIR%%/icons/hicolor/16x16/actions
+@dirrm %%DATADIR%%/icons/hicolor/16x16
+@dirrm %%DATADIR%%/icons/hicolor
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/applications