aboutsummaryrefslogtreecommitdiff
path: root/graphics/evolvotron
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-07 15:56:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-07 15:56:25 +0000
commitc4c604737f5700845fc2cc7e8f87c3cc9c776b5f (patch)
tree9b9cc44513df5eab08cf93b54a7146c64bef9b88 /graphics/evolvotron
parent6a0ad9ba4f1c610a8ee11ccfa4a6317e2851b73d (diff)
downloadports-c4c604737f5700845fc2cc7e8f87c3cc9c776b5f.tar.gz
ports-c4c604737f5700845fc2cc7e8f87c3cc9c776b5f.zip
Notes
Diffstat (limited to 'graphics/evolvotron')
-rw-r--r--graphics/evolvotron/Makefile9
-rw-r--r--graphics/evolvotron/files/patch-libfunction_useful.h18
2 files changed, 21 insertions, 6 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index dd7a2c8cdb53..9165a41c074d 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -13,8 +13,7 @@ DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Generative software that evolves images/textures/patterns
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE= GPLv3+ # LICENSE file is GPLv2 though
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
@@ -22,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USES= python qmake
USE_QT4= corelib gui xml moc_build
-QMAKE_ARGS+= VERSION_NUMBER="${PORTVERSION}"
+QMAKE_ARGS= VERSION_NUMBER="${PORTVERSION}"
QMAKE_SOURCE_PATH= ${WRKSRC}/main.pro
MAKE_JOBS_UNSAFE= yes
@@ -49,11 +48,9 @@ do-install:
.for i in evolvotron evolvotron_mutate evolvotron_render
${INSTALL_PROGRAM} ${WRKSRC}/${i}/${i} ${STAGEDIR}${PREFIX}/bin/
.endfor
-
.for lib in libevolvotron libfunction
${INSTALL_DATA} ${WRKSRC}/${lib}/${lib}.a ${STAGEDIR}${PREFIX}/lib/
.endfor
-
.for s in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
@@ -61,12 +58,12 @@ do-install:
.endfor
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
-
.for m in evolvotron.1 evolvotron_mutate.1 evolvotron_render.1
cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${m} \
${STAGEDIR}${MAN1PREFIX}/man/man1/
.endfor
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/evolvotron/files/patch-libfunction_useful.h b/graphics/evolvotron/files/patch-libfunction_useful.h
new file mode 100644
index 000000000000..0b1bdb79dc40
--- /dev/null
+++ b/graphics/evolvotron/files/patch-libfunction_useful.h
@@ -0,0 +1,18 @@
+--- libfunction/useful.h.orig 2013-01-26 12:49:04 UTC
++++ libfunction/useful.h
+@@ -40,6 +40,7 @@
+ #include <sstream>
+ #include <vector>
+
++#ifndef Q_MOC_RUN
+ #include <boost/array.hpp>
+ #include <boost/ptr_container/ptr_map.hpp>
+ #include <boost/ptr_container/ptr_vector.hpp>
+@@ -49,6 +50,7 @@
+ #include <boost/tuple/tuple.hpp>
+ #include <boost/utility.hpp>
+ #include <boost/version.hpp>
++#endif
+
+ //! Convenience typedef.
+ typedef unsigned int uint;