aboutsummaryrefslogtreecommitdiff
path: root/graphics/exact-image
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /graphics/exact-image
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile1
-rw-r--r--graphics/exact-image/files/patch-edisplay_Makefile15
-rw-r--r--graphics/exact-image/files/patch-edisplay_edisplay.cc24
3 files changed, 40 insertions, 0 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index 0abd3d46b154..7c7088585c10 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exact-image
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= graphics perl5 python
MASTER_SITES= http://dl.exactcode.de/oss/${PORTNAME}/
diff --git a/graphics/exact-image/files/patch-edisplay_Makefile b/graphics/exact-image/files/patch-edisplay_Makefile
new file mode 100644
index 000000000000..61a4a180a8f2
--- /dev/null
+++ b/graphics/exact-image/files/patch-edisplay_Makefile
@@ -0,0 +1,15 @@
+Index: Makefile
+===================================================================
+--- edisplay/Makefile (revision 1751)
++++ edisplay/Makefile (revision 1752)
+@@ -4,7 +4,9 @@
+ BINARY = edisplay
+ BINARY_EXT = $(X_EXEEXT)
+
+-CPPFLAGS += -I . -I lib -I gfx $(shell pkg-config evas --atleast-version 0.9.9.050 && echo -D WITHEVAS_X11_CONNECTION)
++CPPFLAGS += -I . -I lib -I gfx
++CPPFLAGS += $(shell pkg-config evas --atleast-version 0.9.9.050 && echo -D WITHEVAS_X11_CONNECTION)
++CPPFLAGS += $(shell pkg-config evas --atleast-version 0.9.9.49898 && echo -D WITHEVAS_X11_SCREEN)
+
+ DEPS += $(X_OUTARCH)/gfx/X11Helper$(X_OBJEXT) $(X_OUTARCH)/gfx/EvasHelper$(X_OBJEXT) $(X_OUTARCH)/utility/Timer$(X_OBJEXT) $(X_OUTARCH)/utility/ArgumentList$(X_OBJEXT) $(lib_BINARY) $(codecs_BINARY)
+
diff --git a/graphics/exact-image/files/patch-edisplay_edisplay.cc b/graphics/exact-image/files/patch-edisplay_edisplay.cc
new file mode 100644
index 000000000000..4f909e6ed84f
--- /dev/null
+++ b/graphics/exact-image/files/patch-edisplay_edisplay.cc
@@ -0,0 +1,24 @@
+Index: edisplay.cc
+===================================================================
+--- edisplay/edisplay.cc (revision 1751)
++++ edisplay/edisplay.cc (revision 1752)
+@@ -269,12 +269,14 @@
+
+ /* the following is specific to the engine */
+ einfo->info.display = dpy;
+- einfo->info.visual =
+- einfo->func.best_visual_get (dpy, DefaultScreen(dpy));
+- einfo->info.colormap =
+- einfo->func.best_colormap_get(dpy,DefaultScreen(dpy));
+-
++#ifdef WITHEVAS_X11_SCREEN
++ einfo->info.screen = DefaultScreen(dpy);
++ einfo->info.visual = einfo->func.best_visual_get(einfo);
++ einfo->info.colormap = einfo->func.best_colormap_get(einfo);
++#else
++ einfo->info.visual = einfo->func.best_visual_get(dpy, DefaultScreen(dpy));
+ einfo->info.colormap = einfo->func.best_colormap_get(dpy, DefaultScreen(dpy));
++#endif
+ einfo->info.drawable = win;
+ einfo->info.depth = depth;
+