aboutsummaryrefslogtreecommitdiff
path: root/graphics/exact-image
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-01-13 04:40:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-01-13 04:40:37 +0000
commite0ae1a19ba43b2894a2addcf58106bce4c319ff1 (patch)
treebadcfe8316eda93a120c55ee0f8c2ebf70f37581 /graphics/exact-image
parent00a809db8fbe991e67aa6c6c3802998aefa0e43e (diff)
downloadports-e0ae1a19ba43b2894a2addcf58106bce4c319ff1.tar.gz
ports-e0ae1a19ba43b2894a2addcf58106bce4c319ff1.zip
Notes
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile2
-rw-r--r--graphics/exact-image/files/patch-api-api.cc11
-rw-r--r--graphics/exact-image/files/patch-frontends-bardecode.cc11
3 files changed, 23 insertions, 1 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index ed8a0eab0dd9..7d1a0582012e 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -12,7 +12,7 @@ COMMENT= Fast image processing library
LICENSE= GPLv2
-BUILD_DEPENDS= swig>=1.3.32:${PORTSDIR}/devel/swig13
+BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LIB_DEPENDS= libagg.so:${PORTSDIR}/graphics/agg \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libtiff.so:${PORTSDIR}/graphics/tiff \
diff --git a/graphics/exact-image/files/patch-api-api.cc b/graphics/exact-image/files/patch-api-api.cc
new file mode 100644
index 000000000000..1ca6edc5dd6c
--- /dev/null
+++ b/graphics/exact-image/files/patch-api-api.cc
@@ -0,0 +1,11 @@
+--- api/api.cc.orig 2009-06-15 14:39:45.000000000 +0400
++++ api/api.cc 2014-01-13 07:25:57.460488862 +0400
+@@ -909,7 +909,7 @@
+ }
+
+ std::vector<std::string> ret;
+- for (std::map<scanner_result_t,int>::const_iterator it = retcodes.begin();
++ for (std::map<scanner_result_t,int,comp>::const_iterator it = retcodes.begin();
+ it != retcodes.end();
+ ++it) {
+ if (it->first.type || it->second > 1)
diff --git a/graphics/exact-image/files/patch-frontends-bardecode.cc b/graphics/exact-image/files/patch-frontends-bardecode.cc
new file mode 100644
index 000000000000..15ebbcfb985e
--- /dev/null
+++ b/graphics/exact-image/files/patch-frontends-bardecode.cc
@@ -0,0 +1,11 @@
+--- frontends/bardecode.cc.orig 2010-06-18 18:02:15.000000000 +0400
++++ frontends/bardecode.cc 2014-01-13 07:31:33.549465639 +0400
+@@ -145,7 +145,7 @@
+ }
+ }
+
+- for (std::map<scanner_result_t,int>::const_iterator it = codes.begin();
++ for (std::map<scanner_result_t,int,comp>::const_iterator it = codes.begin();
+ it != codes.end();
+ ++it) {
+ if (it->first.type&(ean|code128|gs1_128) || it->second > 1)