aboutsummaryrefslogtreecommitdiff
path: root/graphics/exact-image
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-21 21:14:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-21 21:14:51 +0000
commitfc3b6a0406636f83d9d9da8f1416440965bd28f6 (patch)
treee775ab7bc82bf8177ef947f62fb826a1f6f4c431 /graphics/exact-image
parenteb9781ba09b1a12de10844b9b9ce45cd6be722c1 (diff)
downloadports-fc3b6a0406636f83d9d9da8f1416440965bd28f6.tar.gz
ports-fc3b6a0406636f83d9d9da8f1416440965bd28f6.zip
Notes
Diffstat (limited to 'graphics/exact-image')
-rw-r--r--graphics/exact-image/Makefile3
-rw-r--r--graphics/exact-image/distinfo6
-rw-r--r--graphics/exact-image/files/patch-bardecode__code128.hh11
-rw-r--r--graphics/exact-image/files/patch-codecs__bmp.cc31
-rw-r--r--graphics/exact-image/files/patch-codecs__jpeg.cc6
5 files changed, 46 insertions, 11 deletions
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index cef16899f58d..e33d5b257f07 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= exact-image
-PORTVERSION= 0.7.4
-PORTREVISION= 1
+PORTVERSION= 0.7.5
CATEGORIES= graphics
MASTER_SITES= http://dl.exactcode.de/oss/${PORTNAME}/
diff --git a/graphics/exact-image/distinfo b/graphics/exact-image/distinfo
index 849ca0628f5f..f08b2aa9fc51 100644
--- a/graphics/exact-image/distinfo
+++ b/graphics/exact-image/distinfo
@@ -1,3 +1,3 @@
-MD5 (exact-image-0.7.4.tar.bz2) = ecf43d9878a759ec056942c533c63ddc
-SHA256 (exact-image-0.7.4.tar.bz2) = e091a0b13eccd97a97c9233d939e70a154ffc586e5e509f0b4639e5cdc14db40
-SIZE (exact-image-0.7.4.tar.bz2) = 531051
+MD5 (exact-image-0.7.5.tar.bz2) = 9cf60553cf5ed1bbbf9a59a2e17ac0a2
+SHA256 (exact-image-0.7.5.tar.bz2) = d43635e06fdb48ec8c23bbfd66f40c5a1fc64c81913220f267dd7449050d0c69
+SIZE (exact-image-0.7.5.tar.bz2) = 532314
diff --git a/graphics/exact-image/files/patch-bardecode__code128.hh b/graphics/exact-image/files/patch-bardecode__code128.hh
new file mode 100644
index 000000000000..990c01c88db5
--- /dev/null
+++ b/graphics/exact-image/files/patch-bardecode__code128.hh
@@ -0,0 +1,11 @@
+--- bardecode/code128.hh.orig 2010-01-16 23:58:07.000000000 -0500
++++ bardecode/code128.hh 2010-01-16 23:38:25.000000000 -0500
+@@ -235,7 +235,7 @@
+ switch (code_set) {
+ case code_set_c:
+ if (c < 100) {
+- char str[2];
++ char str[3];
+ sprintf(str,"%02d",c);
+ return std::string(str);
+ } else {
diff --git a/graphics/exact-image/files/patch-codecs__bmp.cc b/graphics/exact-image/files/patch-codecs__bmp.cc
index 0a70c4bfbfdb..0ca75758d938 100644
--- a/graphics/exact-image/files/patch-codecs__bmp.cc
+++ b/graphics/exact-image/files/patch-codecs__bmp.cc
@@ -1,6 +1,31 @@
---- codecs/bmp.cc.orig 2009-07-02 17:37:58.000000000 -0400
-+++ codecs/bmp.cc 2009-07-02 18:38:49.000000000 -0400
-@@ -628,9 +628,9 @@
+--- codecs/bmp.cc.orig 2009-04-27 13:54:29.000000000 -0400
++++ codecs/bmp.cc 2010-01-17 00:32:01.000000000 -0500
+@@ -441,6 +441,8 @@
+ uint8_t* row_data = (uint8_t*) malloc (file_stride);
+ if (!data || !row_data) {
+ std::cerr << "Can't allocate space for image buffer\n";
++ free(data);
++ free(row_data);
+ goto bad1;
+ }
+
+@@ -522,6 +524,7 @@
+ comprbuf = (uint8_t *) malloc( compr_size );
+ if (!comprbuf) {
+ std::cerr << "Can't allocate space for compressed scanline buffer\n";
++ free(comprbuf);
+ goto bad1;
+ }
+ uncomprbuf = (uint8_t *) malloc( uncompr_size );
+@@ -593,6 +596,7 @@
+ data = (uint8_t *) malloc( uncompr_size );
+ if (!data) {
+ std::cerr << "Can't allocate space for final uncompressed scanline buffer\n";
++ free(data);
+ goto bad1;
+ }
+
+@@ -628,9 +632,9 @@
colorspace_de_palette (image, clr_tbl_size, rmap, gmap, bmap);
diff --git a/graphics/exact-image/files/patch-codecs__jpeg.cc b/graphics/exact-image/files/patch-codecs__jpeg.cc
index 7ab7d47d82e3..e80429713c68 100644
--- a/graphics/exact-image/files/patch-codecs__jpeg.cc
+++ b/graphics/exact-image/files/patch-codecs__jpeg.cc
@@ -1,11 +1,11 @@
---- codecs/jpeg.cc.orig 2009-07-02 18:34:41.000000000 -0400
-+++ codecs/jpeg.cc 2009-07-02 18:43:42.000000000 -0400
+--- codecs/jpeg.cc.orig 2009-06-14 08:19:28.000000000 -0400
++++ codecs/jpeg.cc 2010-01-16 21:51:34.000000000 -0500
@@ -683,7 +683,7 @@
* We need to clean up the JPEG object, close the input file, and return.
*/
jpeg_destroy_decompress (cinfo);
- free (cinfo);
-+ delete[] cinfo;
++ delete cinfo;
return false;
}