aboutsummaryrefslogtreecommitdiff
path: root/graphics/exhibit
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
commitee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442 (patch)
tree1bf12eadb5a7920766bf7a613174c0475b810d0d /graphics/exhibit
parent32e98c797bd5b952894ff185e59df8a91844f4ab (diff)
downloadports-ee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442.tar.gz
ports-ee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442.zip
Notes
Diffstat (limited to 'graphics/exhibit')
-rw-r--r--graphics/exhibit/Makefile45
-rw-r--r--graphics/exhibit/distinfo3
-rw-r--r--graphics/exhibit/pkg-descr7
3 files changed, 55 insertions, 0 deletions
diff --git a/graphics/exhibit/Makefile b/graphics/exhibit/Makefile
new file mode 100644
index 000000000000..b9eedadbf1c7
--- /dev/null
+++ b/graphics/exhibit/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: exhibit
+# Date created: 2006-08-15
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= exhibit
+PORTVERSION= 20060926
+CATEGORIES= graphics
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= An ETK-based image viewer
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_EFL= evas eet ecore edje etk epsilon
+WANT_EFL= yes
+GNU_CONFIGURE= yes
+
+OPTIONS= ENGRAVE "Enable E17 desktop wallpaper support" on \
+ ENLIGHTENMENT "Enable e17 desktop integration" off
+
+PLIST_FILES= bin/exhibit %%DATADIR%%/gui.edj
+PLIST_DIRS= %%DATADIR%%
+
+.include <bsd.port.pre.mk>
+BEFOREPORTMK= yes
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.undef BEFOREPORTMK
+
+.if !defined(WITHOUT_ENGRAVE) || ${HAVE_EFL:Mengrave}
+USE_EFL+= engrave
+.endif
+
+.if defined(WITH_ENLIGHTENMENT) || exists(${X11BASE}/bin/enlightenment_remote)
+BUILD_DEPENDS+= enlightenment_remote:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS+= enlightenment_remote:${PORTSDIR}/x11-wm/enlightenment-devel
+.endif
+
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.include <bsd.port.post.mk>
diff --git a/graphics/exhibit/distinfo b/graphics/exhibit/distinfo
new file mode 100644
index 000000000000..4fce8851f7c2
--- /dev/null
+++ b/graphics/exhibit/distinfo
@@ -0,0 +1,3 @@
+MD5 (exhibit-20060926.tar.bz2) = 0057914c0640932fff612435177e0d44
+SHA256 (exhibit-20060926.tar.bz2) = 6ed79409af59b396b8a9765cae91f6940fadbdc5a1849aafd662a87d79a5b041
+SIZE (exhibit-20060926.tar.bz2) = 276307
diff --git a/graphics/exhibit/pkg-descr b/graphics/exhibit/pkg-descr
new file mode 100644
index 000000000000..d56ff135a098
--- /dev/null
+++ b/graphics/exhibit/pkg-descr
@@ -0,0 +1,7 @@
+Exhibit is an image viewer that uses Etk as its toolkit. Exhibit supports
+image previews for image types supported by Evas and allows for directory
+changing using a point and click interface or a text input box with tab
+autocompletion support.
+
+Author: Hisham 'CodeWarrior' Mardambey <hisham.mardambey@gmail.com>
+WWW: http://www.enlightenment.org/