aboutsummaryrefslogtreecommitdiff
path: root/graphics/exif
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-04-24 18:39:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-04-24 18:39:02 +0000
commit5056eff6d5800f155ce61b1cdb0aec00191f5d20 (patch)
treede1d4341ad67e4fabfdb5b8fd02b97ca81815287 /graphics/exif
parent138268cd92a38c960877825afc0312b8d00db0d4 (diff)
downloadports-5056eff6d5800f155ce61b1cdb0aec00191f5d20.tar.gz
ports-5056eff6d5800f155ce61b1cdb0aec00191f5d20.zip
Notes
Diffstat (limited to 'graphics/exif')
-rw-r--r--graphics/exif/Makefile10
-rw-r--r--graphics/exif/files/patch-exif-i18n.c30
-rw-r--r--graphics/exif/pkg-plist6
3 files changed, 42 insertions, 4 deletions
diff --git a/graphics/exif/Makefile b/graphics/exif/Makefile
index dbe9a9bcaf87..88d8b195bc8d 100644
--- a/graphics/exif/Makefile
+++ b/graphics/exif/Makefile
@@ -18,9 +18,17 @@ LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif \
popt.0:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
-USE_ICONV= yes
CONFIGURE_ARGS= --with-popt-prefix=${LOCALBASE}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_ICONV= yes
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
MAN1= exif.1
.include <bsd.port.mk>
diff --git a/graphics/exif/files/patch-exif-i18n.c b/graphics/exif/files/patch-exif-i18n.c
new file mode 100644
index 000000000000..17c9f6a801a3
--- /dev/null
+++ b/graphics/exif/files/patch-exif-i18n.c
@@ -0,0 +1,30 @@
+--- exif/exif-i18n.c 2003/09/30 22:53:37 1.2
++++ exif/exif-i18n.c 2004/08/27 16:28:18 1.3
+@@ -1,7 +1,10 @@
+ #include <config.h>
+ #include "exif-i18n.h"
+
+-#include <iconv.h>
++#ifdef HAVE_ICONV
++# include <iconv.h>
++#endif
++
+ #include <string.h>
+ #include <sys/types.h>
+
+@@ -11,6 +14,7 @@
+ const char *
+ exif_i18n_convert_utf8_to_lat1 (const char *in)
+ {
++#ifdef HAVE_ICONV
+ static iconv_t tr = 0;
+ size_t t = (in ? strlen (in) : 0);
+ static char buf[2048];
+@@ -23,4 +27,7 @@
+ if (!tr) tr = iconv_open ("ISO-8859-1", "UTF-8");
+ iconv (tr, (char **) &in, &t, (char **) &out, &buf_size);
+ return buf;
++#else
++ return in;
++#endif
+ }
diff --git a/graphics/exif/pkg-plist b/graphics/exif/pkg-plist
index 3d2b1fa12f1e..0b7bbf80ab18 100644
--- a/graphics/exif/pkg-plist
+++ b/graphics/exif/pkg-plist
@@ -1,4 +1,4 @@
bin/exif
-share/locale/de/LC_MESSAGES/exif.mo
-share/locale/es/LC_MESSAGES/exif.mo
-share/locale/fr/LC_MESSAGES/exif.mo
+%%NLS%%share/locale/de/LC_MESSAGES/exif.mo
+%%NLS%%share/locale/es/LC_MESSAGES/exif.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/exif.mo