aboutsummaryrefslogtreecommitdiff
path: root/graphics/exifprobe
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-11-01 22:52:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-11-01 22:52:24 +0000
commit51f5b2331c65353877cbe9e659edf1f3bb1849ae (patch)
tree1e84116f822a3f98a49ea5ca6f6cd51468c167d5 /graphics/exifprobe
parent107430622432ef524af56e28b628c0ea1553296d (diff)
downloadports-51f5b2331c65353877cbe9e659edf1f3bb1849ae.tar.gz
ports-51f5b2331c65353877cbe9e659edf1f3bb1849ae.zip
Notes
Diffstat (limited to 'graphics/exifprobe')
-rw-r--r--graphics/exifprobe/Makefile30
-rw-r--r--graphics/exifprobe/distinfo2
-rw-r--r--graphics/exifprobe/pkg-descr9
3 files changed, 41 insertions, 0 deletions
diff --git a/graphics/exifprobe/Makefile b/graphics/exifprobe/Makefile
new file mode 100644
index 000000000000..209585fa4705
--- /dev/null
+++ b/graphics/exifprobe/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: exifprobe
+# Date created: 2004-07-21
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exifprobe
+DISTVERSION= 2.0.1
+CATEGORIES= graphics
+MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Probes JPEG or TIFF images and reports contents and structure
+
+MAN1= exifgrep.1 exifprobe.1
+PLIST_FILES= bin/exifgrep bin/exifprobe
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|cc|${CC}|; s|-DC|${CFLAGS} -DC|' \
+ ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/exifgrep ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/exifprobe ${PREFIX}/bin
+.for i in ${MAN1}
+ @${INSTALL_MAN} ${WRKSRC}/${i} ${MANPREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/exifprobe/distinfo b/graphics/exifprobe/distinfo
new file mode 100644
index 000000000000..46af45edb92e
--- /dev/null
+++ b/graphics/exifprobe/distinfo
@@ -0,0 +1,2 @@
+SHA256 (exifprobe-2.0.1.tar.gz) = d84b118a4fff11ecd6c1ad4dfa7e4b45436175e1ea747438c4458d00e3baa7ad
+SIZE (exifprobe-2.0.1.tar.gz) = 261568
diff --git a/graphics/exifprobe/pkg-descr b/graphics/exifprobe/pkg-descr
new file mode 100644
index 000000000000..b0635e23a4cf
--- /dev/null
+++ b/graphics/exifprobe/pkg-descr
@@ -0,0 +1,9 @@
+[From exifprobe(1)]
+
+Exifprobe examines and reports the contents and structure of JPEG and
+TIFF image files. It will recognize all standard JPEG markers (including
+APPn markers) and will report the contents of any properly structured TIFF
+IFD encountered, even when entry tags are not recognized. Recognized TIFF
+and TIFF/EP tags are expanded, including EXIF2.2 sections and camera MakerNotes
+which are found to be in TIFF IFD format. Location, size, and format of image
+data is reported by default.