aboutsummaryrefslogtreecommitdiff
path: root/graphics/exiv2
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-03-27 15:27:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-03-27 15:27:55 +0000
commit20578ad1458ef39dbbae3e8ba9ced0c384692bbc (patch)
tree7ae93f5af7980b43932d13a08c37896c7aa3170b /graphics/exiv2
parent0d48df2505810afec6d639fc944bcf76ccbb4a19 (diff)
downloadports-20578ad1458ef39dbbae3e8ba9ced0c384692bbc.tar.gz
ports-20578ad1458ef39dbbae3e8ba9ced0c384692bbc.zip
Notes
Diffstat (limited to 'graphics/exiv2')
-rw-r--r--graphics/exiv2/Makefile12
-rw-r--r--graphics/exiv2/distinfo6
-rw-r--r--graphics/exiv2/files/patch-src_Makefile22
-rw-r--r--graphics/exiv2/pkg-plist10
4 files changed, 16 insertions, 34 deletions
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index 660a498040d0..18722c6a52a4 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= exiv2
-PORTVERSION= 0.12
+PORTVERSION= 0.14
CATEGORIES= graphics
MASTER_SITES= http://www.exiv2.org/
@@ -14,18 +14,16 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= Exif and Iptc metadata manipulation library and tools
GNU_CONFIGURE= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
MAN1= exiv2.1
ALLTARGET= all
CONFIGURE_ARGS= --mandir=${PREFIX}/man
USE_GCC= 3.4+
-PORTDOCS= *
-.if !defined(NOPORTDOCS)
-post-install:
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/src/Makefile
.include <bsd.port.mk>
diff --git a/graphics/exiv2/distinfo b/graphics/exiv2/distinfo
index 3ccf67a40858..614409443709 100644
--- a/graphics/exiv2/distinfo
+++ b/graphics/exiv2/distinfo
@@ -1,3 +1,3 @@
-MD5 (exiv2-0.12.tar.gz) = a97a4e489df7ec99458e3e33b506c3e6
-SHA256 (exiv2-0.12.tar.gz) = ebc67d942580731002206ffcbf4b279384d029085262e285150695591a1fa0ab
-SIZE (exiv2-0.12.tar.gz) = 2359138
+MD5 (exiv2-0.14.tar.gz) = 6f8edde77d95f49fc83329feb615bb33
+SHA256 (exiv2-0.14.tar.gz) = a311e3ee884c57547b65c962f8b0a605e97cc64f7e6d1227a9624333acd53a8f
+SIZE (exiv2-0.14.tar.gz) = 1028225
diff --git a/graphics/exiv2/files/patch-src_Makefile b/graphics/exiv2/files/patch-src_Makefile
deleted file mode 100644
index d0a86ca7548c..000000000000
--- a/graphics/exiv2/files/patch-src_Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/Makefile.orig Sat Dec 16 19:35:51 2006
-+++ src/Makefile Sat Dec 16 19:39:49 2006
-@@ -242,7 +242,7 @@
- bin: lib $(BINARY) $(EXIV2BIN) $(MCBIN) path-test
-
- lib: $(OBJ)
-- $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) $(LOBJ) -o $(LIBRARY) -rpath $(libdir) -release $(EXIV2_VERSION) $(LIBS)
-+ $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) $(LOBJ) -o $(LIBRARY) -rpath $(libdir) -version-number $(subst .,:,$(EXIV2_VERSION)) $(LIBS)
- @touch lib
-
- path-test: path-test.o utils.o
-@@ -271,8 +271,8 @@
- @$(LIBTOOL) --mode=install $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(libdir)/$(LIBRARY)
- $(INSTALL_DIRS) $(DESTDIR)$(bindir)
- $(INSTALL_PROGRAM) $(top_srcdir)/config/exiv2-config $(DESTDIR)$(bindir)/exiv2-config
-- $(INSTALL_DIRS) $(DESTDIR)$(libdir)/pkgconfig
-- $(INSTALL_DATA) $(top_srcdir)/config/exiv2.pc $(DESTDIR)$(libdir)/pkgconfig/exiv2.pc
-+ $(INSTALL_DIRS) $(DESTDIR)$(prefix)/libdata/pkgconfig
-+ $(INSTALL_DATA) $(top_srcdir)/config/exiv2.pc $(DESTDIR)$(prefix)/libdata/pkgconfig/exiv2.pc
-
- install: $(EXIV2BIN) install-lib
- $(INSTALL_DIRS) $(DESTDIR)$(bindir)
diff --git a/graphics/exiv2/pkg-plist b/graphics/exiv2/pkg-plist
index 4b3ff5e02bae..7e32a4470aa6 100644
--- a/graphics/exiv2/pkg-plist
+++ b/graphics/exiv2/pkg-plist
@@ -1,5 +1,4 @@
bin/exiv2
-bin/exiv2-config
include/exiv2/basicio.hpp
include/exiv2/canonmn.hpp
include/exiv2/cr2image.hpp
@@ -7,7 +6,6 @@ include/exiv2/crwimage.hpp
include/exiv2/datasets.hpp
include/exiv2/error.hpp
include/exiv2/exif.hpp
-include/exiv2/exiv2_version.h
include/exiv2/exv_conf.h
include/exiv2/exv_msvc.h
include/exiv2/fujimn.hpp
@@ -27,6 +25,7 @@ include/exiv2/olympusmn.hpp
include/exiv2/panasonicmn.hpp
include/exiv2/pngchunk.hpp
include/exiv2/pngimage.hpp
+include/exiv2/rafimage.hpp
include/exiv2/rcsid.hpp
include/exiv2/sigmamn.hpp
include/exiv2/sonymn.hpp
@@ -38,9 +37,16 @@ include/exiv2/tiffparser.hpp
include/exiv2/tiffvisitor.hpp
include/exiv2/types.hpp
include/exiv2/value.hpp
+include/exiv2/version.hpp
lib/libexiv2.a
lib/libexiv2.la
lib/libexiv2.so
lib/libexiv2.so.0
libdata/pkgconfig/exiv2.pc
+share/locale/de/LC_MESSAGES/exiv2.mo
+share/locale/es/LC_MESSAGES/exiv2.mo
+share/locale/fi/LC_MESSAGES/exiv2.mo
+share/locale/fr/LC_MESSAGES/exiv2.mo
+share/locale/pl/LC_MESSAGES/exiv2.mo
+share/locale/ru/LC_MESSAGES/exiv2.mo
@dirrm include/exiv2