aboutsummaryrefslogtreecommitdiff
path: root/graphics/f3d/files
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-09-09 04:33:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-09-09 05:17:42 +0000
commit29210b73e94643c774af1d43b30d92cac3096b14 (patch)
treef3394c3465bcb26702a2aa150441170c4ba184f9 /graphics/f3d/files
parent5772ca34bc507d8f5976dc1528d7d9dc54fb76c4 (diff)
downloadports-29210b73e94643c774af1d43b30d92cac3096b14.tar.gz
ports-29210b73e94643c774af1d43b30d92cac3096b14.zip
Diffstat (limited to 'graphics/f3d/files')
-rw-r--r--graphics/f3d/files/patch-application_CMakeLists.txt11
-rw-r--r--graphics/f3d/files/patch-library_testing_CMakeLists.txt11
2 files changed, 22 insertions, 0 deletions
diff --git a/graphics/f3d/files/patch-application_CMakeLists.txt b/graphics/f3d/files/patch-application_CMakeLists.txt
new file mode 100644
index 000000000000..f219486bd740
--- /dev/null
+++ b/graphics/f3d/files/patch-application_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- application/CMakeLists.txt.orig 2022-09-07 16:38:14 UTC
++++ application/CMakeLists.txt
+@@ -29,7 +29,7 @@ endif()
+ add_executable(f3d ${F3D_SOURCE_FILES})
+ target_link_libraries(f3d PUBLIC libf3d)
+
+-if (UNIX AND NOT APPLE)
++if (UNIX AND NOT APPLE AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ target_link_libraries(f3d PRIVATE stdc++fs)
+ endif ()
+
diff --git a/graphics/f3d/files/patch-library_testing_CMakeLists.txt b/graphics/f3d/files/patch-library_testing_CMakeLists.txt
new file mode 100644
index 000000000000..828882a5d08a
--- /dev/null
+++ b/graphics/f3d/files/patch-library_testing_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- library/testing/CMakeLists.txt.orig 2022-09-07 16:39:43 UTC
++++ library/testing/CMakeLists.txt
+@@ -112,7 +112,7 @@ if(Qt5_FOUND)
+ target_link_libraries(libf3dSDKTests Qt5::OpenGL)
+ endif()
+
+-if (UNIX AND NOT APPLE)
++if (UNIX AND NOT APPLE AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ target_link_libraries(libf3dSDKTests stdc++fs)
+ endif ()
+