aboutsummaryrefslogtreecommitdiff
path: root/graphics/f90gl/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-10-29 04:25:09 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-10-29 04:25:09 +0000
commitb57ae6b4bc456f2a2845332fef06a67a0867e079 (patch)
tree5e2d65c9d7493793339a8eb0b4fb811b3639d05f /graphics/f90gl/Makefile
parent963bd1a735bc8119eda6fbe257dd6f7a5f78da43 (diff)
downloadports-b57ae6b4bc456f2a2845332fef06a67a0867e079.tar.gz
ports-b57ae6b4bc456f2a2845332fef06a67a0867e079.zip
Notes
Diffstat (limited to 'graphics/f90gl/Makefile')
-rw-r--r--graphics/f90gl/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/graphics/f90gl/Makefile b/graphics/f90gl/Makefile
index 134ab64bb855..6d72354af86b 100644
--- a/graphics/f90gl/Makefile
+++ b/graphics/f90gl/Makefile
@@ -43,6 +43,10 @@ PLIST_SUB= WITH_EXAMPLES="@comment "
PLIST_SUB= WITH_EXAMPLES=""
.endif
+.if !defined (OPENGL_DISPLAY)
+EXTRA_PATCHES= ${PATCHDIR}/extra-disable-mkfppinc
+.endif
+
post-patch:
${CP} -r ${WRKSRC} ${WRKSRC_SHARED}
@@ -67,6 +71,10 @@ pre-build:
-e 's,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC_SHARED}/examples/mf8lnt
do-build:
+.if !defined (OPENGL_DISPLAY)
+ ${CP} ${FILESDIR}/glopt.h ${WRKSRC}/util
+ ${CP} ${FILESDIR}/glopt.h ${WRKSRC_SHARED}/util
+.endif
cd ${WRKSRC} ; ${MAKE} -f mf8lim7
cd ${WRKSRC_SHARED} ; ${MAKE} -f mf8lim7
cd ${WRKSRC_SHARED}/examples ; ${MAKE} -f mf8lnt