aboutsummaryrefslogtreecommitdiff
path: root/graphics/farbfeld
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-12 09:44:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-12 09:44:13 +0000
commit3eb64ea5c00adf79ecd76ca88de75a4cffca6224 (patch)
tree8e2f2b724c2cbe1cf4e4d11b1696587f6ce4808e /graphics/farbfeld
parent0b48d2640d4781216a391fddee3652231f7430a8 (diff)
downloadports-3eb64ea5c00adf79ecd76ca88de75a4cffca6224.tar.gz
ports-3eb64ea5c00adf79ecd76ca88de75a4cffca6224.zip
Notes
Diffstat (limited to 'graphics/farbfeld')
-rw-r--r--graphics/farbfeld/Makefile6
-rw-r--r--graphics/farbfeld/distinfo6
-rw-r--r--graphics/farbfeld/files/patch-config.mk13
3 files changed, 15 insertions, 10 deletions
diff --git a/graphics/farbfeld/Makefile b/graphics/farbfeld/Makefile
index d90066f48018..486867e3d37c 100644
--- a/graphics/farbfeld/Makefile
+++ b/graphics/farbfeld/Makefile
@@ -1,12 +1,12 @@
# $FreeBSD$
PORTNAME= farbfeld
-PORTVERSION= 3
+DISTVERSION= 4
CATEGORIES= graphics
-MASTER_SITES= http://dl.suckless.org/farbfeld/
+MASTER_SITES= https://dl.suckless.org/farbfeld/
MAINTAINER= aaron@baugher.biz
-COMMENT= Lossless, uncompressed graphics format
+COMMENT= Lossless image format which is easy to parse, pipe and compress
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
diff --git a/graphics/farbfeld/distinfo b/graphics/farbfeld/distinfo
index 6c24d2758b39..2f36bad96fb7 100644
--- a/graphics/farbfeld/distinfo
+++ b/graphics/farbfeld/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500781142
-SHA256 (farbfeld-3.tar.gz) = 5b953b86a72d3feaedf62698532c8888e5f6e2f6363193a4cc8cee0e38c378ad
-SIZE (farbfeld-3.tar.gz) = 10169
+TIMESTAMP = 1523455293
+SHA256 (farbfeld-4.tar.gz) = c7df5921edd121ca5d5b1cf6fb01e430aff9b31242262e4f690d3af72ccbe72a
+SIZE (farbfeld-4.tar.gz) = 10340
diff --git a/graphics/farbfeld/files/patch-config.mk b/graphics/farbfeld/files/patch-config.mk
index cfa89f8485d4..8427536d4db5 100644
--- a/graphics/farbfeld/files/patch-config.mk
+++ b/graphics/farbfeld/files/patch-config.mk
@@ -1,6 +1,11 @@
---- config.mk.orig 2017-07-23 04:09:50 UTC
+--- config.mk.orig 2018-04-11 10:59:06 UTC
+++ config.mk
-@@ -9,10 +9,10 @@ MANPREFIX = ${PREFIX}/man
+@@ -5,14 +5,14 @@ VERSION = 4
+
+ # paths
+ PREFIX = /usr/local
+-MANPREFIX = $(PREFIX)/share/man
++MANPREFIX = $(PREFIX)/man
# flags
CPPFLAGS = -D_DEFAULT_SOURCE
@@ -8,8 +13,8 @@
-LDFLAGS = -s
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Os -I${LOCALBASE}/include
+LDFLAGS = -s -L${LOCALBASE}/lib
- PNG-LDFLAGS = -lpng
- JPG-LDFLAGS = -ljpeg
+ PNG-LDLIBS = -lpng
+ JPG-LDLIBS = -ljpeg
# compiler and linker
-CC = cc