aboutsummaryrefslogtreecommitdiff
path: root/graphics/ffff/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-10-04 10:54:05 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-10-04 10:54:05 +0000
commit6cdf88141ebc1ab77ee9bc735a3a9a21834d9537 (patch)
treec376a4b3287e5b4fd7b91b71b7226eeb553b7317 /graphics/ffff/Makefile
parent73b9a8754861da2459ec49bd9b9fd54220dd17a2 (diff)
downloadports-6cdf88141ebc1ab77ee9bc735a3a9a21834d9537.tar.gz
ports-6cdf88141ebc1ab77ee9bc735a3a9a21834d9537.zip
Notes
Diffstat (limited to 'graphics/ffff/Makefile')
-rw-r--r--graphics/ffff/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/graphics/ffff/Makefile b/graphics/ffff/Makefile
new file mode 100644
index 000000000000..e8c256a0623b
--- /dev/null
+++ b/graphics/ffff/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: ffff
+# Date created: Sep 20, 2006
+# Whom: rossiya@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= ffff
+PORTVERSION= 323
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= FFFF${PORTVERSION}-src
+
+MAINTAINER= rossiya@gmail.com
+COMMENT= A fast mandelbrot fractal generator
+
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
+USE_DOS2UNIX= yes
+USE_GCC= 3.2+
+USE_GL= yes
+USE_XLIB= yes
+USE_ZIP= yes
+
+SOURCE= FFFF3 FragmentProgram FragmentProgramARB10 GPUProgram \
+ PixelBuffer VertexProgram VertexProgramATI VertexProgramNV \
+ extensions vpext
+
+CXXFLAGS+= -I${X11BASE}/include -I${X11BASE}/include/GL ${PTHREAD_CFLAGS} \
+ -D__linux__
+LDFLAGS+= -L${X11BASE}/lib ${PTHREAD_LIBS} -lglut -lGL -lXext -lX11 -lXmu \
+ -lGLU -lm
+
+PLIST_FILES= bin/ffff
+
+# contains x86 assembler
+ONLY_FOR_ARCHS= i386
+
+do-build:
+.for f in ${SOURCE}
+ ${CXX} ${CXXFLAGS} -c ${WRKSRC}/${f}.cpp -o ${WRKSRC}/${f}.obj
+.endfor
+ ${CXX} ${LDFLAGS} ${SOURCE:C/(.*)/${WRKSRC}\/\1.obj/} -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>