aboutsummaryrefslogtreecommitdiff
path: root/graphics/figurine/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-19 19:42:20 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-19 19:42:20 +0000
commitf54d3587596998fff19739a9206a0ae6a8fd2b43 (patch)
treeb22c10e2d49daba3ec3be16fdd9921d335156491 /graphics/figurine/Makefile
parentc480ec1d9c18e18dfa6a164eb2ad5d85dd6e69bd (diff)
Notes
Diffstat (limited to 'graphics/figurine/Makefile')
-rw-r--r--graphics/figurine/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/figurine/Makefile b/graphics/figurine/Makefile
new file mode 100644
index 000000000000..a5ab8e41aeaf
--- /dev/null
+++ b/graphics/figurine/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: figurine
+# Date created: 15 September 2002
+# Whom: Marc Fonvieille <blackend@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= figurine
+PORTVERSION= 1.0.5
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= blackend@FreeBSD.org
+
+RUN_DEPENDS= fig2dev:${PORTSDIR}/print/transfig
+
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_XPM= yes
+
+MAN1= figurine.1
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e "s|Doc examples src|src|" \
+ ${WRKSRC}/Makefile.in
+.endif
+ @${FIND} ${WRKSRC} -type f -name Makefile.in | \
+ ${XARGS} -n 10 ${REINPLACE_CMD} \
+ -e 's|datadir = @datadir@|datadir = @datadir@/doc|'
+
+.include <bsd.port.mk>