aboutsummaryrefslogtreecommitdiff
path: root/graphics/flam3
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-03-22 20:30:37 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-03-22 20:30:37 +0000
commitb5147f698384bc20b7f0355a517ce27ac4496dea (patch)
treeecbe553ec8ccd3215e49d6a320830e981e51e07d /graphics/flam3
parent0615aacad24345366b916b4ed953448e34c48021 (diff)
downloadports-b5147f698384bc20b7f0355a517ce27ac4496dea.tar.gz
ports-b5147f698384bc20b7f0355a517ce27ac4496dea.zip
Notes
Diffstat (limited to 'graphics/flam3')
-rw-r--r--graphics/flam3/Makefile33
-rw-r--r--graphics/flam3/distinfo3
-rw-r--r--graphics/flam3/pkg-descr14
-rw-r--r--graphics/flam3/pkg-plist10
4 files changed, 60 insertions, 0 deletions
diff --git a/graphics/flam3/Makefile b/graphics/flam3/Makefile
new file mode 100644
index 000000000000..9891bd796691
--- /dev/null
+++ b/graphics/flam3/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: flam3
+# Date created: 21 Mar 2010
+# Whom: John Prather
+#
+# $FreeBSD$
+#
+
+PORTNAME= flam3
+PORTVERSION= 2.7.18
+CATEGORIES= graphics
+MASTER_SITES= http://flam3.com/ \
+ http://interwebfun.org/distfiles/
+
+MAINTAINER= john.c.prather@gmail.com
+COMMENT= A Flame Renderer
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ jpeg.11:${PORTSDIR}/graphics/jpeg
+
+MAN1= flam3-animate.1 flam3-genome.1 flam3-render.1 flam3-convert.1
+MANCOMPRESSED= no
+
+PORTDATA= flam3-palettes.xml
+
+GNU_CONFIGURE= yes
+USE_GZIP= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig gnomehack
+
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/flam3/distinfo b/graphics/flam3/distinfo
new file mode 100644
index 000000000000..5ec7de4c0fa9
--- /dev/null
+++ b/graphics/flam3/distinfo
@@ -0,0 +1,3 @@
+MD5 (flam3-2.7.18.tar.gz) = 052faba777634799b2958205ddf05545
+SHA256 (flam3-2.7.18.tar.gz) = f3f8155d8a0ea11a23412566e18b2751da84f9ae24bd0f37a5f6484b10ad817e
+SIZE (flam3-2.7.18.tar.gz) = 1093666
diff --git a/graphics/flam3/pkg-descr b/graphics/flam3/pkg-descr
new file mode 100644
index 000000000000..d3d21c01e361
--- /dev/null
+++ b/graphics/flam3/pkg-descr
@@ -0,0 +1,14 @@
+Fractal Flames are algorithmically generated images
+and animations. The shape of each image is specified
+by a long string of numbers - a genetic code of sorts.
+
+You can create your own flames with the Apophysis
+interactive designer (for windows), Qosmic (for Linux),
+or Oxidizer (for Mac OS X), or Apophysis-J (cross-
+platform in Java).
+
+Or you can use the Electric Sheep distributed screen
+saver to join the collective evolution of animated
+fractal flames.
+
+WWW: http://flam3.com/
diff --git a/graphics/flam3/pkg-plist b/graphics/flam3/pkg-plist
new file mode 100644
index 000000000000..8c0f6e4c7e8d
--- /dev/null
+++ b/graphics/flam3/pkg-plist
@@ -0,0 +1,10 @@
+bin/flam3-animate
+bin/flam3-genome
+bin/flam3-render
+bin/flam3-convert
+include/flam3.h
+include/isaac.h
+include/isaacs.h
+lib/libflam3.la
+lib/libflam3.a
+libdata/pkgconfig/flam3.pc