aboutsummaryrefslogtreecommitdiff
path: root/graphics/flphoto
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-08 20:01:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-08 20:01:56 +0000
commitd596797d8c55469329ddd6b42b8283eb69cb2964 (patch)
tree399b0b1968638b001b57ca578513e9b09299f5df /graphics/flphoto
parent0d256c54933da6e0af032cbba4d518edc2168abb (diff)
downloadports-d596797d8c55469329ddd6b42b8283eb69cb2964.tar.gz
ports-d596797d8c55469329ddd6b42b8283eb69cb2964.zip
Notes
Diffstat (limited to 'graphics/flphoto')
-rw-r--r--graphics/flphoto/Makefile30
-rw-r--r--graphics/flphoto/distinfo1
-rw-r--r--graphics/flphoto/files/patch-Makefile.in18
-rw-r--r--graphics/flphoto/pkg-descr18
-rw-r--r--graphics/flphoto/pkg-plist37
5 files changed, 104 insertions, 0 deletions
diff --git a/graphics/flphoto/Makefile b/graphics/flphoto/Makefile
new file mode 100644
index 000000000000..692ed2319aaf
--- /dev/null
+++ b/graphics/flphoto/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: flPhoto
+# Date created: 24 November, 2003
+# Whom: johan
+#
+# $FreeBSD$
+#
+
+PORTNAME= flphoto
+PORTVERSION= 1.1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fltk
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A basic image management and display program
+
+LIB_DEPENDS= gphoto2.2:${PORTSDIR}/graphics/libgphoto2 \
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= flphoto.1
+MAN5= album.5
+
+.include <bsd.port.mk>
diff --git a/graphics/flphoto/distinfo b/graphics/flphoto/distinfo
new file mode 100644
index 000000000000..75d4d61cfe39
--- /dev/null
+++ b/graphics/flphoto/distinfo
@@ -0,0 +1 @@
+MD5 (flphoto-1.1-source.tar.bz2) = 2cf2938ea1c6f88f9df279a77ec8af96
diff --git a/graphics/flphoto/files/patch-Makefile.in b/graphics/flphoto/files/patch-Makefile.in
new file mode 100644
index 000000000000..cf8f43e38bb4
--- /dev/null
+++ b/graphics/flphoto/files/patch-Makefile.in
@@ -0,0 +1,18 @@
+--- Makefile.in.orig Sun Sep 14 01:00:35 2003
++++ Makefile.in Mon Dec 8 20:48:49 2003
+@@ -182,15 +182,9 @@
+ $(CP) flphoto$(EXEEXT) $(DESTDIR)$(bindir)
+ $(FLTKCONFIG) --post $(DESTDIR)$(bindir)/flphoto$(EXEEXT)
+ echo Installing flPhoto manpages in $(DESTDIR)$(mandir)
+- -$(MKDIR) $(DESTDIR)$(mandir)/cat1
+- $(RM) $(DESTDIR)$(mandir)/cat1/flphoto.$(CAT1EXT)
+- $(CP) $(srcdir)/doc/flphoto.1 $(DESTDIR)$(mandir)/cat1/flphoto.$(CAT1EXT)
+ -$(MKDIR) $(DESTDIR)$(mandir)/man1
+ $(RM) $(DESTDIR)$(mandir)/man1/flphoto.1
+ $(CP) $(srcdir)/doc/flphoto.man $(DESTDIR)$(mandir)/man1/flphoto.1
+- -$(MKDIR) $(DESTDIR)$(mandir)/cat5
+- $(RM) $(DESTDIR)$(mandir)/cat5/album.$(CAT5EXT)
+- $(CP) $(srcdir)/doc/album.5 $(DESTDIR)$(mandir)/cat5/album.$(CAT5EXT)
+ -$(MKDIR) $(DESTDIR)$(mandir)/man5
+ $(RM) $(DESTDIR)$(mandir)/man5/album.5
+ $(CP) $(srcdir)/doc/album.man $(DESTDIR)$(mandir)/man5/album.5
diff --git a/graphics/flphoto/pkg-descr b/graphics/flphoto/pkg-descr
new file mode 100644
index 000000000000..f4f90eafb19a
--- /dev/null
+++ b/graphics/flphoto/pkg-descr
@@ -0,0 +1,18 @@
+flPhoto is a basic image management and display program based on the FLTK
+toolkit and is provided under the terms of the GNU General Public License.
+It can read, write, and display digital camera EXIF information and supports
+the following image file formats:
+ BMP, CRW, JPEG, PhotoCD, PNG
+
+flPhoto organizes image files into albums which can be:
+ Printed, Viewed as a slideshow, Exported to web pages
+
+Images can be imported individually, by directory, or from digital cameras
+using the gPhoto library.
+
+Image files can be transformed and touched-up; the following image operations
+are available:
+ Crop, Rotate, Scale, Auto-Correct, Adjust Brightness and Contrast,
+ Remove Red Eye, Sharpen, Blur
+
+WWW: http://www.easysw.com/~mike/flphoto/
diff --git a/graphics/flphoto/pkg-plist b/graphics/flphoto/pkg-plist
new file mode 100644
index 000000000000..74495a3566eb
--- /dev/null
+++ b/graphics/flphoto/pkg-plist
@@ -0,0 +1,37 @@
+bin/flphoto
+share/doc/flphoto/COPYING
+share/doc/flphoto/README
+share/doc/flphoto/about.html
+share/doc/flphoto/slideshow.html
+share/doc/flphoto/relnotes.html
+share/doc/flphoto/print.html
+share/doc/flphoto/license.html
+share/doc/flphoto/index.html
+share/doc/flphoto/import.html
+share/doc/flphoto/images.html
+share/doc/flphoto/export.html
+share/doc/flphoto/download.html
+share/doc/flphoto/contents.html
+share/doc/flphoto/albums.html
+share/doc/flphoto/view.html
+share/doc/flphoto/camera.jpg
+share/doc/flphoto/scale.jpg
+share/doc/flphoto/print4.jpg
+share/doc/flphoto/print3.jpg
+share/doc/flphoto/print2.jpg
+share/doc/flphoto/print.jpg
+share/doc/flphoto/jpeg.jpg
+share/doc/flphoto/flphoto.jpg
+share/doc/flphoto/export.jpg
+share/doc/flphoto/crop.jpg
+share/doc/flphoto/slideshow.jpg
+share/doc/flphoto/flphoto.png
+share/locale/de/flphoto_de
+share/locale/en_CA/flphoto_en_CA
+share/locale/en_GB/flphoto_en_GB
+share/locale/es/flphoto_es
+share/locale/fr/flphoto_fr
+share/locale/it/flphoto_it
+share/locale/nl/flphoto_nl
+share/locale/pt/flphoto_pt
+@dirrm share/doc/flphoto