aboutsummaryrefslogtreecommitdiff
path: root/graphics/fly/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-09-09 18:26:47 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-09-09 18:26:47 +0000
commit9e830b33a48231d2714b8638b1306d7a22076347 (patch)
tree76545179f73f9ccd78a8daad82006a466574e068 /graphics/fly/Makefile
parentbbda29f186ba423c31ba097f568df14705018f45 (diff)
Notes
Diffstat (limited to 'graphics/fly/Makefile')
-rw-r--r--graphics/fly/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/graphics/fly/Makefile b/graphics/fly/Makefile
index d110ced92d5c..7f190010777d 100644
--- a/graphics/fly/Makefile
+++ b/graphics/fly/Makefile
@@ -6,20 +6,30 @@
#
PORTNAME= fly
-PORTVERSION= 1.6.5
+PORTVERSION= 2.0.0
CATEGORIES= graphics
-MASTER_SITES= http://members.optushome.com.au/martingleeson/fly/dist/
+MASTER_SITES= http://members.optushome.com.au/martingleeson/%SUBDIR%/ \
+ http://martin.gleeson.com/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}/dist
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple drawing language to generate GIFs on the fly
-#this doesn't matter.. the program builds its own libgd.a.
-#BUILD_DEPENDS= ${PREFIX}/lib/libgd\.a #can't use ports' gd..
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
-MAKE_ENV= PREFIX="${PREFIX}"
-PLIST_FILES= bin/fly
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include fly.c -o fly \
+ -L${LOCALBASE}/lib -lgd
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fly ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${FIND} . | \
+ ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${FIND} . | \
+ ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>