aboutsummaryrefslogtreecommitdiff
path: root/graphics/fotoxx
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2011-05-26 08:50:57 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2011-05-26 08:50:57 +0000
commit484fd842d1547b9c4ecd7635f9b5c1052e72b10f (patch)
treeb4909c23b998a7efd06b21cf57202b4f54fe7031 /graphics/fotoxx
parent7621c6fa7b8060c45262bdf1f6cdf3ff9ae10b12 (diff)
Notes
Diffstat (limited to 'graphics/fotoxx')
-rw-r--r--graphics/fotoxx/Makefile37
-rw-r--r--graphics/fotoxx/distinfo2
-rw-r--r--graphics/fotoxx/files/patch-Makefile26
-rw-r--r--graphics/fotoxx/files/patch-dependencies.sh37
-rw-r--r--graphics/fotoxx/files/patch-fotoxx-11.03.cc43
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.cc119
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.h17
-rw-r--r--graphics/fotoxx/pkg-descr5
-rw-r--r--graphics/fotoxx/pkg-plist98
9 files changed, 384 insertions, 0 deletions
diff --git a/graphics/fotoxx/Makefile b/graphics/fotoxx/Makefile
new file mode 100644
index 000000000000..7936aeded779
--- /dev/null
+++ b/graphics/fotoxx/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fotoxx-11.03
+# Date created: 2011-03-28
+# Whom: Rod Person <rodperson@rodperson.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fotoxx
+PORTVERSION= 11.03
+CATEGORIES= graphics
+MASTER_SITES= http://kornelix.squarespace.com/downloads/ \
+ http://www.rodperson.com/DL/
+
+MAINTAINER= rodperson@rodperson.com
+COMMENT= Application to organize and edit image collections
+
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
+ ufraw-batch:${PORTSDIR}/graphics/ufraw \
+ exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool
+
+USE_GNOME= gtk20
+USE_GMAKE= yes
+MANCOMPRESSED= yes
+MAN1= fotoxx.1
+
+ALL_TARGET= fotoxx
+INSTALL_TARGET= install manpage
+
+MAKE_ENV+= LDFLAGS="-O3 -g -Wall -rdynamic -lexecinfo"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/dependencies.sh
+
+.include <bsd.port.mk>
diff --git a/graphics/fotoxx/distinfo b/graphics/fotoxx/distinfo
new file mode 100644
index 000000000000..b4110d079189
--- /dev/null
+++ b/graphics/fotoxx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fotoxx-11.03.tar.gz) = c23e6b7c5517d1509b14a270bd2ad2af6fd2de613e55e79104f77d1748492577
+SIZE (fotoxx-11.03.tar.gz) = 1152890
diff --git a/graphics/fotoxx/files/patch-Makefile b/graphics/fotoxx/files/patch-Makefile
new file mode 100644
index 000000000000..c624cacf4f12
--- /dev/null
+++ b/graphics/fotoxx/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig 2011-02-28 17:04:24.000000000 +0100
++++ Makefile 2011-05-25 17:26:15.000000000 +0200
+@@ -15,13 +15,12 @@
+ BINDIR = $(PREFIX)/bin
+ DATADIR = $(PREFIX)/share/$(PROGRAM)
+ DOCDIR = $(PREFIX)/share/doc/$(PROGRAM)
+-MANDIR = $(PREFIX)/share/man/man1
++MANDIR = $(PREFIX)/man/man1
+ ICONDIR = $(DATADIR)/icons
+ DESKTOP = $(DATADIR)/kornelix-$(PROGRAM).desktop
+
+ $(PROGRAM): $(PROGRAM).o zfuncs.o
+ $(CXX) $(LFLAGS) -ltiff -o $(PROGRAM) $(PROGRAM).o zfuncs.o
+- @ ./dependencies.sh
+
+ $(PROGRAM).o: $(SOURCE)
+ $(CXX) $(CFLAGS) -o $(PROGRAM).o $(SOURCE) \
+@@ -42,8 +41,6 @@
+ cp -f icons/* $(DESTDIR)$(ICONDIR)
+ cp -f -R locales/* $(DESTDIR)$(DATADIR)/locales
+ cp -f $(PROGRAM) $(DESTDIR)$(BINDIR)
+- @ echo use make menu to install desktop menu
+- @ echo use make manpage to install man page
+
+ menu:
+ cp -f desktop $(DESTDIR)$(DESKTOP)
diff --git a/graphics/fotoxx/files/patch-dependencies.sh b/graphics/fotoxx/files/patch-dependencies.sh
new file mode 100644
index 000000000000..907629690ac7
--- /dev/null
+++ b/graphics/fotoxx/files/patch-dependencies.sh
@@ -0,0 +1,37 @@
+--- dependencies.sh.orig 2011-02-28 11:04:24.000000000 -0500
++++ dependencies.sh 2011-03-28 08:52:03.000000000 -0400
+@@ -1,4 +1,4 @@
+-#! /bin/bash
++#!/bin/sh
+ #
+ # Check if dependencies are installed before build.
+ #
+@@ -7,15 +7,15 @@
+ # but they are required at run time to handle EXIF data
+ # and RAW files from digital cameras.
+
+-dlist=" g++ /usr/include/gtk-2.0/gtk/gtk.h
+- /usr/include/tiffio.h /usr/lib*/libtiff.so
+- xdg-open xdg-desktop-menu exiftool"
++dlist=" /usr/local/include/gtk-2.0/gtk/gtk.h
++ /usr/local/include/tiffio.h /usr/local/lib/libtiff.so
++ /usr/local/bin/xdg-open /usr/local/bin/xdg-desktop-menu /usr/local/bin/exiftool"
+
+ error=0
+
+ for dname in $dlist
+ do
+- if [ ${dname:0:1} = "/" ]
++ if [ ${dname#/*} = ${dname} ]
+ then find $dname >/dev/null 2>&1
+ else which $dname >/dev/null
+ fi
+@@ -40,7 +40,7 @@
+
+ for dname in $dlist
+ do
+- if [ ${dname:0:1} = "/" ]
++ if [ ${dname#/*} = ${dname} ]
+ then find $dname >/dev/null 2>&1
+ else which $dname >/dev/null
+ fi
diff --git a/graphics/fotoxx/files/patch-fotoxx-11.03.cc b/graphics/fotoxx/files/patch-fotoxx-11.03.cc
new file mode 100644
index 000000000000..292dd0f6a234
--- /dev/null
+++ b/graphics/fotoxx/files/patch-fotoxx-11.03.cc
@@ -0,0 +1,43 @@
+--- fotoxx-11.03.cc.orig 2011-02-28 17:04:24.000000000 +0100
++++ fotoxx-11.03.cc 2011-05-26 10:36:11.000000000 +0200
+@@ -24,6 +24,13 @@
+ #include <tiffio.h>
+ #include "zfuncs.h"
+
++#ifdef __FreeBSD__
++ #include <unistd.h> /* for getcwd */
++ #include <sys/types.h> /* for getpwuid */
++ #include <pwd.h> /* for getpwuid */
++ #define WEXITSTATUS(w)((w)>>8) // fixes WEXITSTATUS not declared on FreeBSD
++#endif
++
+ #define fversion "Fotoxx v.11.03 2011.03.01" // version and date
+ #define fversioncc 16 // cc to use for window title bar
+ #define flicense "Free software - GNU General Public License v.3"
+@@ -986,7 +993,7 @@
+ }
+
+ if (! curr_file) { // set curr. directory anyway v.11.01
+- ppv = get_current_dir_name();
++ ppv = getwd(null);
+ curr_dirk = strdupz(ppv,0,"curr_dirk");
+ free(ppv);
+ err = chdir(curr_dirk);
+@@ -2428,7 +2435,7 @@
+ if (curr_file)
+ image_gallery(curr_file,"paint1",0,m_gallery2,mWin); // overlay main window v.10.9
+ else {
+- char *pp = get_current_dir_name();
++ char *pp = getwd(null);
+ if (pp) {
+ image_gallery(pp,"paint1",0,m_gallery2,mWin); // use current directory v.10.9
+ free(pp);
+@@ -5169,7 +5176,7 @@
+ }
+
+ *tempdir = 0; // temp directory: /tmp/<user>/fotoxx/email
+- strncatv(tempdir,99,"/tmp/",cuserid(null),"/fotoxx/email",null);
++ strncatv(tempdir,99,"/tmp/",getpwuid(null),"/fotoxx/email",null);
+
+ sprintf(command,"mkdir -p %s",tempdir); // (re)create directory
+ err = system(command);
diff --git a/graphics/fotoxx/files/patch-zfuncs.cc b/graphics/fotoxx/files/patch-zfuncs.cc
new file mode 100644
index 000000000000..f92ddf042292
--- /dev/null
+++ b/graphics/fotoxx/files/patch-zfuncs.cc
@@ -0,0 +1,119 @@
+--- zfuncs.cc.orig 2011-02-28 17:04:24.000000000 +0100
++++ zfuncs.cc 2011-05-26 10:04:13.000000000 +0200
+@@ -24,6 +24,15 @@
+
+ #include "zfuncs.h"
+
++#ifdef __FreeBSD__
++ #include <sys/event.h>
++ #include <sys/types.h>
++ #include <sys/times.h>
++ #include <pwd.h>
++ #include <execinfo.h>
++
++ #define WEXITSTATUS(w)((w)>>8) // fixes the WEXITSTATUS not declared on FreeBSD
++#endif
+
+ /**************************************************************************
+ system-level utility functions
+@@ -778,23 +787,27 @@
+ char fname[200]; // null-terminated file name within directory
+ };
+
++ int f, kq, nev;
++ struct kevent change;
++ struct kevent event;
++
+ inotify_event evbuff;
+ struct timeval waitime;
+ fd_set fids;
+ int wd, retval, cc, fcc;
+- int evbcc = sizeof(evbuff);
++ int evbcc = sizeof(event);
+ static int fid = -1;
+
+ if (strEqu(action,"open")) // setup a monitored directory
+ {
+- fid = inotify_init();
+- if (fid < 0) {
++ f = kqueue();
++ if (f < 0) {
+ return -1;
+ }
+- wd = inotify_add_watch(fid,dirk,IN_ALL_EVENTS);
++ wd = kevent(f, &change, 1, &event, 1, NULL);
+ if (wd < 0) {
+- close(fid);
+- fid = -1;
++ close(f);
++ f = -1;
+ return -1;
+ }
+ return 0;
+@@ -802,7 +815,7 @@
+
+ if (strEqu(action,"event")) // return pending event or zero
+ {
+- if (fid < 0) return -1;
++ if (f < 0) return -1;
+
+ if (file) {
+ if (*file) zfree(*file); // free prior memory
+@@ -816,12 +829,12 @@
+ waitime.tv_sec = 0;
+ waitime.tv_usec = 1;
+
+- retval = select(fid+1, &fids, null, null, &waitime);
++ retval = select(f+1, &fids, null, null, &waitime);
+ if (retval == 0) return 0; // nothing pending
+
+ if (retval == -1) { // error
+ close(fid);
+- fid = -1;
++ f = -1;
+ return -1;
+ }
+
+@@ -832,28 +845,21 @@
+ return -1;
+ }
+
+- fcc = evbuff.len;
+- if (fcc > 199) return -1;
+- if (fcc > 0 && file)
+- *file = strdupz(evbuff.fname,0,"zmondirk_file"); // return filename v.3.5
+-
+- if (evbuff.mask & (IN_CREATE | IN_MOVED_TO)) // file was added
++ if (event.fflags & (NOTE_WRITE | NOTE_RENAME)) // file was added
+ return 1;
+- if (evbuff.mask & (IN_CLOSE_WRITE | IN_CLOSE_NOWRITE | IN_MODIFY)) // file was possibly added
++ if (event.fflags & (NOTE_EXIT | NOTE_REVOKE | NOTE_ATTRIB)) // file was possibly added
+ return 1;
+- if (evbuff.mask & (IN_DELETE | IN_MOVED_FROM)) // file was deleted
++ if (event.fflags & (NOTE_DELETE)) // file was deleted
+ return 2;
+- if (evbuff.mask & (IN_DELETE_SELF | IN_MOVE_SELF)) // monitored directory gone
+- return 3;
+ return 9; // other
+ }
+ }
+
+ if (strEqu(action,"close")) // stop monitoring
+ {
+- if (fid > -1) retval = close(fid);
++ if (f > -1) retval = close(f);
+ else retval = -1;
+- fid = -1;
++ f = -1;
+ return retval;
+ }
+
+@@ -2983,7 +2989,7 @@
+ strcpy(zicondir,zdatadir);
+ strcat(zicondir,"/icons");
+
+- pp = cuserid(0);
++ pp = getlogin();
+ if (strEqu(pp,"root")) snprintf(zuserdir,199,"/root/.%s",zappname); // get /root/.appname
+ else snprintf(zuserdir,199,"%s/.%s",getenv("HOME"),zappname); // or /home/user/.appname
+
diff --git a/graphics/fotoxx/files/patch-zfuncs.h b/graphics/fotoxx/files/patch-zfuncs.h
new file mode 100644
index 000000000000..4cfd1a9c6209
--- /dev/null
+++ b/graphics/fotoxx/files/patch-zfuncs.h
@@ -0,0 +1,17 @@
+--- zfuncs.h.orig 2011-02-28 17:04:24.000000000 +0100
++++ zfuncs.h 2011-05-25 17:50:21.000000000 +0200
+@@ -36,7 +36,13 @@
+ #include <signal.h>
+ #include <execinfo.h>
+ #include <locale.h>
+-#include <sys/inotify.h>
++
++#ifdef __linux__
++ #include <sys/inotify.h>
++#elif defined(__FreeBSD__)
++ #include <sys/event.h>
++ #include <sys/types.h>
++#endif
+
+ #define int8 char // number types
+ #define int16 short
diff --git a/graphics/fotoxx/pkg-descr b/graphics/fotoxx/pkg-descr
new file mode 100644
index 000000000000..fec6f11dd4c8
--- /dev/null
+++ b/graphics/fotoxx/pkg-descr
@@ -0,0 +1,5 @@
+Fotoxx is a free open source Linux program for photo editing
+and collection management. The goal is to meet most user needs
+while remaining fast and easy to use.
+
+WWW: http://kornelix.squarespace.com/fotoxx
diff --git a/graphics/fotoxx/pkg-plist b/graphics/fotoxx/pkg-plist
new file mode 100644
index 000000000000..e73d86c54827
--- /dev/null
+++ b/graphics/fotoxx/pkg-plist
@@ -0,0 +1,98 @@
+@comment $FreeBSD$
+bin/fotoxx
+%%DATADIR%%/icons/arrow.png
+%%DATADIR%%/icons/busy.png
+%%DATADIR%%/icons/drag.png
+%%DATADIR%%/icons/draw.png
+%%DATADIR%%/icons/first-page.png
+%%DATADIR%%/icons/folder.png
+%%DATADIR%%/icons/folder256.png
+%%DATADIR%%/icons/fotoxx.png
+%%DATADIR%%/icons/gallery.png
+%%DATADIR%%/icons/help.png
+%%DATADIR%%/icons/last-page.png
+%%DATADIR%%/icons/next-page.png
+%%DATADIR%%/icons/next-row.png
+%%DATADIR%%/icons/next.png
+%%DATADIR%%/icons/open.png
+%%DATADIR%%/icons/prev-page.png
+%%DATADIR%%/icons/prev-row.png
+%%DATADIR%%/icons/prev.png
+%%DATADIR%%/icons/print.png
+%%DATADIR%%/icons/quit.png
+%%DATADIR%%/icons/redo.png
+%%DATADIR%%/icons/save.png
+%%DATADIR%%/icons/saveas.png
+%%DATADIR%%/icons/trash.png
+%%DATADIR%%/icons/undo.png
+%%DATADIR%%/icons/zoom+.png
+%%DATADIR%%/icons/zoom-.png
+%%DOCSDIR%%/userguide-en.html
+%%DOCSDIR%%/freshmeat
+%%DOCSDIR%%/fotoxx.man
+%%DOCSDIR%%/TRANSLATIONS
+%%DOCSDIR%%/README
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/CHANGES
+%%DOCSDIR%%/images/HDF-paint.jpg
+%%DOCSDIR%%/images/HDR-adjust.jpg
+%%DOCSDIR%%/images/annotate.jpg
+%%DOCSDIR%%/images/brightness-color.jpg
+%%DOCSDIR%%/images/brightness-ramp.png
+%%DOCSDIR%%/images/edit-tags.jpg
+%%DOCSDIR%%/images/expand-brightness.png
+%%DOCSDIR%%/images/gallery image selection.jpg
+%%DOCSDIR%%/images/manage-tags.jpg
+%%DOCSDIR%%/images/navigation.jpeg
+%%DOCSDIR%%/images/pano-dialog.jpeg
+%%DOCSDIR%%/images/rename.jpeg
+%%DOCSDIR%%/images/save-as.jpeg
+%%DOCSDIR%%/images/search-images.jpg
+%%DOCSDIR%%/images/select-area.png
+%%DOCSDIR%%/images/select-whole-image.jpg
+%%DOCSDIR%%/images/select_edit.jpg
+%%DOCSDIR%%/images/sharpen.jpeg
+%%DOCSDIR%%/images/smart-erase.png
+%%DOCSDIR%%/images/stack.png
+%%DOCSDIR%%/images/tone-mapping.png
+%%DOCSDIR%%/images/trim.jpg
+%%DOCSDIR%%/images/watermark.jpg
+%%DATADIR%%/locales/de/fotoxx.po
+%%DATADIR%%/locales/de/zfuncs.po
+%%DATADIR%%/locales/en/fotoxx.po
+%%DATADIR%%/locales/en/zfuncs.po
+%%DATADIR%%/locales/es/fotoxx.po
+%%DATADIR%%/locales/es/zfuncs.po
+%%DATADIR%%/locales/fr/fotoxx.po
+%%DATADIR%%/locales/fr/fotoxx.po.old
+%%DATADIR%%/locales/fr/zfuncs.po
+%%DATADIR%%/locales/gl/fotoxx.po
+%%DATADIR%%/locales/gl/zfuncs.po
+%%DATADIR%%/locales/it/fotoxx.po
+%%DATADIR%%/locales/it/zfuncs.po
+%%DATADIR%%/locales/nl/fotoxx.po
+%%DATADIR%%/locales/nl/zfuncs.po
+%%DATADIR%%/locales/pt/fotoxx.po
+%%DATADIR%%/locales/pt/zfuncs.po
+%%DATADIR%%/locales/ru/fotoxx.po
+%%DATADIR%%/locales/ru/zfuncs.po
+%%DATADIR%%/locales/sv/fotoxx.po
+%%DATADIR%%/locales/sv/zfuncs.po
+%%DATADIR%%/locales/zh_CN/fotoxx.po
+%%DATADIR%%/locales/zh_CN/zfuncs.po
+@dirrm %%DOCSDIR%%/images
+@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/locales/de
+@dirrm %%DATADIR%%/locales/en
+@dirrm %%DATADIR%%/locales/es
+@dirrm %%DATADIR%%/locales/fr
+@dirrm %%DATADIR%%/locales/gl
+@dirrm %%DATADIR%%/locales/it
+@dirrm %%DATADIR%%/locales/nl
+@dirrm %%DATADIR%%/locales/pt
+@dirrm %%DATADIR%%/locales/ru
+@dirrm %%DATADIR%%/locales/sv
+@dirrm %%DATADIR%%/locales/zh_CN
+@dirrm %%DATADIR%%/locales
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%