aboutsummaryrefslogtreecommitdiff
path: root/graphics/founts
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-05-06 14:30:38 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-05-06 14:30:38 +0000
commit4901195b5e6b1f02b40e42c82f6d0305749096dc (patch)
treec2eb8e8e681e6d31f6f88e4e457f258a0e9b4725 /graphics/founts
parent718a11de69394f3cef3ece3a8fc5a51595ea470f (diff)
downloadports-4901195b5e6b1f02b40e42c82f6d0305749096dc.tar.gz
ports-4901195b5e6b1f02b40e42c82f6d0305749096dc.zip
Notes
Diffstat (limited to 'graphics/founts')
-rw-r--r--graphics/founts/Makefile40
-rw-r--r--graphics/founts/distinfo2
-rw-r--r--graphics/founts/pkg-descr3
3 files changed, 45 insertions, 0 deletions
diff --git a/graphics/founts/Makefile b/graphics/founts/Makefile
new file mode 100644
index 000000000000..8874e9456e85
--- /dev/null
+++ b/graphics/founts/Makefile
@@ -0,0 +1,40 @@
+# New Ports collection makefile for: founts
+# Date created: 2012-05-01
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= founts
+PORTVERSION= 12
+CATEGORIES= graphics games
+MASTER_SITES= http://www.linuxmotors.com/founts/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= A demo/program inspired by Erics cascade
+
+LICENSE= GPLv2
+
+USE_SDL= sdl
+
+PLIST_FILES= bin/founts
+
+PORTDOCS= Changelog README
+
+do-build:
+ cd ${WRKSRC} && ${CC} -o ${PORTNAME} ${CFLAGS} \
+ -lm `${SDL_CONFIG} --cflags --libs` founts.c
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/founts/distinfo b/graphics/founts/distinfo
new file mode 100644
index 000000000000..c6a59688bef5
--- /dev/null
+++ b/graphics/founts/distinfo
@@ -0,0 +1,2 @@
+SHA256 (founts-12.tgz) = 46da7a97eef91c162c946914dc81ab523963b4a5faebdf2bfd8482f32a485a8a
+SIZE (founts-12.tgz) = 21447
diff --git a/graphics/founts/pkg-descr b/graphics/founts/pkg-descr
new file mode 100644
index 000000000000..95ab0dd37741
--- /dev/null
+++ b/graphics/founts/pkg-descr
@@ -0,0 +1,3 @@
+The Founts is a demo/program, which was inspired by Eric's Cascade.
+
+WWW: http://www.linuxmotors.com/founts/