aboutsummaryrefslogtreecommitdiff
path: root/graphics/fracplanet/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-18 21:19:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-18 21:19:46 +0000
commitbdd5b1bf197e3250f4aeace796d3d293f7a2a419 (patch)
tree2f66a17817ffbd3c4c0ed66c5e1184d17a6943ab /graphics/fracplanet/Makefile
parent09c657820f70d87959c2be8819d8531a1f3bea89 (diff)
downloadports-bdd5b1bf197e3250f4aeace796d3d293f7a2a419.tar.gz
ports-bdd5b1bf197e3250f4aeace796d3d293f7a2a419.zip
Notes
Diffstat (limited to 'graphics/fracplanet/Makefile')
-rw-r--r--graphics/fracplanet/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/graphics/fracplanet/Makefile b/graphics/fracplanet/Makefile
new file mode 100644
index 000000000000..c374a02bbba8
--- /dev/null
+++ b/graphics/fracplanet/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: fracplanet
+# Date created: 15 Sep 2005
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fracplanet
+PORTVERSION= 0.2.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= An interactive generator of planets and terrain
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+
+USE_REINPLACE= yes
+USE_GL= yes
+USE_QT_VER= 3
+USE_X_PREFIX= yes
+MAKE_ENV= QTDIR="${X11BASE}" QMAKESPEC="${QMAKESPEC}" VERSION_NUMBER="${PORTVERSION}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+QMAKE?= ${LOCALBASE}/bin/qmake
+QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= fracplanet.htm fracplanet.css
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build on FreeBSD 4.x"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|%%PREFIX%%|${PREFIX}|g; s|%%DOCSDIR%%|${DOCSDIR}|g' \
+ ${WRKSRC}/${PORTNAME}.pro
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.ifndef (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>