aboutsummaryrefslogtreecommitdiff
path: root/graphics/fracplanet
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /graphics/fracplanet
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'graphics/fracplanet')
-rw-r--r--graphics/fracplanet/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/fracplanet/Makefile b/graphics/fracplanet/Makefile
index 7f3d2a37cb34..4bb6427b5d0e 100644
--- a/graphics/fracplanet/Makefile
+++ b/graphics/fracplanet/Makefile
@@ -23,10 +23,9 @@ LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= gmake
+USES= gmake qmake:no_env qt:4
USE_GL= glu
-USE_QT4= corelib moc_build qmake_build gui opengl
-QT_NONSTANDARD= yes
+USE_QT= corelib moc_build qmake_build gui opengl
HAS_CONFIGURE= yes
CONFIGURE_ENV= QTDIR="${PREFIX}"
CONFIGURE_ARGS= -spec ${QMAKESPEC}