aboutsummaryrefslogtreecommitdiff
path: root/graphics/fractorama/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-04 16:02:12 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-04 16:02:12 +0000
commit45f798531af74946d50b65406f85abf0fcf90e9c (patch)
tree596d89cfe28c6432cb5149ab6bcba360493d2f53 /graphics/fractorama/Makefile
parente654603e95c01d436ad460461511a1df017660ea (diff)
downloadports-45f798531af74946d50b65406f85abf0fcf90e9c.tar.gz
ports-45f798531af74946d50b65406f85abf0fcf90e9c.zip
Notes
Diffstat (limited to 'graphics/fractorama/Makefile')
-rw-r--r--graphics/fractorama/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/graphics/fractorama/Makefile b/graphics/fractorama/Makefile
index dc2d179746ac..34af7c86c934 100644
--- a/graphics/fractorama/Makefile
+++ b/graphics/fractorama/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= fractorama
-PORTVERSION= 1.6.5
-PORTREVISION= 1
+PORTVERSION= 1.6.7
CATEGORIES= graphics
MASTER_SITES= http://fractorama.com/
DISTNAME= ${PORTNAME}
@@ -16,8 +15,6 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fractal generation program
-BROKEN= "Checksum mismatch"
-
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_QT_VER= 3
@@ -31,11 +28,11 @@ ALL_TARGET= release
post-patch:
@${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|gcc|\$${CC}|g ; \
- s|g++|\$${CXX}|g ; \
- s|-L[$$][{]QTROOT[}]/lib -lqt|-lqt-mt \$${QTCFGLIBS}|g ; \
- s|-I[$$][{]QTROOT[}]/include|\$${QTCPPFLAGS}|g ; \
- s|-O2|\$${CFLAGS}|g'
+ 's|gcc|$${CC}|g ; \
+ s|g++|$${CXX}|g ; \
+ s|-L$${QTROOT}/lib -lqt|-lqt-mt $${QTCFGLIBS}|g ; \
+ s|-I$${QTROOT}/include|$${QTCPPFLAGS}|g ; \
+ s|-O2|$${CFLAGS}|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../fractorama.exe ${PREFIX}/bin/fractorama