aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-04-16 00:37:31 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-04-16 00:37:31 +0000
commit1c4eec3721d357c59a14019678ca3223eb3007ca (patch)
tree745c444948ea56f1cb6a431b798686a2d0c18101 /graphics/freeimage
parent06507e1078a553e6bff19edd8a7da351346ed400 (diff)
downloadports-1c4eec3721d357c59a14019678ca3223eb3007ca.tar.gz
ports-1c4eec3721d357c59a14019678ca3223eb3007ca.zip
graphics/freeimage: unbreak consumers on arm* with NEON
$ echo 'int main() {}' | cc -xc - -o /dev/null -L/usr/local/lib -lfreeimage -lm /usr/local/lib/libfreeimage.so: undefined reference to `png_init_filter_functions_neon' cc: error: linker command failed with exit code 1 (use -v to see invocation)
Notes
Notes: svn path=/head/; revision=467449
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index bbf7d4e6a1fa..371db8b157e7 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -3,7 +3,7 @@
PORTNAME= freeimage
PORTVERSION= 3.16.0
-PORTREVISION= 4
+PORTREVISION= 5
# Version 3.17.0 is available, but does not build on i386 (and probably
# other 32-bit arches) without some not-quite-trivial patching. If one
# decides to update the port, please make sure 32-bit builds are tested!
@@ -22,7 +22,7 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/FreeImage
MAKE_ARGS= CC="${CC}" CPP="${CPP}" CXX="${CXX}"
-CFLAGS+= -fexceptions -fvisibility=hidden
+CFLAGS+= -DPNG_ARM_NEON_OPT=0 -fexceptions -fvisibility=hidden
CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
CFLAGS_armv7= -fPIC