aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-12-03 16:29:37 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-12-03 16:29:37 +0000
commita5f3f72336039c5c44b17c3f2de03bd52eaa2496 (patch)
treeddba84ea9a3655500e21bb010e4d583ec2cb9163 /graphics/freeimage
parent14d4ea63159f3bb490f50d87a1048f47b7121314 (diff)
downloadports-a5f3f72336039c5c44b17c3f2de03bd52eaa2496.tar.gz
ports-a5f3f72336039c5c44b17c3f2de03bd52eaa2496.zip
- Remove dependency on memalign
PR: 129388 Submitted by: Jacob Atzen <jatzen@gmail.com>
Notes
Notes: svn path=/head/; revision=223731
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile1
-rw-r--r--graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h12
2 files changed, 13 insertions, 0 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 4eb60affa4d7..9fde17f47040 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freeimage
PORTVERSION= 3.11.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF
DISTNAME= FreeImage${PORTVERSION:S/.//g}
diff --git a/graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h b/graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h
new file mode 100644
index 000000000000..fc4362a3b6fd
--- /dev/null
+++ b/graphics/freeimage/files/patch-Source-LibOpenJPEG_opj_malloc.h
@@ -0,0 +1,12 @@
+--- Source/LibOpenJPEG/opj_malloc.h.orig 2008-12-03 16:48:35.000000000 +0100
++++ Source/LibOpenJPEG/opj_malloc.h 2008-12-03 16:49:08.000000000 +0100
+@@ -77,7 +77,9 @@
+ #define HAVE_MEMALIGN
+ /* Linux x86_64 and OSX always align allocations to 16 bytes */
+ #elif !defined(__amd64__) && !defined(__APPLE__)
++ #ifndef __FreeBSD__
+ #define HAVE_MEMALIGN
++ #endif
+ #include <malloc.h>
+ #endif
+ #endif