aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-12 08:49:38 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-12 08:49:38 +0000
commita666d7948a609df6e47d4b1f8f654c25cbf7a001 (patch)
tree33c063aec21dc182ab7e6f1b781913b7e070724f /graphics/freeimage
parent43aff4e4b9c7e69dae40c9faeca049a6c9e986ac (diff)
downloadports-a666d7948a609df6e47d4b1f8f654c25cbf7a001.tar.gz
ports-a666d7948a609df6e47d4b1f8f654c25cbf7a001.zip
Notes
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile28
-rw-r--r--graphics/freeimage/distinfo4
2 files changed, 15 insertions, 17 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 0b62abc5566d..c2ea2b4b4eff 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= freeimage
-PORTVERSION= 3.15.4
-PORTREVISION= 3
+PORTVERSION= 3.16.0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Source%20Distribution/${PORTVERSION}
DISTNAME= FreeImage${PORTVERSION:S/.//g}
@@ -11,13 +10,14 @@ DISTNAME= FreeImage${PORTVERSION:S/.//g}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Simple C/C++ bitmap graphics library
-USES= gmake dos2unix zip
+USES= dos2unix gmake zip
DOS2UNIX_FILES= Source/LibOpenJPEG/opj_malloc.h
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/FreeImage
MAKE_ARGS= CC="${CC}" CPP="${CPP}" CXX="${CXX}"
CFLAGS+= -fexceptions -fvisibility=hidden
+CFLAGS_amd64= -fPIC
PLIST_FILES= include/FreeImage.h \
include/FreeImagePlus.h \
@@ -30,22 +30,20 @@ PLIST_FILES= include/FreeImage.h \
lib/libfreeimageplus.so.3 \
lib/libfreeimageplus.so
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-CFLAGS+= -fPIC
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}| ; s|-o root -g root ||' \
${WRKSRC}/Makefile.gnu ${WRKSRC}/Makefile.fip
post-build:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} -f Makefile.fip ${_MAKE_JOBS} ${MAKE_ARGS}
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -f Makefile.fip ${_MAKE_JOBS} \
+ ${MAKE_ARGS} -C ${BUILD_WRKSRC}
post-install:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} -f Makefile.fip ${MAKE_ARGS} ${INSTALL_TARGET}
- ${LN} -s libfreeimageplus.so.3 ${STAGEDIR}${PREFIX}/lib/libfreeimageplus.so
- ${LN} -s libfreeimageplus-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libfreeimageplus.so.3
-
-.include <bsd.port.post.mk>
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -f Makefile.fip ${MAKE_ARGS} \
+ -C ${INSTALL_WRKSRC} ${INSTALL_TARGET}
+ ${LN} -sf libfreeimageplus.so.3 \
+ ${STAGEDIR}${PREFIX}/lib/libfreeimageplus.so
+ ${LN} -sf libfreeimageplus-${PORTVERSION}.so \
+ ${STAGEDIR}${PREFIX}/lib/libfreeimageplus.so.3
+
+.include <bsd.port.mk>
diff --git a/graphics/freeimage/distinfo b/graphics/freeimage/distinfo
index 184c358131df..45f906522e1c 100644
--- a/graphics/freeimage/distinfo
+++ b/graphics/freeimage/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FreeImage3154.zip) = eb6361519d33131690a0e726b085a05825e5adf9fb72c752d8d39100e48dc829
-SIZE (FreeImage3154.zip) = 5513923
+SHA256 (FreeImage3160.zip) = 03af32dd60140d07515ddfe7b4f467baa3b888a72ea78828811aded7adb42f60
+SIZE (FreeImage3160.zip) = 5669228