aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-04-15 23:57:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-04-15 23:57:59 +0000
commit7a15de116847795e800251b6a5c2016442a9df86 (patch)
tree99a4cb3f2a768a144f6d552b2b175bd5e6e4c9dc /graphics/freeimage
parent1ce36a57d28a068a363a07f89108d87dd7f4dba6 (diff)
downloadports-7a15de116847795e800251b6a5c2016442a9df86.tar.gz
ports-7a15de116847795e800251b6a5c2016442a9df86.zip
graphics/freeimage: unbreak on armv7
/usr/bin/ld: ./Source/FreeImage/BitmapAccess.o(.text+0x2d0): unresolvable R_ARM_MOVW_ABS_NC relocation against symbol `_ZSt7nothrow' /usr/bin/ld: final link failed: Nonrepresentable section on output cc: error: linker command failed with exit code 1 (use -v to see invocation)
Notes
Notes: svn path=/head/; revision=467443
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index f0921ee707be..bbf7d4e6a1fa 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -25,6 +25,7 @@ MAKE_ARGS= CC="${CC}" CPP="${CPP}" CXX="${CXX}"
CFLAGS+= -fexceptions -fvisibility=hidden
CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
+CFLAGS_armv7= -fPIC
PLIST_FILES= include/FreeImage.h \
include/FreeImagePlus.h \