aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-07-01 20:24:50 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-07-01 20:24:50 +0000
commitd7ec45064c0044b54186aa1bd03ef589ec1fffa7 (patch)
tree90c49335680188e33d00ca4a9fbb7aef99846463 /graphics/freeimage
parentbdb767c4d79e5ee17bb4c3945e217c8c0018a0b2 (diff)
downloadports-d7ec45064c0044b54186aa1bd03ef589ec1fffa7.tar.gz
ports-d7ec45064c0044b54186aa1bd03ef589ec1fffa7.zip
- Update to 3.12.0
Notes
Notes: svn path=/head/; revision=236880
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile11
-rw-r--r--graphics/freeimage/distinfo6
-rw-r--r--graphics/freeimage/files/patch-Makefile.gnu59
3 files changed, 9 insertions, 67 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 9fde17f47040..d517c6a70b3b 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freeimage
-PORTVERSION= 3.11.0
-PORTREVISION= 1
+PORTVERSION= 3.12.0
CATEGORIES= graphics
MASTER_SITES= SF
DISTNAME= FreeImage${PORTVERSION:S/.//g}
@@ -30,11 +29,13 @@ CFLAGS+= -fPIC
PLIST_FILES= include/FreeImage.h \
lib/libfreeimage.a \
- lib/libfreeimage.so \
- lib/libfreeimage.so.3
+ lib/libfreeimage-3.12.0.so
post-patch:
${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g'
- ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile.gnu
+ ${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g; s|-g root|-g wheel|g' ${WRKSRC}/Makefile.gnu
+
+post-install:
+ ${LN} -f ${PREFIX}/lib/libfreeimage-3.12.0.so ${PREFIX}/lib/libfreeimage.so.3
.include <bsd.port.post.mk>
diff --git a/graphics/freeimage/distinfo b/graphics/freeimage/distinfo
index 06e039627588..e8d69a8a2850 100644
--- a/graphics/freeimage/distinfo
+++ b/graphics/freeimage/distinfo
@@ -1,3 +1,3 @@
-MD5 (FreeImage3110.zip) = ad1db36414391417654ba7bf1c0277d3
-SHA256 (FreeImage3110.zip) = 84021b8c0b86e5801479474ad9a99c18d121508ee16d363e02ddcbf24195340c
-SIZE (FreeImage3110.zip) = 4250382
+MD5 (FreeImage3120.zip) = 47b259102f776a4bcd7affc00942f3b4
+SHA256 (FreeImage3120.zip) = a431fccbfd7c06fd32155b39361d520a710ee878440cca3e11706c0bd1ae6cc3
+SIZE (FreeImage3120.zip) = 4335135
diff --git a/graphics/freeimage/files/patch-Makefile.gnu b/graphics/freeimage/files/patch-Makefile.gnu
deleted file mode 100644
index 7f8ac1a92a4c..000000000000
--- a/graphics/freeimage/files/patch-Makefile.gnu
+++ /dev/null
@@ -1,59 +0,0 @@
---- Makefile.gnu.orig 2008-09-24 22:28:31.000000000 +0200
-+++ Makefile.gnu 2008-09-24 22:34:35.000000000 +0200
-@@ -4,17 +4,17 @@
- include Makefile.srcs
-
- # General configuration variables:
--CC = gcc
--CXX = g++
-+CC ?= gcc
-+CXX ?= g++
- AR = ar
-
--INCDIR = /usr/include
--INSTALLDIR = /usr/lib
-+INCDIR = %%PREFIX%%/include
-+INSTALLDIR = %%PREFIX%%/lib
-
- # Converts cr/lf to just lf
- DOS2UNIX = dos2unix
-
--COMPILERFLAGS = -O3 -fPIC -fexceptions -fvisibility=hidden
-+COMPILERFLAGS := ${CFLAGS}
- LIBRARIES = -lstdc++
-
- MODULES = $(SRCS:.c=.o)
-@@ -24,7 +24,7 @@
-
- TARGET = freeimage
- STATICLIB = lib$(TARGET).a
--SHAREDLIB = lib$(TARGET)-$(VER_MAJOR).$(VER_MINOR).so
-+SHAREDLIB = lib$(TARGET).so.$(VER_MAJOR)
- LIBNAME = lib$(TARGET).so
- VERLIBNAME = $(LIBNAME).$(VER_MAJOR)
- HEADER = Source/FreeImage.h
-@@ -37,7 +37,7 @@
-
- dist: FreeImage
- cp *.a Dist
-- cp *.so Dist
-+ cp *.so.* Dist
- cp Source/FreeImage.h Dist
-
- dos2unix:
-@@ -58,12 +58,10 @@
- $(CC) -s -shared -Wl,-soname,$(VERLIBNAME) -o $@ $(MODULES) $(LIBRARIES)
-
- install:
-- install -m 644 -o root -g root $(HEADER) $(INCDIR)
-- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
-- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
-- ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(VERLIBNAME)
-+ install -m 644 -o root -g wheel $(HEADER) $(INCDIR)
-+ install -m 644 -o root -g wheel $(STATICLIB) $(INSTALLDIR)
-+ install -m 755 -o root -g wheel $(SHAREDLIB) $(INSTALLDIR)
- ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
-- ldconfig
-
- clean:
- rm -f core Dist/*.* u2dtmp* $(MODULES) $(STATICLIB) $(SHAREDLIB) $(LIBNAME)